none
Disable Autologon RRS feed

  • Question

  • We have one limited-access machine set up with the old Shared Computer Toolkit, I'm trying to replicate the settings with SteadyState. I'd like the computer to boot to the welcome screen, with only the Public user (no password) available. 

    With the SCT, it boots right to the welcome screen so a patron can click to logon and have the timer start for their session. With SS, it boots into the Public login.

    I've tried registry hacks and even the old SCT DOS tools (which iirc is what I used when setting up the SCT machine), nothing seems to be working. Help!

    (Note: I obviously urge the team to make sure the Welcome screen works in the next version, after reading it's disabled in 2.5!!)
    Tuesday, February 26, 2008 4:45 PM

Answers

  • There is another workaround, using hidden accounts to stop autologon. As you know, if you have more than 1 account to logon to, then XP shows the choices on the Welcome screen.

     

    However, if you have installed the .net framework (which most do for compatibility), then it creates a 'hidden' user account something like "ASPnet" - by default this account is hidden from view, but still counts as an alternative account, and therefore stops the welcome screen from autologging on (which still only shows your single 'real' user account)

     

    You can actively change whether this 'ASPnet' account should be included in the welcome screen calculations by using TweakUI v2.10, and going down to the 'logon' section, and selecting that the 'ASPnet' user be made visible (don't worry, it won't show up on the screen). By enabling this user, it stops the welcome screen from autologging on.

     

    I found this issue/workaround as I always want a welcome autologon, and found that it always stopped after installing the .NET framework v1 or v2 (I always install both, so I cannot tell which actually creates this account) - so I always have to remove the 'ASPnet' user from the logon list to re-enable welcome auto logon capability.

     

    There might be a way more simple way, by simply creating a similar system account to that of the 'ASPnet' one - but I haven't ever investigated.

     

    Hope that this helps

    Cheers

    Steve

     

     

     

    Friday, February 29, 2008 9:03 AM

All replies

  • Hi,

     

    Thanks for posting here.

     

    After checking the post, I understand that you would like to disable Auto Logon and use the welcome screen for public users.

     

    Firstly, I'd like to inform you that Auto logging on is caused by your system configurations instead of SteadyState settings. This is an normal behavior if you configure some user account log on automatically. You can hold on Shift key when the Welcome screen appears. Auto logon will be interrupted. After that, we can log on with an administrator account to make changes. 

     

    If you would like to disable auto logon, you can perform the steps below:

    ----------------

    1. Click "Start", click "Run", type in "control userpasswords2" and press Enter.

    2. Select "Users must enter a username and password to use this computer" check box. Click "Apply".

     

    Note: If you have Windows Disk Protection (WDP) enabled, please change it to “Retain all changes permanently” to save changes.

     

    Regarding the welcome screen issue, unfortunately, this is a known issue of this beta version. You can refer to the following Readme File:

     

    Windows SteadyState 2.5 Beta Readme File

     

    http://download.microsoft.com/download/E/2/F/E2F23589-E8E1-404F-9DAB-77F1CAE24153/ReadmeBeta.txt

     

    -------------------------------------------------------------------------------

    2.2 Welcome screen does not display on Windows XP

    -------------------------------------------------------------------------------

     

    The Welcome screen is not supported with Windows SteadyState on shared computers running Windows XP.

     

    WORKAROUND: To log on, press CTL+ALT+DELETE. Type your name and password, and then click OK.

     

    Our product team is still working on the new version. If there is any update, I will post here soon.

     

    Best regards,

     

    Wednesday, February 27, 2008 6:11 AM
    Moderator
  • Yeah, I had already tried that. Check box was already checked. I unchecked, hit Apply, rechecked and hit Apply just to see if it would reset something. Still autologging on.
    Wednesday, February 27, 2008 3:11 PM
  • So...?
    Thursday, February 28, 2008 2:22 PM
  • There is another workaround, using hidden accounts to stop autologon. As you know, if you have more than 1 account to logon to, then XP shows the choices on the Welcome screen.

     

    However, if you have installed the .net framework (which most do for compatibility), then it creates a 'hidden' user account something like "ASPnet" - by default this account is hidden from view, but still counts as an alternative account, and therefore stops the welcome screen from autologging on (which still only shows your single 'real' user account)

     

    You can actively change whether this 'ASPnet' account should be included in the welcome screen calculations by using TweakUI v2.10, and going down to the 'logon' section, and selecting that the 'ASPnet' user be made visible (don't worry, it won't show up on the screen). By enabling this user, it stops the welcome screen from autologging on.

     

    I found this issue/workaround as I always want a welcome autologon, and found that it always stopped after installing the .NET framework v1 or v2 (I always install both, so I cannot tell which actually creates this account) - so I always have to remove the 'ASPnet' user from the logon list to re-enable welcome auto logon capability.

     

    There might be a way more simple way, by simply creating a similar system account to that of the 'ASPnet' one - but I haven't ever investigated.

     

    Hope that this helps

    Cheers

    Steve

     

     

     

    Friday, February 29, 2008 9:03 AM
  • Hi,

     

    Thanks for Steve’s input.

     

    It’s strange issue as others usually has problem enable Auto logon. By default SteadyState will not enable Auto logon.

     

    Can we temporary disable auto logon by pressing the Shift key when Windows log on. Just hold the shift key to check the result.

    Do you have WDP enabled?

     

    I would suggest create a new user or change the user’s password to check if there is any changes. As I know, if there is only one user account without password, it will auto logs on.

     

    Regards,

     

    Friday, February 29, 2008 12:16 PM
  • Steve,

    Thanks so much! When you mentioned the hidden user, I knew you had the solution. On the first machine, I had .NET installed, but for some reason it wasn't installed on this machine. I had already made the second user account and hidden it and couldn't figure out why that hadn't worked. Installed .NET and voila, boot to Welcome screen.

    Thanks to everyone for the help!
    - Odin
    Friday, February 29, 2008 5:51 PM