locked
Sub Projects & Project Centre RRS feed

  • Question

  • Hi, I have inserted sub-projects into a project plan. This has led to the inserted projects disappearing from the project centre. I wish to undo this change but am struggling.

    I have found this post from 2012. I have followed the instructions (removed the row from the master project, open the sub project and publish), but many projects are still not showing in project centre. Looking in "delete enterprise objects"  I see that 17 projects are identified as sub-projects. But 10 of these are showing in project centre even with the show sub-projects checkbox unchecked.

    How can i change the project from sub-project to project?

    Why are some sub-projects showing in project centre when the sub-projects checkbox is unchecked? 

    Wednesday, December 9, 2020 11:45 AM

Answers

  • !

    Hi Dale,

    I no longer needed these projects in the master project and also wanted them showing in project centre without having to have the sub-projects checkbox ticked.

    I have now managed to get these projects showing 'normally'.

    Firstly, i used the 'delete enterprise objects' page to quickly identify those projects that were still categorised as sub-projects. 

    Then I cleared the cache from Project desktop, opened each sub-project schedule and published. This worked for about 80%. Even repeated cleaning of the cache and publishing did not work for the remainder. FOr those, we had to make a minor edit to the schedule then publish. 

    Now all projects are identified as projects in "'delete enterprise objects" page and all are showing in project centre without the checkbox ticked.

    PS

    The reason i was creating a master project was to attempt to add tasks from multiple projects into a single row within the new Roadmap tool. Unfortunately my bright idea was not so bright as i could not connect a roadmap row to a master schedule...  


    Thursday, December 10, 2020 8:15 AM

All replies

  • rapscalli --

    Wow, you have gone to a lot of work trying to solve this problem.  The solution is to SELECT the Subprojects checkbox in the Show/Hide section of the Projects ribbon on the Project Center page.  I would recommend that you add your subprojects back to the master project, then save and publish it.  The subprojects should now show up in the Project Center page.  Hope this helps.


    Dale A. Howard [MVP]

    Wednesday, December 9, 2020 1:48 PM
  • !

    Hi Dale,

    I no longer needed these projects in the master project and also wanted them showing in project centre without having to have the sub-projects checkbox ticked.

    I have now managed to get these projects showing 'normally'.

    Firstly, i used the 'delete enterprise objects' page to quickly identify those projects that were still categorised as sub-projects. 

    Then I cleared the cache from Project desktop, opened each sub-project schedule and published. This worked for about 80%. Even repeated cleaning of the cache and publishing did not work for the remainder. FOr those, we had to make a minor edit to the schedule then publish. 

    Now all projects are identified as projects in "'delete enterprise objects" page and all are showing in project centre without the checkbox ticked.

    PS

    The reason i was creating a master project was to attempt to add tasks from multiple projects into a single row within the new Roadmap tool. Unfortunately my bright idea was not so bright as i could not connect a roadmap row to a master schedule...  


    Thursday, December 10, 2020 8:15 AM
  • rapscalli --

    Got it.  Like you, I also have had a few "brilliant" ideas that turned out to be not so bright.  :)


    Dale A. Howard [MVP]

    Thursday, December 10, 2020 1:52 PM