locked
Namespace sharing with 2003/2007 and external RRS feed

  • Question

  • Hi
    Our company all shares the same email namespace however each location is currently running its own AD domain.  Let's say the namespace is company.com.
    In our AD, we have one 2003 and two 2007 Exchange servers.  We have one 2003 Exchange and two 2007 Exchange servers.  In 2003 speak, the 2003 server is in it's own routing group and the two 2007 Exchange servers are in another.  There's a routing group connector between each in both directions.
    We have set the primary address to @company.com with the checkbox "This Exchange Organization is responsible for all mail delivery to this address" ticked.  If the @company.com recipient is not resolved within our AD, it gets forward onto the 3rd party email provider as we have set the provider for the option under the SMTP Virtual server (Messages tab) to "Forward all mail with unresolved recipients to host."
    The system is working fine.
    However, when we set up a contact from another office in the company in our AD with the address name@company.com, sending to that contact fails due to the object existing in our AD:
    "A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients.  Contact your administrator."
    We tried un-ticking the box  "This Exchange Organization is responsible for all mail delivery to this address" for company.com in the recipient policy but we found internal email went into the deferred delivery queue, emails destined for the journal mailbox (we use archiving) went to the external queue and users on the 2007 Exchange servers received 5.6.1 NDRs when trying to send internal emails.
    Currently in our AD, if an email is sent to a company.com address, since the organization is currently authoritative, it simply sends the email around until a recipient is found.  If the recipient isn't found, it sends out the external connector since the "Forward all mail with unresolved recipients to host." is enabled in the SMTP virtual server.
    However, if the organization isn't authoritative and since the RG and SMTP connectors don't have any cost, some mail will leave the organization even though it should have stayed internally.  However if we give the RG connectors priority then email will never flow out.  I'm thinking we need to have connectors configured with an address space somehow but not sure how it should configured.
    We'd like the final result to be:
    -if an internal email is sent from a 2003 mailbox to a 2007 mailbox, then it simply delivers to the specific 2007 server
    -if an internal email is sent from a 2007 mailbox to a 2003 mailbox, then it simply delivers to the 2003 server
    -if an email is sent from either the 2003 or 2007 servers for an external company.com user, then the email leaves the organization even if the company.com contact is in our AD
    Can anyone help?
    Thanks
    Thursday, September 8, 2011 1:53 AM

Answers


  • Hi,

    This error is caused by a routing loop. When a message exceeded maximum hops count, you will receive such NDR.

    To configure the sharing SMTP namespace, please use smarthost instead of the feature “Forward all mail with unresolved recipients to host”:

    1. Open SMTP virtual server, remove the server/IP from “Forward all mail with unresolved recipients to host” field.

    2. Un-ticking the box "This Exchange Organization is responsible for all mail delivery to this address" for company.com in the recipient policy.

    In sharing STMP namespace environment, the email first arrive at the non-Authoritative mail server. If the user does not exist in this server, this mail will be rerouted to next destination by using SMTP connector.

    3. Create new SMTP connector, in address space tab, type in 'Company.com'. In General tab, select “Forward all mail through this connector to the following smart hosts:” type in the IP address of your 3rd party email provider. [192.168.1.1].

    If you are using Exchange 2007 sent connector to deliver the external mails, please open EMC, expand to Organization configuration->Hub transport. In Send connectors tab, open the properties of your Send connector. In network tab, select route mail through the following smart host.

    Then test to see if the issue persists.

     


    • Edited by Gen Lin Tuesday, September 13, 2011 9:30 AM
    • Marked as answer by Gen Lin Friday, September 23, 2011 9:42 AM
    Tuesday, September 13, 2011 8:20 AM

All replies

  • What you're seeing is expected, however I don't understand the contact you're trying to set up. You mention "we set up a contact from another office in the company in our AD with the address name@company.com" This user is in the same Forest\Exchange org and has a mailbox and would be in the GAL? When you said each location is currently running it's own AD domain do you mean separate forest? If so that would make sense then. What you would need to do is create internal smtp addresses for each forest. @domain1.local @domain2.local @domain3.local. Then when you create the contact name@company.com, you add name@company.com as a proxy address but set the target address to @domain2.local.

    Then create SMTP connector for domain1.local.

    Also it's recommended to use an SMTP connector for the shared namespace routing as well and not the SMTP virtual server option "Forward all mail with unresolved recipients to host box"


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Thursday, September 8, 2011 2:32 PM

  • Hi,

    This error is caused by a routing loop. When a message exceeded maximum hops count, you will receive such NDR.

    To configure the sharing SMTP namespace, please use smarthost instead of the feature “Forward all mail with unresolved recipients to host”:

    1. Open SMTP virtual server, remove the server/IP from “Forward all mail with unresolved recipients to host” field.

    2. Un-ticking the box "This Exchange Organization is responsible for all mail delivery to this address" for company.com in the recipient policy.

    In sharing STMP namespace environment, the email first arrive at the non-Authoritative mail server. If the user does not exist in this server, this mail will be rerouted to next destination by using SMTP connector.

    3. Create new SMTP connector, in address space tab, type in 'Company.com'. In General tab, select “Forward all mail through this connector to the following smart hosts:” type in the IP address of your 3rd party email provider. [192.168.1.1].

    If you are using Exchange 2007 sent connector to deliver the external mails, please open EMC, expand to Organization configuration->Hub transport. In Send connectors tab, open the properties of your Send connector. In network tab, select route mail through the following smart host.

    Then test to see if the issue persists.

     


    • Edited by Gen Lin Tuesday, September 13, 2011 9:30 AM
    • Marked as answer by Gen Lin Friday, September 23, 2011 9:42 AM
    Tuesday, September 13, 2011 8:20 AM