locked
Where did my post go regarding PPTP MTU? RRS feed

  • Question

  • I created a thread in this group a few weeks ago asking how to change the MTU size of a PPTP connection in Windows 7 because the method described in 

    http://support.microsoft.com/kb/826159

    did not work for me in Windows 7, though it worked in Vista and in Windows XP.

    An MSFT person replied by saying that I should add an MTU entry to 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{ID}

    Where ID was replaced by the proper ID for the PPTP connection in question.

    I did this and it worked.  I replied with a thanks, but asked if there was an easy way to identify the correct ID since the name of the connection did not appear in the set of ID parameters.

    Now this entire thread is missing. (That is, a search for MTU or narnian1 in this forum, does not bring it up)

    Does anyone know why?
    • Edited by narnian1 Wednesday, March 18, 2009 10:09 PM
    Wednesday, March 18, 2009 10:02 PM

Answers

  • Hi,

    I cannot find the thread via search either. After view your profile information for this forum I found the thread.

    How do I change the PPTP MTU size?

    To determine which ID is your adapter ID, just click on it, in the right pane check if it has proper IP address and Default Gateway, DHCP server, etc.


    Arthur Xie - MSFT
    Friday, March 20, 2009 7:30 AM

All replies

  • OK.  I found the posting by manually looking through the forum.  But my question remains, why doesn't the search tool for this forum bring it up if you just enter MTU as a search term?
    Wednesday, March 18, 2009 10:08 PM
  • Hi,

    I cannot find the thread via search either. After view your profile information for this forum I found the thread.

    How do I change the PPTP MTU size?

    To determine which ID is your adapter ID, just click on it, in the right pane check if it has proper IP address and Default Gateway, DHCP server, etc.


    Arthur Xie - MSFT
    Friday, March 20, 2009 7:30 AM
  • Maybe it's because it contains the solution?!?!?! If all-alike answers to these-like questions are first to pop-up in the search results, then what would MSFT stuff do? :-P

     I'm busting my head for over a month with pptp issues, i tried everything and finaly realized that my problems got to do something with MTU...
    Wednesday, December 30, 2009 5:32 PM
  • I know this is old, but it seems to be high in google search results as well...

    ..there is a good how to for changing MTU in win 7 here as well:

    http://www.publicvpn.com/support/index.php


    Under Windows 7, the way you set a connection's MTU value has changed. To change it, do the following:

    ...do the following from an admin command line (hold down control and shift while running 'cmd':

     

    netsh interface ipv4 show subinterfaces

     

    Assuming your connection is named "PublicVPN.com PPTP" in the list of subinterfaces, do this:

     

    netsh interface ipv4 set subinterface "PublicVPN.com PPTP" mtu=1200

     

    To make sure it stuck, do this:

     

    netsh interface ipv4 show subinterfaces

     

    Then, reboot your computer for the setting to take effect.

    Wednesday, January 6, 2010 7:11 PM