none
IE9; Downloading a file; "Do you want to save" vs "Do you want to open or save" RRS feed

  • Question

  • Mighty all,

    I've searched the internet and this forum but cannot seem to find an answer. Some clients (IE9) do get the "save file" prompt instead of the expected "open or save" (see attached screenshots).

    Same page, same file, just different results from different clients. IE8 is not affected, only IE9.

    Does anyone has an idea what controls which type of the prompt will get displayed?

    Thanks in advance for your help!

    vs

    Friday, March 15, 2013 1:50 PM

Answers

  • Hi,

    Try this:
    Click start button, click Default Programs > Set your default programs. Click Internet Explorer and Choose defaults for this program.
    Uncheck .htm and click save.


    Tracy Cai
    TechNet Community Support

    • Marked as answer by Alex_zz Tuesday, March 19, 2013 12:45 PM
    Tuesday, March 19, 2013 6:11 AM
    Moderator

All replies

  • Friday, March 15, 2013 11:32 PM
  • Unfortunately this does not help: as I've stated above "Same page, same file, just different results from different clients".

    I've played with browser/document modes and it has not yielded anything :(

    Monday, March 18, 2013 8:17 AM
  • for questions about html, css and scripting please post to the IE Web Development forum... include in your question a link to your website and in your case the file extension of the file you are trying to download and the mime-type configuration of that file extension from your servers.

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads

    Probably, different results occur because of differences in settings of the client browsers...

    IE has security zone settings for

    mime-sniffing, 'unsafe' files and downloads in general...

    there is also a setting in Advanced options... uncheck "do not save encrypted files to disk"

    the first step in troubleshooting IE issues is to run in NoAddons mode....

    Second is to reset the IE Security zone settings....Internet Options>Security tab, click "Reset all zones to default"

    third is an IEReset which does all of the above + clears history and cookies.


    Rob^_^

    Monday, March 18, 2013 8:42 AM
  • Yes... It was more that before opening a premier support case I was just hoping to see if someone has seen something like this before. And thanks for the intro into IE troubleshooting :)

    Monday, March 18, 2013 8:48 AM
  • Hi,

    Try this:
    Click start button, click Default Programs > Set your default programs. Click Internet Explorer and Choose defaults for this program.
    Uncheck .htm and click save.


    Tracy Cai
    TechNet Community Support

    • Marked as answer by Alex_zz Tuesday, March 19, 2013 12:45 PM
    Tuesday, March 19, 2013 6:11 AM
    Moderator
  • As it did came from one of my colleagues, most likely is was taken from an RDP session :)
    Tuesday, March 19, 2013 12:37 PM
  • Wow, this seems to do the trick. Changing between IE/other browser who will open .html files reproduces the problem. Kudos to Tracy!
    Tuesday, March 19, 2013 12:44 PM