none
Folder Redirection 502 Access Denied but redirecting to wrong place

    Question

  • Hi,

    I have come across a very unusual problem.  Folder redirection was implemented a few months ago where a number of folders were redirected with the following settings:

    • Redirect everyones folder to the same location
    • Create a folder for each user under the root path
    • \\server\homefolders

    It has worked flawlessly but in recent weeks when we create new users, some of them experience this problem.  Folder redirection fails consistently for that user with 502 Access denied.  That isn't the unusual bit.  This is the unusual bit - The message is:

    Failed to apply policy and redirect folder "Documents" to "\\fileserver\homefolders\joe.bloggs\Documents".

    Redirection options=0x1001.

    The following error occurred: "Failed to build the list of regular subdirectories under "\\fileserver\homefolders\Jane.Doe\Documents".".

    Error details: "Access is denied.

    ".

    Yes for some reason it knows where it should be redirecting to, but then attempts to redirect to someone elses home folder location.  I've substituted the server name and user names for security but the name equivalent to Jane.Doe is consistent in every error.

    This only occurs on our RDS 2012 R2 farm, which has 3 session hosts and doesn't happen on any other system.  We use roaming profiles.  I have logged the user off and deleted the local and network profiles but get the same result.  I've rebuilt the GPO that handles folder redirection, but again, same result.  I've checked and double checked Folder Redirection settings and nothing points to a this specific Jane.Doe user.

    Anyone come across this before?

    Friday, March 27, 2015 3:39 PM

Answers

  • Rebuilding the hosts from scratch was implemented as a work around.  Never got to the bottom of what was causing the behaviour.
    • Marked as answer by The_Ronin_69 Friday, July 10, 2015 1:29 PM
    Friday, July 10, 2015 1:29 PM