locked
External Access RRS feed

  • Question

  • Dear All,

    We were trying to install one Terminal server. We installed all the role on one server (Web and gateway server). Internally RDP session for any computer works fine using rdweb, but we are facing issues with External connection

    When we open our published rdweb website i can see connect to PC option when i enter the ip address for the server. Its asks me for authetication after which it fails with the below error

    "Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to. Contact your Network Administrator for assistance."

    for testing i published rdweb and when i use it it works fine, but connect to PC option is still not working please help me with suggestions:


    Monday, October 16, 2017 1:49 PM

Answers

  • Hi,

    On the RDWeb server, please open IIS Manager, in the left pane navigate to and select Sites\ Default Web Site\ RDWeb\ Pages, in middle pane double-click Application Settings.  Please modify DefaultTSGateway and set it to the FQDN of your RD Gateway server.

    After making the above change please refresh the RDWeb page on the client PC and test the Connect to a remote PC tab again.

    Thanks.

    -TP

    • Proposed as answer by Amy Wang_ Tuesday, October 17, 2017 4:05 AM
    • Marked as answer by vgahod Tuesday, October 31, 2017 8:07 AM
    Monday, October 16, 2017 4:45 PM

All replies

  • Hi,

    On the RDWeb server, please open IIS Manager, in the left pane navigate to and select Sites\ Default Web Site\ RDWeb\ Pages, in middle pane double-click Application Settings.  Please modify DefaultTSGateway and set it to the FQDN of your RD Gateway server.

    After making the above change please refresh the RDWeb page on the client PC and test the Connect to a remote PC tab again.

    Thanks.

    -TP

    • Proposed as answer by Amy Wang_ Tuesday, October 17, 2017 4:05 AM
    • Marked as answer by vgahod Tuesday, October 31, 2017 8:07 AM
    Monday, October 16, 2017 4:45 PM
  • Hi,

    Please remember to mark useful reply as answer, which would be much more efficient for other forum community members to find useful information.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 23, 2017 2:30 AM