none
Windows 10 pro cannot RDP into Server 2012 r2 RRS feed

  • Question

  • Hello,

    I've searched all over but it seems no one has experienced the exact issue I'm seeing with a computer.  

    The user was previously set up to RDP into Server 2012 r2, using a gateway, with her older Windows 8 machine and never had any issues.  She is also able to RPD into Server 2012 r2 on her laptop without issue.  Her PC was just replaced with a new one with Windows 10 pro 64-bit installed and now, even though I used the same exact RDP settings, when she tries to login, she gets a "login failed" message.  Same thing happens when I try to use my own login (which I have been using with Windows 10 Pro without issue for over a year now) and I even went as far is using our test account.  

    Now I've tried the following without much success when comparing her new PC to the settings on my Windows 10 pro machine.

    Added the RPD app to the allow list through the firewall settings.

    Disable the firewall completely.  

    Selected Allow remote connections to this computer in the system properties

    Unchecked the "bypass RD gateway server for local addresses" in the RDP gateway settings

    I'm on the same network as this users and literally the only change the occurred was the change of the physical computer on her desk.  

    Both PCs windows login is set up to go to one domain and then will RDP to different domain server.  My machine has been working fine with this setup for a year.  

    I can set up the RDP on a windows 8 machine, in the same office, that didn't have access to it before, and can remote in fine.  If I go to a different station that also received a new machine with windows 10 pro installed, I receive the same results as the user who was previously using the RDP connection.  

    I tried contacting the company that installed the new PC, thinking maybe there was a setting that's turned on within the antivirus software they installed that I don't have admin access to, but I was immediately dismissed with the explanation that the issue is a setting in the remote server we are trying to connect to.

    I will add this server hosts several outside sales guys, all remoting in using laptops on various wifis, IPs, etc., and this the first time I've had this much trouble getting someone to connect to the server through RPD and she's been using the wifi in the office.  I've used the same wifi and never had any issues.  

    Any input, suggestions, or comments anyone can have that I may have missed would be greatly appreciated.

    -G

    Wednesday, October 4, 2017 3:40 PM

All replies

  • If, I accidentally posted to the incorrect form, please point me in the correct direction.  I was posting based on other posts I was reading just before posting my issue.  
    Wednesday, October 4, 2017 3:41 PM
  • Hi gretchmag16,

    You need to make sure the firewall isn't blocking RDP.

    if you haven't done so, open the Firewall for RDP, in PowerShell:

    Enable-NetFirewallRule -Name "RemoteDesktop-UserMode-In-TCP"

    Enable-NetFirewallRule -Name "RemoteDesktop-UserMode-In-UDP"

    Alternatively you may also change the network type to Private from Public.

    Reset router back to factory defaults and then re-connected all the computers. Including check the port.

    Some suggestions you could check in the link below.

    https://superuser.com/questions/442077/remote-desktop-connection-cant-connect-to-windows-server-2012

    You could post the issue to the RDP forum to get more help.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserverTS

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 5, 2017 6:48 AM
    Moderator
  • Yea, all is kosher there.  

    I opened another ticket with the IT company that provided and installed the new machine.  I spent 3 days troubleshooting every angle I could think of and even got my Network Manager involved.  The installer just passed the blame off without even trying to look into it when the first ticket was opened.  

    Thursday, October 5, 2017 5:21 PM