locked
Send On Behalf vs Send As RRS feed

  • Question

  • We have a mailbox set up on our Exchange 2010 server called resume with the associated address resume@domain.com. Our Admin team receives resumes here from potential candidates for hire. I've applied both Full Access and Send As permissions for all three Admin team members who use this account.  

    They have requested the ability the reply to emails and have it appear as not coming from themselves but rather the resume@domain.com address. When they try to reply they get the error "You do not have the permission to send the message on behalf of the specified user". They do not want their name or address appearing in the reply, which is why I did not apply the Send on behalf permission. Is there a way to accomplish this?


    Hank Vare

    Tuesday, June 20, 2017 8:31 PM

Answers

  • Hi Hank,

    Are you using Outlook in online mode or cache mode? Please try switching between these two modes and see whether this issue continues.

    How did the admins add the shared mailbox in their Outlook? As an additional account via Account Settings or as a second Exchange account in the same mail profile?

    The Send As permission isn't granted until after replication has occurred. Replication times depend on your Exchange and network configuration. It's recommended to stop and then restart the Microsoft Exchange Information Store service to make the permission granted immediately.

    In addition, please also check whether the mailbox is hidden from address lists. You cannot send e-mail messages on behalf of a mailbox if the mailbox is hidden from address lists.

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by techrep43 Wednesday, June 21, 2017 11:56 PM
    Wednesday, June 21, 2017 7:47 AM

All replies

  • Hi Hank,

    Are you using Outlook in online mode or cache mode? Please try switching between these two modes and see whether this issue continues.

    How did the admins add the shared mailbox in their Outlook? As an additional account via Account Settings or as a second Exchange account in the same mail profile?

    The Send As permission isn't granted until after replication has occurred. Replication times depend on your Exchange and network configuration. It's recommended to stop and then restart the Microsoft Exchange Information Store service to make the permission granted immediately.

    In addition, please also check whether the mailbox is hidden from address lists. You cannot send e-mail messages on behalf of a mailbox if the mailbox is hidden from address lists.

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by techrep43 Wednesday, June 21, 2017 11:56 PM
    Wednesday, June 21, 2017 7:47 AM
  • Thanks Steve, lots of good info. We always un-check the cache mode setting as we find the negatives of that feature outweigh the positives (sync errors, performance issues, etc). Turns out it was just a matter of waiting for replication to occur and then the Send As permission began to work w/o errors.

    Would be nice if there was a dialog window advising such to give the technician a heads-up once the Send As permission is granted, rather than a message for the user advising that they don't have the ability to Send on Behalf, when we we hadn't even applied that permission.


    Hank Vare

    Thursday, June 22, 2017 12:06 AM
  • Thank you Hank for the good suggestion. I'll submit a feedback regarding this to our engineering team via internal way.

    Thank you again for your understanding and support.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 22, 2017 1:40 AM