none
Project Server 2013 - Queue Job Error. RRS feed

  • Question

  • Hi, 

    I can create a project - Save - Publish = fine

    when i check-in it get stuck in queue with Error below. any help/suggestion appreciated, Custom Workflows works fine with Workflow Manager1.0.


    Alim

    Tuesday, May 21, 2013 10:43 AM

All replies

  • Hi SP

    Please check below the points :

    • Is this Problem with specific EPT or workflow?? Please try with different EPT.
    • Is there any custom calender attached with MSP Template??
    • Check "Project Check In Required" option in the Workflow Stages


    Regards, Pankaj Waghmare - MCTS | Consultant

    Tuesday, May 21, 2013 11:23 AM
  • Thanks Pankaj for quick reply,

    • I have custom list workflows using on other site collection bur don't have any EPT or Workflows on Project site,
    • i am not using any MSP Template/calender , this is just simple project...
    • no workflows attached

    just a simple test project without any templates or customization, throws error when Check- in project

    Please advise


    Alim

    Tuesday, May 21, 2013 11:36 AM
  • hi SP

    Can you please describe the procedure of Project Creation?? SharePoint list workflow is already available in the EPT types you can use this.. any way have you checked connected SharePoint sites' option in the server setting??  


    Regards, Pankaj Waghmare - MCTS | Consultant

    Tuesday, May 21, 2013 11:50 AM
  • Hi Sp,

    Means you are using only Basic Project Plan,But should be there MSP project template with Project web app sync.

    Should be follow below point

    1.Kindly check all project fieldes,Might be some custom field with checkout.
    Go-- server setting--- force checking enterprise Object  ---- then select first project and Then  select enterprise Custom fields.....one by one check and verify, should be all check in.
    next step might be your custom field is required field,should be pick all value during publish.

    then check services.msc and also check timer job status for queue jobs 

    2. In your PS2013 instance, do you have the Workflow Manager associated with the farm and registered?

    Project Server 2013  instance is having trouble communicating with the Workflow Manager. The project itself is checking in or Check out  the queue trying to update the workflow manager with the workflow status probably this generating  error.

    Kindly check below mail its related to your problem.

    http://social.msdn.microsoft.com/Forums/en-US/projserv2010setup/thread/6f2b2c75-5584-40b2-883f-f49394052139



    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Share Point Application Developer,TCS

    Tuesday, May 21, 2013 11:57 AM
  • Hi Pankaj and Hasan,

    Creating Project with MSP 2013 - save - publish - works fine 

    check- in from PWA generates error- did Force checin and i have given all mandatory required fields when creating project

    checked above link regards with WF Manager Workflow manager for SP designer 2013 work fine without any error...


    Alim

    Tuesday, May 21, 2013 12:05 PM
  • Hi Alim,

    you could deactivate the the alerts / reminders / smtp gateway, 

    and then check


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Share Point Application Developer,TCS

    Tuesday, May 21, 2013 12:13 PM
  • Hi Aleem,

    Also fallow the below link

    http://support.microsoft.com/kb/2000241?wa=wsignin1.0


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Share Point Application Developer,TCS

    Tuesday, May 21, 2013 12:16 PM
  • Nothing works !!!!


    Alim

    Tuesday, May 21, 2013 1:23 PM
  • Hi Aleem,

    I thought its bugg in Project Server 2013.Need to raised issue on microsoft product solution service department.

    Check below threat.

    http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/60a328d0-b361-4e8a-b29b-8fdd1e477693


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Share Point Application Developer,TCS

    Wednesday, May 22, 2013 10:35 AM
  • WorkflowCheckinNotify will work correctly after those steps:
    You need to open Sharepoint Designer 2013, open PWA site and create any "workflow sharepoint 2013 - Project Server". Then Project Server will be create WFScope automaticaly.

    Friday, August 16, 2013 1:28 PM
  • i have tired this "You need to open Sharepoint Designer 2013, open PWA site and create any "workflow sharepoint 2013 - Project Server". Then Project Server will create WFScope automaticaly."

    but the error is still remain, i have checked the workflow manager settings and it is fine.


    Abhishek Jangid

    Tuesday, June 3, 2014 11:37 AM
  • can you check scope state in SQL database?

    you need to open SQL management studio (with SQL "sa" privileges), connect to WorkFlow DB server, open new query and execute:

    use WFResourceManagementDB
    SELECT [Path],[Status] FROM [WFResourceManagementDB].[dbo].[Scopes]

    where WFResourceManagementDB - name of WorkFlow resource management database

    check cloumn - Status, all field have status active?

    Tuesday, June 3, 2014 11:57 AM
  • Hi Alim,

    Since it is not a blocking error, this is not critical. Anyway I understand that you want to point out the culprit.

    Eventhough it seems to be related to the workflow move to the next stage, I'd start by digging into the ULS logs to have more details than the queue generic message.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, June 3, 2014 12:26 PM
    Moderator
  • Can you check whether the services "Service Bus Message Broker" and "Service Bus Gateway" are running in the Workflow Farm?


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.

    Thursday, June 5, 2014 7:37 PM
    Moderator
  • Hi,

    Yes i have checked all services is running fine.

    regards,

    abhishek jangid


    Abhishek Jangid

    Thursday, June 12, 2014 3:51 AM
  • Hi All,

    I also encounter this issue when I try to check in the enterprise project. My environment was built by upgrading the Project Server 2010 to 2013 version and it is already upgraded into latest PU April 2015.

    This is what I got from ULS logs when i tried to replicate the issue.
    1)
    Microsoft.Workflow.Client.InvalidRequestException: The scope '/SharePoint/default/c155e3d0-4163-464b-bc80-fa4d259a5f46/f93679ba-dfdd-47ef-96e0-aa7889cd685e' has no workflows under it. HTTP headers received from the server - ActivityId: cc125be6-f567-4495-aed2-e1bd1b1fa578. NodeId: RENON. Scope: /SharePoint/default/c155e3d0-4163-464b-bc80-fa4d259a5f46/f93679ba-dfdd-47ef-96e0-aa7889cd685e. Client ActivityId : 8f25ff9c-0c67-209e-f38c-748179499e66. ---> System.Net.WebException: The remote server returned an error: (400) Bad Request.    
     at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)    
     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)    
     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     -
     -- End of inner exception stack trace ---    
     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)    
     at Microsoft.Workflow.Client.HttpWorkflowNotificationPublisher.OnPublishNotification(String address, WorkflowNotification notification, ICredentials credentials, String userCulture, Guid traceActivityId, TimeSpan requestTimeout)    
     at Microsoft.Workflow.Client.WorkflowNotificationPublisher.PublishNotification(String address, WorkflowNotification notification, ICredentials credentials, String userCulture, Guid traceActivityId, TimeSpan requestTimeout)    
     at Microsoft.Workflow.Client.WorkflowManagementClient.PublishNotification(WorkflowNotification notification, IDictionary`2 activationMetadata, Int64 expectedScopeRevision)    
     at Microsoft.SharePoint.WorkflowServices.WorkflowProxy.PublishEvent(String eventSource, String eventType, IDictionary`2 payload, SPUserToken userToken) StackTrace: 
     at Microsoft.Office.Server.Native.dll: (sig=a1000fac-02c7-4003-8d43-320bb54966b7|2|microsoft.office.server.native.pdb, offset=131D6)
     at Microsoft.Office.Server.Native.dll: (offset=21B79)

    2)
    Watson bucket parameters: SharePoint Server 2013, ULSException14, 044806dd "sharepoint server", 0f0011d9 "15.0.4569.0", 09d02580 "microsoft.workflow.client", 01009cc3 "1.0.40131.0", 52ef34cc "mon feb 03 14:18:52 2014", 0000005e "0000005e", 00000076 "00000076", 2e474e4c "invalidrequestexception", 0020f80c "aip6m"

    3)
    PWA:http://renon/PWA, ServiceApp:Project Server Service Application, User:i:0#.w|domain\gita, PSI: [QUEUE] Unable to properly communicate with the workflow endpoint., LogLevelManager Warning-ulsID:0x746A7076 has no entities explicitly specified.

    I tried to attach a simple SharePoint 2013 - Project Server workflow to the EPT but the issue still persist (previously no workflow was attached). Moreover, I tried to create a custom list under the pwa site and I cannot get the SharePoint 2013 Workflow works into that custom list. It shows similar error as the above. However, I am able to get the workflow running in different site collection and also different web applications.

    I wonder if you already have the solution for this issue. Thank you.
    Wednesday, April 22, 2015 9:10 AM
  • Hi,

    As from this article https://msdn.microsoft.com/EN-US/library/office/dn467936.aspx, I tried to install the Messaging Queue feature at the host server.

    Now the error is only shown when I look into ULS log. At least the error have been gone from the queue job table and I have never received any email about that error anymore.

    Tuesday, May 12, 2015 4:09 AM
  • hi,

    Also try to integrate mail id with user ,some time during mail generation unable to get mail id and generate issue.Also check epm services is running or ont in serives.msc. 


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Tuesday, September 1, 2015 9:55 AM