none
Security Upgrade broke vmWare Shared Folders RRS feed

  • Question

  • This is not the first time this has happened. Windows Update automatically upgrades my VMWare Image. Upon reboot my configured shared folder to the host no longer works. I'm tired of backing out updates and want to remain on the newest, most secure versions of Windows, but I'm constantly forced to revert. I have tried removing the shared folder in VMWare settings and restarting to no avail. I receive "Location is not available" errors when trying to connect. I actually unmapped the drive and tried to re-map, but it no longer shows up. My host doesn't show up in the Network options to try and re-map the drive. I just logged off Windows from my Microsoft account and logged on as a local account and that did not help either.
    Wednesday, January 25, 2017 6:37 PM

Answers

  • Hi,

    The main issue is that the mapped drive no longer worked after the upgrade, right? What is the present version you are using(The latest version should be 14393.693)? Are there any error messages recorded in the Event Viewer(Windows Logs\Applications, System)? Is it available to access the shared folder directly from Windows Explorer before mapping the shared folder (We should ensure the shared folder is available before we mapped it)?

    Please try the following steps to troubleshoot this issue.
    1.Reinstall the network adapter driver from the device manager.
    2.Open an administrator command line and run the following command line to reset the TCP/IP stack.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot
    3.Disable the firewall and the antivirus software temporarily.
    4.Open an administrator command line and run "net use * /d" to delete all the mapped drives created before then map the drive again.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 26, 2017 6:46 AM
    Moderator

All replies

  • Just reverted to a snapshot from last August - after removing my Outlook files and trying to get everything back in order, it appears Update has just hijacked my image and is going to do it again. I'm disabling this piece of shit. So sick of spending a down day every time an Update is pushed.
    Wednesday, January 25, 2017 7:03 PM
  • Hi,

    The main issue is that the mapped drive no longer worked after the upgrade, right? What is the present version you are using(The latest version should be 14393.693)? Are there any error messages recorded in the Event Viewer(Windows Logs\Applications, System)? Is it available to access the shared folder directly from Windows Explorer before mapping the shared folder (We should ensure the shared folder is available before we mapped it)?

    Please try the following steps to troubleshoot this issue.
    1.Reinstall the network adapter driver from the device manager.
    2.Open an administrator command line and run the following command line to reset the TCP/IP stack.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot
    3.Disable the firewall and the antivirus software temporarily.
    4.Open an administrator command line and run "net use * /d" to delete all the mapped drives created before then map the drive again.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 26, 2017 6:46 AM
    Moderator
  • In addition to the steps above, In the vmWare option, I had to un-check the option to automatically "Map as a network drive in Windows guests", then had to manually go to the drive in Windows Explorer under Network, drill down to get the correct mapping path, then map the drive manually. This seems to work now. I think the issue is that Windows no longer accepts a dash (-) in the path? Not sure, but it seems like the old path generated by vmWare had a dash in it.

    Tuesday, February 7, 2017 3:40 PM