locked
Windows takes forever when using any workstation to move files and folders on a NAS. RRS feed

  • Question

  • This is not always specific to ONLY on the NAS but it is worse when doing it there. 

    Any time you try to move a large quantity of files or folders with subfolders and files from one place to another whether on your local drive or on a NAS,  Windows spends sometimes hours "calculating". 

    I can understand the need to know the total size in the case of writing to a CD or DVD where you might exceed the capacity of the drive and not know until too late into a burn and waste a lot of disks but on a hard-drive, even if it won't fit, since you are cutting and pasting, what won't go just stays where it is.

    This is especially annoying when trying to combine what amounts to two identical folders when you are trying to "clean up" the overlap to save space  The more the overlap, the worse the time delay.

    I have followed other threads about this and seen a lot of possible solutions but all of them seem to be near hits but not full solutions.  In the first place, why can't you simply disable any "calculations" regarding a move?  What if I am willing to take the risk and just want to do it?  I wish I had more of a technical insight into why things don't just "happen" when you tell them to

    This is not simply a NAS issue as it happens regardless of what I do it on.  Windows 7 x64 with 16GB RAM in an I7 laptop.  Whether I do it on the local C: drive or do it from one folder to another on the NAS. It seems Windows MUST do that calculation before starting and either it cant count that high or the processes needed have such a low priority that they just never finish.  It is there where the ball gets dropped and everything stops. 

    It is Worse by far when moving a folder containing subfolders which may also have subfolders. And it is WAY worse if trying to do more than one at a time. I have also tried several third party sync tools but nothing could be more simple than Cut and Paste, Copy /Paste, or even resorting to command-line "move' command. I don't need to sync anything in most cases I just want to be sure I have at least One copy of every file. Then delete the entire extra folder and all the copies in it.

    Since there are many threads with the same issue I know it isn't just me or my configuration.  Has anyone found a 100% solution yet?

     

    Sunday, July 7, 2013 4:14 PM

Answers

All replies

  • Hi Questorfla,

    I’m afraid you can’t find a perfect solution. When copying/moving/deleting a file, the calculation time depends on not only the file sizes but the file number of its folder.

    Alternatively, you could try to use this following tool:

    Robocopy

    http://blogs.msdn.com/b/granth/archive/2009/12/07/multi-threaded-robocopy-for-faster-copies.aspx

    Best regards,

    Karen Hu

    • Marked as answer by Cloud_TS Tuesday, July 16, 2013 7:48 AM
    Tuesday, July 9, 2013 9:10 AM
  • I don't know if this is relevant to your case or not...but we were seeing a difference between copy/paste and cut/paste with the same files.  Copy/paste would take less than 5-6 seconds to copy files from one folder to another (both on a network server).  But cut/paste of the same exact files took 20 minutes.

    The problem was immediately resolved (with no reboot) when we disabled on-Write In Sophos 10.x On-access scanning.  Something changed with how Sophos handles this operation from 9.5.5 to 10.0.  On a machine with 9.5.5, on-write was enabled but the cut/paste was normal (5-6 seconds).

    Hope that helps.

    Friday, August 23, 2013 12:00 AM