locked
New Document Template does not save in Document Library RRS feed

  • Question

  • Hi Guys

    I have created a standard document library within SharePoint and when I click on the New Document which is again a default SharePoint MS Word 2007 template, it expectedly opens MS Word after authentication. But when I try to save the document it does not give me the option to save directly into the Document Library but instead I am having to save it locally. I have tried Save and Save As buttons in MS Word without any luck.

    Any ideas?

    Thanks

    Adnan
    Tuesday, November 17, 2009 2:59 PM

Answers

All replies

  • Can u please provide more details on the OS and  sharepoint version you are using.

     Also please check whether check in / checkout is enabled in your site.

    Try direclty closing the document and click save when it asks whether to save it or not.

    PLease provide more details, also try testing the scenario  in a new doc ibrary/ new site/new machine.
    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    Tuesday, November 17, 2009 3:18 PM
  • Hello,

    When you click Save or Save As and the window pops up, what is the default location it is setup to save to?

    Is there an option on the left called My Network Places?  It would be next to Desktop, My Computer, My Documents, ect.  If so, click on that and see if your SharePoint site is available.


    Chris Caravajal MCTS SharePoint Help
    Tuesday, November 17, 2009 3:35 PM
  • Thank You for the quick response

    The answer to your question is

    Answers to AJ
    ==========

    OS: Windows 2003 SP2 x64
    SharePoint: MOSS 2007 with SP1

    Check in and Check Out is enabled on the site

    I have tried directly closing the document and rather than asking me to check in and save it just closes Word if the document is blank or asks me to save locally is i type something in the document.

    This i am trying on a complete new site, new library and a new document.

    Answers for Chris
    =============

    The default location for my Word application is My Documents and in my network places I only see the Network Places I have synched with in the past but not the SharePoint document library which I have opened the New document from


    Any suggestions?

    Thanks
    Tuesday, November 17, 2009 5:20 PM
  • Are you running Office 2007?
    Chris Caravajal MCTS SharePoint Help
    Wednesday, November 18, 2009 5:02 AM
  • Dear Adnan,

    Just follow these steps.. it will work 100%.

    Go To Start > Run > Type webfldrs.msi
    Click on Select Reinstall Mode button (not Reinstall button)
    Select all options
    Click on OK
    Now click on the Reinstall button
    Click on OK
    Click on Yes to restart the machine or manually restart the machine.

    Regards
    Balu
    Wednesday, November 18, 2009 6:27 AM
  • Chris - Yes I am running Office 2007 with Windows 7

    Ballu - I think the issue might be with Windows 7 as this issue doesnt occur with Windows XP and Office 2007 or Office 2003. Also there no webfldrs.msi on Windows 7

    Has any one come across this issue using Windows 7?

    Regards

    Adnan
    Wednesday, November 18, 2009 10:53 AM
  • Hi

     

    Try to create a new web application and then create a new site collection, create a new document library, check the effect.

     

    Did you break the permission inherited for the document library? For example, you prevent the file inherit permission from its parent. If so, try to inherit permission from its parent and check the effect.

     

    What permission does the problematical account have? Try to use site collection administrator log on another machine, check the effect.

     

    What version is your client’s operation system? Check whether you install the following hotfix, if not, try to install it and check the effect.

     

    http://support.microsoft.com/kb/907306/en-us

     

    For more information about control access to sites, please look into the following articles:

     

    About controlling access to sites and site content

    http://office.microsoft.com/en-us/sharepointtechnology/HA101001441033.aspx

     

    Permission levels and permissions

    http://office.microsoft.com/en-us/sharepointtechnology/HA101001491033.aspx

     

    Manage permissions for a list, library, folder, document, or list item

    http://office.microsoft.com/en-us/sharepointtechnology/HA100215641033.aspx?pid=CH100649861033

     

    Hope this helps.

     

    Rock Wang


    Rock Wang– MSFT
    Thursday, November 19, 2009 3:35 AM
  • Hi Adnan

    I have resolved the same issue yesterday with this Windows 7 compatible EXE.  Just download and run it. It will work 100%.


    It resolved my issue.

    regards
    Balu
    • Proposed as answer by Mighty B Thursday, November 19, 2009 4:18 AM
    • Marked as answer by Rock Wang– MSFT Wednesday, November 25, 2009 9:38 AM
    Thursday, November 19, 2009 4:08 AM