none
VBS logon script not running

    Question

  • I have one .vbs script for changing the registry value. Manually running in system its working fine. If i apply through group policy its not working.

    Group Policy Settings:- User. Conf-->Windows Settings---> Logon Script.(server 2012)

    Client Machines:- Win 7 & Win 8

    Steps taken:-

    1) disabled UAC policy and tried.

    2) Script location verified in gpmc.

    Sunday, January 10, 2016 6:29 PM

Answers

  • Hi,
     
    Am 10.01.2016 um 19:29 schrieb vino1985:
    > I have one .vbs script for changing the registry value.
     
    Why are you not using GPP registry settings?
     
    > If i apply through group policy its not working.
     
    Do other vbs script run applied by GPO?
    create a sample vbs with a "echo hello world" and write the output to to
    a file on users desktop. Does it work?
     
    Replication problem? Did you check the DFS path of GPO or did you check
    every single DC path?
    \\yourdomain\sysvol\...\guid of policy\...
    \\yourdc\sysvol\...\guid of policy\...
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Sunday, January 10, 2016 7:38 PM

All replies

  • Hi,
     
    Am 10.01.2016 um 19:29 schrieb vino1985:
    > I have one .vbs script for changing the registry value.
     
    Why are you not using GPP registry settings?
     
    > If i apply through group policy its not working.
     
    Do other vbs script run applied by GPO?
    create a sample vbs with a "echo hello world" and write the output to to
    a file on users desktop. Does it work?
     
    Replication problem? Did you check the DFS path of GPO or did you check
    every single DC path?
    \\yourdomain\sysvol\...\guid of policy\...
    \\yourdc\sysvol\...\guid of policy\...
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Sunday, January 10, 2016 7:38 PM
  • Hi Mark,

    Thanks for your response.

    GPP registry not applicable for this case, since my script is checking which office version and it will add the registry value based on that version.

    problem is in my outlook signature it showing "linked images are not displayed".

    For fixing this above issue i have to update registry "send pictures with document"

    regarding replication no issue between domain controllers.

    Monday, January 11, 2016 4:22 AM
  • Hi
     
    Am 11.01.2016 um 05:22 schrieb vino1985:
    > GPP registry not applicable for this case,
     
    it is! It´s called Item Level Target filter, where you can create nearly
    any filter you like -> Common Tab of any GPP Item.
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Monday, January 11, 2016 7:52 PM
  • Hi,

    Have you checked if group policy is applied successfully? Please run gpresult /r command to have a check.

    We need to confirm that the issue is related to group policy or vbs script .

    Besides, you could create a sample vbs script to have a test via group policy as Mark suggested.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 20, 2016 7:19 AM
    Moderator