locked
"Download a copy" button is greyed out. RRS feed

  • Question

  • Hello,

    If i go to any of the SP2010 Document library and select multiple documents and try to download all at one go by going Documents (on dic lib ribbon) > Download a copy, I can not. Download a copy button is greyed out. If i select just one document then "Download a copy" button is working.

    Please help.

    Thanks.

    Tuesday, June 19, 2012 8:20 PM

Answers

  • That is by design.  You can't download multiple files at a time using the ribbon in SharePoint. 

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Tuesday, June 19, 2012 8:27 PM
  • Thanks all for your reply. I'm able to download all the ducumetns using "explorer view". The reason I was getting thie view blank is I didnt have access to that SharePoint site.

    Thanks,

    • Marked as answer by abc67 Monday, June 25, 2012 4:37 PM
    Monday, June 25, 2012 4:37 PM

All replies

  • That is by design.  You can't download multiple files at a time using the ribbon in SharePoint. 

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Tuesday, June 19, 2012 8:27 PM
  • Thanks. so if i try to "open in explorer view", the view is blank. Any idea about that?

    Thanks.

    Tuesday, June 19, 2012 8:32 PM
  • I've seen the open in explorer view greyed out, but I've never seen it blank if you have documents in the library.  Not sure why it would do that.

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Tuesday, June 19, 2012 8:45 PM
  • Thanks Paul. It looks like something is weird. I have documetns in the lib and explorer view is just blank and that is happening for particular site collection. For other site collections in the same web application, explorer view is just working fine.

    Thanks, 

    Tuesday, June 19, 2012 8:49 PM
  • Hi abc67, 

    As the previous poster has said you cannot download many copies at once and it has to be done separately. However, where you have a blank explorer page, are you sure that SharePoint is opening up the correct file location? Just for reference, find the location by clicking on 'Documents' on the machine that the SharePoint server resides on and see if it is there. I have had SharePoint do this to me before, and I just browsed myself to the correct location. I cannot explain why it does this!


    http://sharepointythings.blogspot.co.uk/

    Wednesday, June 20, 2012 10:56 AM
  • Thanks all for your reply. I'm able to download all the ducumetns using "explorer view". The reason I was getting thie view blank is I didnt have access to that SharePoint site.

    Thanks,

    • Marked as answer by abc67 Monday, June 25, 2012 4:37 PM
    Monday, June 25, 2012 4:37 PM
  • To Microsoft!!

    Just for the record, this sucks!!  It would be very helpful to be able to either open or download a copy of multiple documents as selected in a library.  This is a huge limitation.

    ok, rant over...

    Would you happen to know where this can be added as a feature request?  Do you know if there is some sort of workaround that might provide the functionality?

    Thanks.

    Friday, October 12, 2012 7:31 PM