locked
Gadgets Stay on top RRS feed

  • Question

  • I'm using a series of gadgets on Win7. Most are not habilitated but can be called forward when needed.
    I have constantly 3 gadgets on screen which are:
    -Default Analog Watch
    -Wireless Network Meter V 3.1 by Addgadget.com
    -Control System with Uptime from Addgadget.com

    I consider these 3 gadgets essential to my daily work on screen and therefore need them to stay on top.

    When using certain applications/Programs this stops working. When then going to the properties of each gadget, the "Always on Top" option is still ticked. Only unticking and ticking again makes the gadgets return to Stay on Top.

    I suspect that the applications Google Chrome and my Encore ENU TV program might be the guilty ones for this, but I'm not completely sure as this happens all the time.

    Any hints out there?



    Ambidextrous installed Windows 7 Release Candidate on an HP Pavilion dv1000 Laptop with a Centrino 1.86 GB CPU and 2 GB RAM.
    Wednesday, June 10, 2009 6:04 PM

Answers

  • Ambidextrous,

    That disclaimer will disappear and be replaced with the aforementioned driver later this year ;)

    Bazikcho,

    To run a program or installer in compatibility mode, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    Saturday, June 13, 2009 10:58 PM

All replies

  • You gadgets probably have some transparency issue with Crome or Encore. I would look to HP for better Video drivers as the final 7 version is released. Installing the apps in Vista Compatibility Mode may also help.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Saturday, June 13, 2009 12:19 PM
  • Most probable.
    Happens without any notable frequency.

    Message picked up at the HP driver site:
    Quote
    Please Note:
    HP does not support Beta or test versions of Windows® 7.
    Unquote

    Do you know where to go to get the mentioned driver?


    Ambidextrous installed Windows 7 Release Candidate on an HP Pavilion dv1000 Laptop with a Centrino 1.86 GB CPU and 2 GB RAM.
    Saturday, June 13, 2009 8:39 PM
  • And how to install gadget in compatibility mode ?
    Saturday, June 13, 2009 8:47 PM
  • Ambidextrous,

    That disclaimer will disappear and be replaced with the aforementioned driver later this year ;)

    Bazikcho,

    To run a program or installer in compatibility mode, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    Saturday, June 13, 2009 10:58 PM
  • Yes, let's wait and see what they all come up with and how fast it goes.
    Remembering Vista days, I hope they are sitting on a little less fingers this time.
    I hear that MS wants to launch sometime in October and make availability for vendors even before.
    Well, I wouldn't like to buy a Win7 computer just to find out that half of the computer doesn't work because of driver problems.

    Ambidextrous installed Windows 7 Release Candidate on an HP Pavilion dv1000 Laptop with a Centrino 1.86 GB CPU and 2 GB RAM.
    Sunday, June 14, 2009 2:48 AM
  • Ambidextrous,

    That disclaimer will disappear and be replaced with the aforementioned driver later this year ;)

    Bazikcho,

    To run a program or installer in compatibility mode, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    I know that stupid think but u don't answer me. 

    Gadgets are not .exe files and that is not possible
    Monday, June 15, 2009 5:32 PM
  • I think Axfelix referred to the driver apps and not the gadget apps.
    Ambidextrous installed Windows 7 Release Candidate on an HP Pavilion dv1000 Laptop with a Centrino 1.86 GB CPU and 2 GB RAM.
    Monday, June 15, 2009 10:13 PM
  • I have the same issue on my win 7 RC. It`s bugged because of gadget component.
    Quick resolution: simply switch user.
    Thursday, July 2, 2009 10:52 AM
  • I have the same problem with my gadgets falling behind the front application even when "always on top" is checked.  I have eventually noticed the problem commonly occurs when I am using Microsoft Access 2007.  Even though I run it on my second monitor (not on the same one as the gadgets), I often have to uncheck and recheck the "alway on top" option for each gadget.  It is not any function of video or transparency, it si simply not on top anymore.
    Friday, July 3, 2009 1:23 PM
  • I've given up on this one...
    I had an analog clock, a shutdown control and a wireless monitor always on top plus 2 weather zones and a couple of games not on top.
    What should stay on top disappears and what shouldn't ends up staying on top.
    Those that should stay on top only get back on top if i unclick the stay on top option and then activate the option again.

    But it is completely random when and what gadget appears and disappears.
    I've thrown it all out and only keep the analog clock which I can at least see if I move the mouse down in the lower right corner...

    As it is not just one gadget and not just gadgets from one writer I must believe that the problem is in Win7 or some application installed - But which one......
    Ambidextrous installed Windows 7 Release Candidate on an HP Pavilion dv1000 Laptop with a Centrino 1.86 GB CPU and 2 GB RAM.
    Saturday, July 4, 2009 2:19 AM
  • Hi There,

    I have "Gadgets" staying on top randomly and it is very annoying. I am using 7 and Firefox BETA 15.2 but it has been happening for a while now through many BETA upgrades. I have found that if you move the gadgets and then back to their original spot, they will disappear from the top once you click on the window that you are using. Anywhere is OK.

    This will keep them at bay until they appear again and you have to go through the "Move" procedure all over again.....

    It is a real pain in the neck to do this....

    I wonder who is at fault here....

    After reading some of the entries here, I suspect that the BETA version is not plying nice with the gadgets and this is the results...

    Regards,

    CC

    Monday, July 30, 2012 1:46 PM