none
CM2012 - Client Install Fails with Unable to compile Sql CE script file RRS feed

  • General discussion

  • CM2012 Client Install fails with Error: 

     

     

     

    From the ccmsetup.log file:

     

    MSI: Setup was unable to compile Sql CE script file C:\Windows\CCM\CIStoreDB.sqlce.

    The error code is 87D00244. ccmsetup 9/27/2012 2:32:59 PM 7440 (0x1D10)

    MSI: Action 14:33:00: Rollback. Rolling back action: ccmsetup 9/27/2012 2:33:00 PM 7440 (0x1D10)

    File C:\Windows\ccmsetup\{F5EAB9A8-E852-429F-92BC-BB82712ACA9B}\client.msi installation failed. Error text: ExitCode: 1603

    Action: CcmCompileSqlCEScripts.

    ErrorMessages:

    Setup was unable to compile Sql CE script file C:\Windows\CCM\CIStoreDB.sqlce.

    The error code is 87D00244.

    ccmsetup 9/27/2012 2:33:03 PM 7440 (0x1D10)

     

    From the client.msi.log file:

     

    [14:32:49] Creating Sql CE database: CcmStore.sdf

    MSI (s) (14!1C) [14:32:49:501]: Closing MSIHANDLE (10437) of type 790531 for thread 6172

    MSI (s) (14!1C) [14:32:49:502]: Creating MSIHANDLE (10438) of type 790531 for thread 6172

    [14:32:49] ERROR: Ccm::Utility::Sql::CcmSqlDB::Create - Failed to create data source: C:\Windows\CCM\\CcmStore.sdf.

    MSI (s) (14!1C) [14:32:49:502]: Closing MSIHANDLE (10438) of type 790531 for thread 6172

    MSI (s) (14!1C) [14:32:49:502]: Creating MSIHANDLE (10439) of type 790531 for thread 6172

    [14:32:49] Warning: failed to create database C:\Windows\CCM\\CcmStore.sdf. Error code = 0x80040e21. Setup will continue.

     

     

     

    MS Policy Platform is successfully installed as are the other pre-reqs up to this stage of the install - It appears the system has a pending SCEP pre-req and the Windows Firewall Configuration Provider.msi.

     

    Have tried multiple approaches to fix - clean uninstall, WMI Repair, Recreating the repository and the error persists - experiencing the error on multiple machines generally Windows 7 x86 x64 to include SP1 systems.  Stumped my PFE and ripping my hair out in frustration as it seems like a fairly simple error. 

     

    Decided to post on the forum in case of a miracle and also to provide some small curmb of solace to anyone moving to CM2012 who might experience the same issue - No solution but it does make someone feel better when the pain is shared.
    Thursday, September 27, 2012 9:03 PM

All replies

  • (This is a very new part of the ConfigMgr client.) Something is apparently getting in the way of it installing the local SQLCE database. I would fire up procmon and watch for some other errors related to the creation of the ccmstore.sdf file. It could be a lot of things like anti-virus. Have you reviewed the event logs for any corresponding events?

    Does the system have SQL Server already installed on it or any version of the SQL Server Native Client?


    Jason | http://blog.configmgrftw.com

    Friday, September 28, 2012 12:59 AM
    Moderator
  • Howdy Jason!

    I have a bit of challenge as the system currently experiencing this is remote and the end-user is non-technical......

    So procmon might not be possible - I am unable to replicate in the lab and as our support breakfix is at this point is reimage so its difficult to capture - If I can get my hands (physically) on an affected system I plan on capturing the OS image. 

    Yes on this specifc system SQL CE 3.5  was on the system previously - I did upgrade it to 3.5 SP2 with no affect. I know it related to MS Policy Platform but the relationship is unclear - Ive got an ask in to MS.

    AV has been suggested as a possible root cause - Trust me when I get the solution Ill share! :)

    Cheers

    Angie

    Friday, September 28, 2012 4:27 PM
  • Well I have an answer - Its a bug in CM2012 RTM Code - There is no work-around and no hotfix.  The issue was uncovered internally by the MS Dev/Product Team and addressed with Service Pack 1.  Some systems (RARE) have unexpected schema changes which prevent the SQLCE Script from compiling and creating the CIStore.sdf

    SP1 also addresses another client install failure where the MS Policy Platform Provider fails to install correctly due to an an issue with verifying the authenticode signature.

    So for those out there who get bit by this while using RTM code the only break fix available is a system reimage or wait for the release of SP1.

    Wednesday, October 3, 2012 8:07 PM
  • Not sure if you still have this issue, but i have seen this on a few of my hosts whilst upgrading to SCCM 2012 SP1. the process i followed was

    • ccmsetup /uninstall
    • delete SMSCFG.ini
    • re-install ccmsetup

    on the majority of hosts this was all that is required but i had a few hosts fail with the error as above. What cleared it for me was to use the CCMCLEAN tool from the SMS2k3 Toolkit. I know this is not supported by Microsoft, but it helped my cause.

    CCMCLEAN /ALL

    Monday, January 21, 2013 4:12 PM
  • I had the same problem with SCCM2012R2 and a 2008R2 client.

    Wizz1969 workt fine for me.

    Thanks

    Monday, January 13, 2014 11:27 AM
  • ccmclean was the only thing that resolved this issue. was about to have a tech reimage, then I found this and figured it was worth a shot. Never used the sms 2003 tools as we have SCCM 2012, but it worked great. Thank you for sharing. Nancy
    Tuesday, February 3, 2015 5:25 PM
  • I know its an old post but I wanted to share my experience since it did not work on me with above solutions.. My OS was windows 2008 R2 where the error kept coming regardless of what I did so finally I found following article which was suggesting to install VC++ 2013 and that fixed my issue

    https://social.technet.microsoft.com/Forums/en-US/d3cb3b25-8195-47dd-8121-993681c21b5e/cm2012-client-install-fails-with-unable-to-compile-sql-ce-script-file?forum=configmanagerdeployment


    Hope this will help someone who could not fix with ccmclean..

    • Edited by IHunzai Monday, July 24, 2017 9:38 PM
    Monday, July 24, 2017 4:20 PM
  • thanks

    Thursday, November 23, 2017 11:48 AM
  • For me, this worked:

    Fix- Error -Unable to compile Sql CE script file during SCCM client install or upgrade (80004005)

    Steps to Resolve the issue :

    1- Uninstall the SCCM client . (C:\Windows\ccmsetup>ccmsetup.exe /uninstall)

    2- Delete all the files on the folder C:\Windows\CCM

    3- Install the SCCM client again.

    Credits to Rajneesh Yadav


    Friday, December 7, 2018 8:12 PM