none
PS2010 Administrative Time-Off Requests RRS feed

  • Question

  • I am trying to understand how to set-up Project Server to have administrative time-off requested in a future timesheet show up in the PWA "Reminders" web part.  Last item in the following list:

    Approvals
    You have X task updates from resources pending your approval.
    You have no timesheets from resources pending your approval.
    You have no timesheet lines from resources pending your approval.
    You have no administrative time-off requests from resources pending your approval.

    I set up a resource with a timesheet manager other than themselves, created a new "future" timesheet, added vacation time (requires approval) and saved the timesheet.  Not only did the request not show up as a "request pending approval" for the Timesheet Manager, the request processed all the way to the resources calendar showing reduced availability.  After that I submitted the timesheet and it just shows as "timesheets from resources pending approval".

    What I want to be able to do is have a resource enter a Non-working time request on a future timesheet and have the request require approval before it posts to their calendar.  I also want to understand the process steps to trigger the "time-off requests from resources pending approval" item in the Reminders/Approvals section of the PWA homepage.

    Thanks,

    Frank Records frecords@oakwoodsys.com

    Monday, February 7, 2011 11:19 PM

Answers

  • Hi,

    I am sorry, I was not successful in installing CU December and don't have the time to investigate what is causing my installation issue currently. There will be a new one within the next two weeks to give it another try ;-).

    In the meantime I activated a soultion, based on Jeff's observation (Jeff, since I had been able to reproduce Frank's issue with using an Administrator account and could solve it by the following, I am pretty sure that found the correct permission causing this behaviour):

    • Create a new category in Server Settings - Manage Categories
    • Enter name and description (I used DisableAdministratorsAdministrativeTimeAutoApproval)
    • Add group Administrators to this category
    • Select Administrator to open Permissions section for groups Administrators
    • Select Deny for "Adjust Timesheet"
    • In section Resource, select "The User is the resource" only. This will let administrators still doing their job for timesheets of other users, but will not allow them to do so for their own timesheets - so there will be no auto-approval for vacations etc.
    • Save this new category

    I tested it and it is now working as expected, also for members of Administrator group.

    Regards
    Barbara

    • Marked as answer by FrankRec Monday, February 14, 2011 3:39 PM
    Sunday, February 13, 2011 4:44 PM
    Moderator

All replies

  • Hi Frank,

    if you enter administrative time in the future, you can submit this to timesheet manager by selecting this line and use Send Status - Selected Tasks. If I do this, availability is reduced after timesheet manager's approval.

    Does that work for you?
    Barbara

    Tuesday, February 8, 2011 7:44 AM
    Moderator
  • Hi Barbara,

    Thanks for the reply.  I performed the process you suggest before I posted my problem. The Timesheet Manager did not see a message in his Reminders on the Home Page, he did not get the request for approval on his Approvals Page and the availability was reduced immediately without any approval. I did check to see that the Timesheet Manager did not have any approval rules in place.

    My PS2010 installation is vanilla out-of-the-box. Is there a setting that controls this process that I am missing?

    Any other suggestions would be appreciated.

    Frank

     


    Frank Records
    Tuesday, February 8, 2011 2:53 PM
  • Frank --

    Please allow me to ask a dumb question.  Is the manager in question actually formally designated as the Timesheet Manager for the resource in question? The Project Server administrator must do this by completing the following steps:

    1.  Log into PWA with administrator permissions.
    2.  Navigate to the Resource Center page and select the checkbox for the resource in question.
    3.  Click the Edit Resource button in the Resources ribbon.
    4.  On the Edit Resource page, click the Browse button for the Timesheet Manager field.
    5.  In the Pick Resource dialog, select the correct manager and click the OK button.
    6.  On the Edit Resource page, click the Save button.

    Please let us know what you find and we will try to help you.


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Wednesday, February 9, 2011 1:07 AM
    Moderator
  • Dale,

    I appreciate your time on this issue.  In my testing I was careful to do the following:

    1) update the Timesheet Manager for the selected resource (in this case I used myself)

    2) then since I am an Administrator in the system, went to the timesheet periods and created a new future one

    3) then went to my Timesheets and created a new Timesheet for the new period and enterred time in vacation and one new administrative category also set to require approval. 

    4) I then selected the two rows and "Updated the Selected"

    5) The Timesheet Manager is also an administrator in the system and as descried before, no notifications were issued in his approval area or on his home page and my calendar was changed.

    I was reading your book "Implementing and Administering" and on page 451 the highlighted warning would lead me to believe that an approval from the Timesheet Manager would trigger the update to the resource calendar.  Unfortunately in my system it is not.

    I will be testing in a second (different) environment today and will update this thread with the results.

    I really appreciate your comments.

    Frank


    Frank Records
    Wednesday, February 9, 2011 2:33 PM
  • Frank,

    This appears to be an issue when using Delegation.

    Are you using Delegation to perform your tests?  I was experiencing similar results using Delegation, but get expected results when not using delegation (notification of administrative time-off requests for approval, My Timesheet calendar exception not created until approval).

    Issue 1:  When using delegation, merely saving an Admin time request creates a My Timesheet calendar exception.
    Here are the details of the scenario:

    1.     Using Delegation, User A (acting as a delegate for User B) enters an Administrative Time Off request by entering Planned work on an Administrative line on their timesheet. 

    2.     Click Save

    3.     The status of this timesheet is Status: In progress (Pending Send Timesheet)

    4.     Stop Delegation

    5.     Open the calendar for User B

    6.     A My Timesheet calendar exception has already been created (this is not expected since the request has neither been submitted nor approved.
    Note that this Admin Time entry was only saved.  Send Status was not clicked.  Send Timesheet was not clicked.

    7.     User C, as the Timesheet Manager for User B has nothing to approve (this is expected as nothing was submitted)

    Issue 2:  When using delegation, submitting an Admin time request does not create a notification about administrative time-off request.

    Continuing with the above scenario:

    1.     Using Delegation, User A (acting as a delegate for User B) clicks on Send Timesheet to submit the timesheet created above with the Administrative time off request.

    2.     User C (the timesheet manager for User B) receives notification about a pending timesheet approval (as expected)

    3.     User C does not receive a notification about administrative time-off request to approve.

    4.     User C rejects the timesheet.

    5.     The calendar exception (which shouldn’t have been created in the first place) is not removed.

    6.     User B sees that their timesheet has been rejected.

    7.     User B (or User A using delegation) zeroes out the original Admin request and clicks save.

    8.     The calendar exception is removed.

    Not sure if it matters, but in this scenario the user performing the delegation (User A) is not the Timesheet Manager of User B.

    Wednesday, February 9, 2011 7:33 PM
  • Jeff,

    Thanks for the details but there are no delegations defined in the system.  Here are the results of my further testing in two different environments:

    1) In my second environment but where the setup was basic and similar to my initial environment the result was: No change, still not working as expected.

    2) Then I went to the Microsoft provided Hyper-V VM environment (2010-7a) and conducted the same test.  In this environment the process worked as expected.  Here is the process I used and what I observed:

        a) I set resource Ben Spain to have Jan Kotas as his Timesheet Manager.

        b) I created a new future timesheet and put vacation in for several days.  This caused a red cell in the status field to come on (just like in my other environments) indicating “Not Submitted” and that I needed to send for approval.

        c) I checked the line item box and submitted the selected task.  This caused the Status field to stay red and indicate “Pending Approval”.  In the other environments this field returned to a blank state after submittal or save.  I logged in as Jan Kotas and the Reminder web part had the expected notice of a pending administrative time request.

    3) I then started looking at the settings in the Microsoft vm environment to see what might be different.

        a) In the Timesheet Settings area the only difference was that “Single Entry Mode” was checked and the “Status Manager Approval” was “Enabled”.

    4) I then unchecked the “Single Entry Mode” and re-ran the test.  No change to the results, it worked. (Note: I was expecting the routing to not work anymore).  The only change was that additional task line items appeared in Jan’s Approval Center. I assume that is because of the “Status Manager Approval” being “Enabled”.  I then rechecked the “Single Entry Mode” and looked at the Approval Center and only the Administrative lines remained.

    I still have not found the setting (or difference in the environments) and so still need help getting this feature enabled in my two environments.

    Thanks,

    Frank


    Frank Records
    Thursday, February 10, 2011 8:47 PM
  • Hi Frank,

    I have also spent some time today testing with several settings. I was not able to reproduce with any setting. I have also tried what Jeff described, using delegation had no effect on my system. I have only one more idea. What's the patch level of the environment, where you can see the issue? What patch level does evaluation environment (2010-7a) have?

    Regards
    Barbara

    Thursday, February 10, 2011 8:54 PM
    Moderator
  • Hi Barbara,

    My two environments are at the October CU patch level and the Microsoft vm was created in April 2010 and I have not patched that environment as I use it for demo purposes.

    Frank


    Frank Records
    Thursday, February 10, 2011 9:00 PM
  • OK, I will patch my system tomorrow and let you know. Now I am really curious!

    Regards
    Barbara

    Thursday, February 10, 2011 9:02 PM
    Moderator
  • Getting closer. ...

    I was able to duplicate the error on the 2010-7a environment which should help narrow it down to the root cause of the problem.  It doesn't seem to be related to the timesheet settings.  It appears to be an issue related with user permissions which is why I initially thought it was related to delegation. 

    I duplicated the test that Frank performed with Ben Spain (2a through 2c above).  I received identical results which match the expected behavior. 

    To create the error condition, I added Ben Spain to the Administrator group and duplicated the test on another week.  Jan Kotas did not receive the request, the calendar exception was added to Ben's calendar, and the Process Status of the request in Ben's My Timesheet was blank.

    So it appears that Administrators can take vacation whenever they wish without approval! 

     

    Thursday, February 10, 2011 9:57 PM
  • Jeff,

    That is great news.  In my original testing I was using resources that were both Administrators in the system.  I will re-test using non-admins and see what happens in my original environment when I have access tomorrow and will then update this post. 

    My clinet is going to be concerned as they have several users who are Administrators in the system that also run projects and want to use this feature to indicate OOO (Out-Of-Office) time once the request is approved by their Manager who is not an admin in PS2010.

    Frank


    Frank Records
    Thursday, February 10, 2011 11:15 PM
  • Frank,

    After further testing, I've pinpointed the specific permission causing the problem.  If the user submitting the Admin timeoff request has the category permission Adjust Timesheet (for themsleves) the request time-off function does not work as expected.  In this scenario the user is not their own Timesheet Approver.

    Barbara this should give you enough specifics to test on your patched system to see if this issue was resolved with the Dec 2010 CU or earlier.  My test was conducted on version 14.0.4763.1000.

    I'll be patching my Dev box soon, but don't know if I will get to it today.

    Jeff

    Friday, February 11, 2011 3:20 PM
  • Hi Jeff,

    thanks for this detail. I found no time to patch my system today. I hope I will be able this evening or in the weekend. I will let you know. But I can't remember any changes regarding permissions, so I don't expect any change for that.

    Since you had been able to narrow it down to one specific permission, it is at least possible to work-around this behaviour. Thanks!!!!

    Regards
    Barbara

    Friday, February 11, 2011 3:40 PM
    Moderator
  • I haven't been able to consistently reproduce my test results around the Adjust Timesheet permissions.  I'm going to wait until I get my system patched before doing any more testing.

    Friday, February 11, 2011 6:40 PM
  • Hi,

    I am sorry, I was not successful in installing CU December and don't have the time to investigate what is causing my installation issue currently. There will be a new one within the next two weeks to give it another try ;-).

    In the meantime I activated a soultion, based on Jeff's observation (Jeff, since I had been able to reproduce Frank's issue with using an Administrator account and could solve it by the following, I am pretty sure that found the correct permission causing this behaviour):

    • Create a new category in Server Settings - Manage Categories
    • Enter name and description (I used DisableAdministratorsAdministrativeTimeAutoApproval)
    • Add group Administrators to this category
    • Select Administrator to open Permissions section for groups Administrators
    • Select Deny for "Adjust Timesheet"
    • In section Resource, select "The User is the resource" only. This will let administrators still doing their job for timesheets of other users, but will not allow them to do so for their own timesheets - so there will be no auto-approval for vacations etc.
    • Save this new category

    I tested it and it is now working as expected, also for members of Administrator group.

    Regards
    Barbara

    • Marked as answer by FrankRec Monday, February 14, 2011 3:39 PM
    Sunday, February 13, 2011 4:44 PM
    Moderator
  • Jeff and Barbara,

    I have tested several variants of the solution and now understand how to work with my clients to chose the solution that best works in their Project Management envirtonment.

    I want to thank you both for the support you have provided.  It is very much appreciated.

    Thanks again,

    Frank


    Frank Records
    Monday, February 14, 2011 3:43 PM
  • Jeff and Barbara,

    I have tested several variants of the solution and now understand how to work with my clients to chose the solution that best works in their Project Management envirtonment.

    I want to thank you both for the support you have provided.  It is very much appreciated.

    Thanks again,

    Frank


    Frank Records


    My pleasure Frank.  I think we helped each other.  I started in the same place you did.  I found your post when I was experiencing the same problem.  Your detailed test results helped me to confirm that I wasn't the only one experiencing the issue. 

    Regards,

    Jeff

    Monday, February 14, 2011 4:45 PM
  • Hi Jeff, experts

      Could you please help me.

     I have the same of issue with two our users. I check groups which include this users and then category permissions which include this groups. But none of this group and related category permissions with this groups does not contain Adjust Timesheet permission. Maybe i some did not understand correctly from your post.

    We use 14.0.4763.1000 version of Project Server in our environment.

    Tuesday, February 15, 2011 2:02 PM
  • Hi Alexey,

    since only two users are affected:

    • are they members of any group different to other users?
    • is timesheet manager other than themselves?

    Let us know!
    Barbara

    Tuesday, February 15, 2011 2:07 PM
    Moderator
  • Hi Barbara,

      Thank you for your reply

    • I think this issue related more then two our users, but only this users tell me about this issue. So i checked another user. He had the same issue. So, at this time i know about three users.
    • Two of this users are timesheet managers themselves, but one of them are not timesheet manager for themselves

    Alexey

    Wednesday, February 16, 2011 7:51 AM
  • Hi Alexey,

    if a user is his own timesheet manager, an administrative request which requires approval, will be approved automatically. This is the explanation for two of your users.

    Let's have a look at the third one:

    • Have you modified any of default groups and categories?
    • What groups is your third user member of?

    Let us know!
    Barbara

    Wednesday, February 16, 2011 8:06 AM
    Moderator

  • Hi Barbara,

      You right, if this two users are timesheet managers for themselves, his administrative time request will be approved automatically. But all of this three users functionally are heads of departments and other users submit to them administrative time-off requests. I mean that this three users can received administrative time-off requests not only from themselves.

      The issue is that these three users can see a reminder:

    You have X administrative time-off requests from resources pending your approval

    even after all these requests were approved , no matter how ( manually or automatically ) . And when this users (managers) follow the link - they do not see any administrative time-off requests.

       We have default and custom groups for this users on our Project server:


    Number of user

    Whether the user is timesheet manager for themselves?

    In which groups the user belongs?

     

    First user

    Yes

    Administrators Team Members First Custom group

    Second

    Yes

    Resource Managers Team Members Second Custom Group

    Third

    No

    Project Managers Resource Managers Team Members


      Personally, I have modified only default Resource Managers group. I added Manage Basic Project Security permission for this group via My Projects category. I am not sure exactly, but think that another permissions in default groups the same as default from install. (We migrate from 2007 to 2010 version through databases).

    First Custom group build  on one custom category (for some projects) witch have
    Second custom group build on one custom category (for all projects with some category security permission) witch have


     

     

    Wednesday, February 16, 2011 9:47 AM
  • Hi Alexey,

    so you have the opposite problem of Frank. You do see reminders, if there aren't any pending administrative times? Before going deeper into security: please ask your users if they have applied any filter on approval center? If they have applied any filter at some time, this filter will be kept until they select "No Filter".

    Regards
    Barbara

    Wednesday, February 16, 2011 9:57 AM
    Moderator
  • Hi Barbara,

       Yes, exactly. Our manager see reminders, but when he open approval center he does not see any pending administrative time on Approval center page. We check that Filter section have "No filter" value. Also we approve any updates in Approval Center and after that - filter section becomes inactive as entire ribbon from this page. But when this manager follow home PWA page he still see reminder about administrative time-off requests.

    Alexey

    Wednesday, February 16, 2011 12:09 PM
  • Hi Alexey,

    I have run out of ideas. I am also not able to replicate your issue.

    Filter section becomes inactive after approval, since there are no data left for filtering. That's also the reason why the whole ribbon is inactive - with two exception (History and Rule).

    Sorry
    Barbara

    Thursday, February 17, 2011 5:03 PM
    Moderator
  •      Hi Barbara,

      Thank you for your help and answers. In our environment i will try to reproduce and find the conditions under which it occurs.

    If I can get some additional information , i will tell you. So i posted another topic for this issue, because my question is different from the question that was addressed in this topic.

    Alexey
    Thursday, February 17, 2011 5:14 PM
  • Hi Alexey,

    good luck! I have set an alert to your new question and will follow the discussion. Perhaps I get some additional ideas in future?

    Regards
    Barbara

    Thursday, February 17, 2011 5:25 PM
    Moderator
  • Thanks!  We were experiencing the exact issue.  Your solution of a new category worked great.

     

    Wednesday, April 20, 2011 7:18 PM