none
Lync 2010 Installation_ WEbcomponents.msi installation error code 1603 RRS feed

  • Question

  • i am trying to install lync enterprise edition with 2 node of pools. i have installed 1 DC, 1 ADC, 1 SQL server, and 1 Pool server successfully, and i have assigned the right to sql account, and also to the administrator. now i am trying to install the 2nd pool server  and when i reach at "Setup or Remove Lync Server" it give me error " Error returned while Installing Webcomponents.msi( Feature_WebComponents_CommonFiles), Code 1603"

    Below is the log which i receive...

    Property(S): VersionNT = 601
    Property(S): Manufacturer = Microsoft Corporation
    Property(S): ProductCode = {B9EFB994-8B55-4B9C-8BF2-5AA346D3DEF2}
    Property(S): ProductLanguage = 1033
    Property(S): ProductName = Microsoft Lync Server 2010, Web Components Server
    Property(S): ProductVersion = 4.0.7577.0
    Property(S): ProductDisplayName = Lync Server 2010, Web Components Server
    Property(S): ARPURLINFOABOUT = http://www.microsoft.com/rtc
    Property(S): ARPHELPLINK = http://www.microsoft.com/rtc
    Property(S): ARPPRODUCTICON = Icon_Setup
    Property(S): Property_Internal_Website_Name = Lync Server Internal Web Site
    Property(S): Property_External_Website_Name = Lync Server External Web Site
    Property(S): Property_AuthenticatedUsersGroup = AUTHENTICATED USERS
    Property(S): Property_ListeningURL_CertProv = https://+:444/LiveServer/CertAuthProv
    Property(S): Property_Classes_Root_SE_Reg_Key = CLASSES_ROOT
    Property(S): Property_IIS_DCOM_Reg_Key = AppID\{9fa5c497-f46d-447f-8011-05d03d7d7ddc}
    Property(S): Property_ListeningURL_ConfValidator = https://+:444/LiveServer/AuthFramework/ConferenceValidation
    Property(S): PROPERTY_UCMA_RUNTIME_VERSION_REQUIRED = 4.0.7577.0
    Property(S): DefaultUIFont = WixUI_Font_Normal
    Property(S): WixUI_Mode = InstallDir
    Property(S): ErrorDialog = ErrorDlg
    Property(S): Property_RTCGroups = RTC Local Groups
    Property(S): Property_NetworkServiceLocalGroup = NETWORK SERVICE
    Property(S): Property_RTCLocalAdministrators = RTC Local Administrators
    Property(S): Property_RTCLocalAdministrators_Comment = RTC domain Server Administrators get local Central Management database access through this group
    Property(S): Property_RTCLocalReadOnlyAdministrators = RTC Local Read-only Administrators
    Property(S): Property_RTCLocalReadOnlyAdministrators_Comment = RTC domain Read-only Administrators get local Central Management database access through this group
    Property(S): Property_RTCLocalUserAdministrators = RTC Local User Administrators
    Property(S): Property_RTCLocalUserAdministrators_Comment = RTC domain User Administrators get local DCOM permissions through this group
    Property(S): Property_RTCLocalConfigReplicator = RTC Local Config Replicator
    Property(S): Property_RTCLocalConfigReplicator_Comment = Lync Server replication services are granted appropriate local permissions through this group
    Property(S): Property_RTCServerApplications = RTC Server Applications
    Property(S): Property_RTCServerApplications_Comment = Lync Server Server applications are granted appropriate local permissions through this group
    Property(S): Property_RTCServerLocalGroup = RTC Server Local Group
    Property(S): Property_RTCServerLocalGroup_Comment = Lync Server service accounts are granted appropriate local permissions through this group
    Property(S): Property_RTCComponentLocalGroup = RTC Component Local Group
    Property(S): Property_RTCComponentLocalGroup_Comment = Lync Server Web Components And MCU service accounts are granted appropriate local permissions through this group
    Property(S): Property_RTCLocalProvisioningService = RTC Local Provisioning Service
    Property(S): Property_RTCLocalProvisioningService_Comment = Lync Server User Provisioning applications are granted appropriate local permissions through this group
    Property(S): MsiLogging = voicewarmup
    Property(S): SecureCustomProperties = ALLUSERS;ARPHELPLINK;ARPINSTALLLOCATION;ARPNOREPAIR;ARPPRODUCTICON;ARPURLINFOABOUT;NETFRAMEWORK35;NETFRAMEWORK35_SP_LEVEL;PROPERTY_ADMINTOOLS_INSTALLED;PROPERTY_APPSERVER_INSTALLED;PROPERTY_ARCH_INSTALLED;PROPERTY_AVMCU_INSTALLED;PROPERTY_CORE_INSTALLED;PROPERTY_DATAMCU_INSTALLED;PROPERTY_DOT_NET_INSTALLED;PROPERTY_EXISTING_BUILD_NUMBER;PROPERTY_EXISTING_PRODUCT_VERSION;PROPERTY_IIS_ASP_NET;PROPERTY_IIS_DEFAULTDOCUMENT;PROPERTY_IIS_HTTPCOMPRESSIONSTATIC;PROPERTY_IIS_HTTPERRORS;PROPERTY_IIS_HTTPLOGGING;PROPERTY_IIS_HTTPTRACING;PROPERTY_IIS_ISAPIEXTENSIONS;PROPERTY_IIS_ISAPIFILTER;PROPERTY_IIS_LOGGINGLIBRARIES;PROPERTY_IIS_MANAGEMENTCONSOLE;PROPERTY_IIS_MANAGEMENTSCRIPTINGTOOLS;PROPERTY_IIS_NETFXEXTENSIBILITY;PROPERTY_IIS_REQUESTFILTERING;PROPERTY_IIS_STATICCONTENT;PROPERTY_IIS_WIN_AUTH;PROPERTY_IIS7_APPHOST_CONFIG;PROPERTY_INSTALLED_DIR;PROPERTY_MEDIATION_INSTALLED;PROPERTY_MONSRV_INSTALLED;PROPERTY_SERVER_INSTALLED;PROPERTY_SERVERROLE_INSTALLED;PROPERTY_UCMA_RUNTIME_INSTALLED;PROPERTY_UCME_REDIST_INSTALLED;PROPERTY_VERSION_VCREDIST_INSTALLED;PROPERTY_VERSION_WWW_SERVICE_INSTALLED;PROPERTY_WEBCOMPONENTS_INSTALLED;PROPERTY_WSMAN_SCHEMA_SOURCE_LOCATION;PROPERTY_WSMAN_SCHEMA_TARGET_LOCATION;WEBSERVICES_ACTIVATED;WIX_DOWNGRADE_DETECTED;WIX_UPGRADE_DETECTED
    Property(S): PROPERTY_CORE_INSTALLED = {9521B708-9D80-46A3-9E58-A74ACF4E343E}
    Property(S): PROPERTY_UCMA_RUNTIME_INSTALLED = {100B5297-413F-435B-8CBB-A3D21487C221}
    Property(S): MsiLogFileLocation = C:\Users\Administrator.demotest\AppData\Local\Temp\Add-WebComponents.msi-Feature_WebComponents_CommonFiles-[2011_04_29][11_17_59].log
    Property(S): PackageCode = {05A8892A-1911-4CD5-8585-C4B0B8AC7241}
    Property(S): ProductState = -1
    Property(S): PackagecodeChanging = 1
    Property(S): ADDLOCAL = Feature_WebComponents_CommonFiles
    Property(S): REBOOT = ReallySuppress
    Property(S): CURRENTDIRECTORY = C:\Program Files\Microsoft Lync Server 2010\Deployment
    Property(S): CLIENTUILEVEL = 3
    Property(S): CLIENTPROCESSID = 1264
    Property(S): VersionDatabase = 405
    Property(S): VersionMsi = 5.00
    Property(S): VersionNT64 = 601
    Property(S): WindowsBuild = 7600
    Property(S): ServicePackLevel = 0
    Property(S): ServicePackLevelMinor = 0
    Property(S): MsiNTProductType = 3
    Property(S): MsiNTSuiteEnterprise = 1
    Property(S): WindowsVolume = C:\
    Property(S): SystemFolder = C:\Windows\SysWOW64\
    Property(S): RemoteAdminTS = 1
    Property(S): TempFolder = C:\Users\ADMINI~1.UFO\AppData\Local\Temp\
    Property(S): ProgramFilesFolder = C:\Program Files (x86)\
    Property(S): CommonFilesFolder = C:\Program Files (x86)\Common Files\
    Property(S): AppDataFolder = C:\Users\Administrator.demotest\AppData\Roaming\
    Property(S): FavoritesFolder = C:\Users\Administrator.demotest\Favorites\
    Property(S): NetHoodFolder = C:\Users\Administrator.demotest\AppData\Roaming\Microsoft\Windows\Network Shortcuts\
    Property(S): PersonalFolder = C:\Users\Administrator.demotest\Documents\
    Property(S): PrintHoodFolder = C:\Users\Administrator.demotest\AppData\Roaming\Microsoft\Windows\Printer Shortcuts\
    Property(S): RecentFolder = C:\Users\Administrator.demotest\AppData\Roaming\Microsoft\Windows\Recent\
    Property(S): SendToFolder = C:\Users\Administrator.demotest\AppData\Roaming\Microsoft\Windows\SendTo\
    Property(S): TemplateFolder = C:\ProgramData\Microsoft\Windows\Templates\
    Property(S): CommonAppDataFolder = C:\ProgramData\
    Property(S): LocalAppDataFolder = C:\Users\Administrator.demotest\AppData\Local\
    Property(S): MyPicturesFolder = C:\Users\Administrator.demotest\Pictures\
    Property(S): AdminToolsFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\
    Property(S): StartupFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\
    Property(S): ProgramMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
    Property(S): StartMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\
    Property(S): DesktopFolder = C:\Users\Public\Desktop\
    Property(S): FontsFolder = C:\Windows\Fonts\
    Property(S): GPTSupport = 1
    Property(S): OLEAdvtSupport = 1
    Property(S): ShellAdvtSupport = 1
    Property(S): MsiAMD64 = 6
    Property(S): Msix64 = 6
    Property(S): Intel = 6
    Property(S): PhysicalMemory = 1024
    Property(S): AdminUser = 1
    Property(S): MsiTrueAdminUser = 1
    Property(S): LogonUser = Administrator
    Property(S): UserSID = S-1-5-21-947455399-3617606806-2002455702-500
    Property(S): UserLanguageID = 1033
    Property(S): ComputerName = POOL2
    Property(S): SystemLanguageID = 1033
    Property(S): ScreenX = 1024
    Property(S): ScreenY = 768
    Property(S): CaptionHeight = 19
    Property(S): BorderTop = 1
    Property(S): BorderSide = 1
    Property(S): TextHeight = 16
    Property(S): TextInternalLeading = 3
    Property(S): ColorBits = 32
    Property(S): TTCSupport = 1
    Property(S): Time = 11:18:24
    Property(S): Date = 4/29/2011
    Property(S): MsiNetAssemblySupport = 2.0.50727.4927
    Property(S): MsiWin32AssemblySupport = 6.1.7600.16385
    Property(S): RedirectedDllSupport = 2
    Property(S): MsiRunningElevated = 1
    Property(S): Privileged = 1
    Property(S): USERNAME = Windows User
    Property(S): DATABASE = C:\Windows\Installer\9df67.msi
    Property(S): OriginalDatabase = C:\ProgramData\Microsoft\Lync Server\Deployment\cache\4.0.7577.0\setup\WebComponents.msi
    Property(S): UILevel = 2
    Property(S): Preselected = 1
    Property(S): ACTION = INSTALL
    Property(S): ROOTDRIVE = C:\
    Property(S): CostingComplete = 1
    Property(S): OutOfDiskSpace = 0
    Property(S): OutOfNoRbDiskSpace = 0
    Property(S): PrimaryVolumeSpaceAvailable = 0
    Property(S): PrimaryVolumeSpaceRequired = 0
    Property(S): PrimaryVolumeSpaceRemaining = 0
    Property(S): INSTALLLEVEL = 1
    Property(S): SOURCEDIR = C:\ProgramData\Microsoft\Lync Server\Deployment\cache\4.0.7577.0\setup\
    Property(S): SourcedirProduct = {B9EFB994-8B55-4B9C-8BF2-5AA346D3DEF2}
    Property(S): PROPERTY_LOCALGROUPLOCATION = POOL2
    Property(S): ProductToBeRegistered = 1
    MSI (s) (EC:50) [11:18:24:443]: Note: 1: 1708
    MSI (s) (EC:50) [11:18:24:443]: Product: Microsoft Lync Server 2010, Web Components Server -- Installation failed.

    MSI (s) (EC:50) [11:18:24:444]: Windows Installer installed the product. Product Name: Microsoft Lync Server 2010, Web Components Server. Product Version: 4.0.7577.0. Product Language: 1033. Manufacturer: Microsoft Corporation. Installation success or error status: 1603.

    MSI (s) (EC:50) [11:18:24:455]: Deferring clean up of packages/files, if any exist
    MSI (s) (EC:50) [11:18:24:455]: MainEngineThread is returning 1603
    MSI (s) (EC:84) [11:18:24:458]: RESTART MANAGER: Session closed.
    MSI (s) (EC:84) [11:18:24:458]: No System Restore sequence number for this installation.
    === Logging stopped: 4/29/2011  11:18:24 ===
    MSI (s) (EC:84) [11:18:24:459]: User policy value 'DisableRollback' is 0
    MSI (s) (EC:84) [11:18:24:459]: Machine policy value 'DisableRollback' is 0
    MSI (s) (EC:84) [11:18:24:459]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (EC:84) [11:18:24:459]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (EC:84) [11:18:24:459]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (EC:84) [11:18:24:459]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (EC:84) [11:18:24:459]: Restoring environment variables
    MSI (s) (EC:84) [11:18:24:513]: Destroying RemoteAPI object.
    MSI (s) (EC:98) [11:18:24:513]: Custom Action Manager thread ending.
    MSI (c) (F0:10) [11:18:24:515]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (F0:10) [11:18:24:516]: MainEngineThread is returning 1603
    === Verbose logging stopped: 4/29/2011  11:18:24 ===

     

     

    i have searched too much bt still of no use. i have turned off the firewall but still the issue is same.. is there anyone who can help me in this regard.


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83
    Friday, April 29, 2011 7:41 AM

Answers

  • Guys this error occurs if you install full features during installation of the prerequisites. if you receive this error then there is no way out, although you can install the web component feature by manually running webcomponent.msi in the Lync setup files, but at later stages you'll face the issues. so best way is the fresh installation,while installing per-requisites only install those features which are required by Lync you can use this power shell command to install the features :

    Import-module servermanager

    Add-WindowsFeature as-net-framework,RSAT-ADDS,Web-Static-Content,Web-Default-Doc,Web-Http-Errors,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Http-Logging,Web-Log-Libraries,Web-Http-Tracing,Web-Windows-Auth,Web-Filtering,Web-Stat-Compression,Web-Mgmt-Console,Web-Scripting-Tools,Web-Client-Auth,Desktop-Experience,Desktop-Experience

    don't forget to reboot the machine..

    i hope this will help you

    Regards,

    Atif Bilal


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83


    • Marked as answer by Atif Bilal Wednesday, May 16, 2012 6:14 AM
    • Edited by Atif Bilal Wednesday, May 16, 2012 6:16 AM some spelling mistake
    Wednesday, May 16, 2012 6:13 AM

All replies

  • Hmm... event logs might give some more info on the install.  That error is pretty generic, but when I have seen it it was a file issue.  Try to copy the install files locally and run again, as Lync "installs" the setup utility before you get to this step you might want to uninstall it and reinstall as well.  Also make sure you have free space on the drive =)


    Friday, April 29, 2011 4:53 PM
  • still no use, i tried this too.. :(( really stopped at this stage now
    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83
    Monday, May 2, 2011 10:29 AM
  • Hi, Atif,

       Here I provide some suggestions.

    1.        For the error code 1603, this means a system restart may be required because the file being updated is also currently in use. Users may be given the opportunity to avoid some system restarts by using the FilesInUse Dialog or the MsiRMFilesInUse Dialog.

    2.        Installation of the Web Components Server also requires Internet Information Services (IIS) 6.0 to be installed in advance. So please check the configuration of IIS.

    3.        Please try to install webcomponents manually, then run the step Setup or Remove Lync Server Components.

       Above all, hope helpful.


    Please remember to click “Mark As Answer” on the post that helps you, and to click “Unmark As Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 5, 2011 8:44 AM
    Moderator
  • Hi Noya,

    thnx for your response, we tried all steps you mentioned above, but i was still unsuccessful.  although i succeeded to install the web components just by selecting a new folder other than the folder created by default during setup preparation. but still i want to know what is the issue, i may face this issue  again, so i want to avoid it..

    thanks in advance if someone can help


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83
    Thursday, May 5, 2011 9:13 AM
  • Hi, Atif,

       After you succeeded to install web components, what happened when you ran the step Setup or Remove Lync Server Components? Any error message or logs?

       And your 1st pool server is normal, so is there any difference between them? Please have a check.


    Please remember to click “Mark As Answer” on the post that helps you, and to click “Unmark As Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 6, 2011 2:14 AM
    Moderator
  • hi Noya,

    yes i checked the logs, and event viewer, nothing special over there. i just installed 2nd node of pool, while 1st node was working fine. after installation i was able to register to both nodes individually and also using pool. both pool servers are working fine now. but still searching why it happend


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83
    Friday, May 6, 2011 6:38 AM
  • Hi guys

    i have this problem in step 2:Setup or Remove Lync server component

    but my error msg like this:

     Error: Error returned while installing ReachFonts.msi(Feature_WebComponent_ReachFonts), code 1603. Please consult log at C:\Users\fulluser\AppData\Local\Temp\Add-ReachFonts.msi-Feature_WebComponent_ReachFonts-[2011_06_07][12_01_56].log 

     

    plz somebody help to solve this problem.

    • Proposed as answer by tinmyint Tuesday, May 15, 2012 9:48 AM
    • Unproposed as answer by tinmyint Tuesday, May 15, 2012 9:48 AM
    Tuesday, June 7, 2011 7:32 AM
  • I also have the same problem, how to do. very urgently, i cannot proceed the installation now, pls help me, thanks you very much...
    Tuesday, May 15, 2012 9:47 AM
  • Guys this error occurs if you install full features during installation of the prerequisites. if you receive this error then there is no way out, although you can install the web component feature by manually running webcomponent.msi in the Lync setup files, but at later stages you'll face the issues. so best way is the fresh installation,while installing per-requisites only install those features which are required by Lync you can use this power shell command to install the features :

    Import-module servermanager

    Add-WindowsFeature as-net-framework,RSAT-ADDS,Web-Static-Content,Web-Default-Doc,Web-Http-Errors,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Http-Logging,Web-Log-Libraries,Web-Http-Tracing,Web-Windows-Auth,Web-Filtering,Web-Stat-Compression,Web-Mgmt-Console,Web-Scripting-Tools,Web-Client-Auth,Desktop-Experience,Desktop-Experience

    don't forget to reboot the machine..

    i hope this will help you

    Regards,

    Atif Bilal


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83


    • Marked as answer by Atif Bilal Wednesday, May 16, 2012 6:14 AM
    • Edited by Atif Bilal Wednesday, May 16, 2012 6:16 AM some spelling mistake
    Wednesday, May 16, 2012 6:13 AM
  • Also always keep your setup files stored locally.. and also do the installation with domain "Administrator" account.. although domain administrator account becomes local administrator account of any server.. if you are using some other account, make sure that account has the local administrator rights on that machine.

    best of Luck

    Regards

    Atif


    Atif Bilal MCITP Enterprise Engg. Symbia Pvt. Ltd. Islamabad Pakistan Skype: bilalatif83

    Wednesday, May 16, 2012 6:20 AM
  • Atif,

    i just had this issue in my lab today. I ended up blowing away the VM and rebuilt it!! !! I could've reinstalled all the prereqs.


    Z-Hire -- Automate IT Account creation process ( AD / Exchange / Lync )
    Z-Term -- Automate IT account termination process ( AD / Exchange )

    Thursday, May 17, 2012 3:42 AM
  • Hello,

    Check in the LCSSetup_Commands.log at the bottom you should see something like:

    Filename: \\?\C:\Windows\system32\inetsrv\config\applicationHost.config
    Line Number: 428
    Description: Cannot add duplicate collection entry of type 'add' with unique key attribute 'name' set to 'OCSAuthHelperModule'

    Then the solution is simple: Edit ApplicationHost.config --> and remove OCSAuthHelperModule.

    Thats all (ofcourse you can delete IIS roles and excess features before you do this.) but there's by no means a need for a re-install or anything like that.. just a quick edit ;-)

    Solution was found at: http://blog.chrislehr.com/2011/02/lync-2010-upgrading-to-rtm-and-web.html

    Regards,

    Marco


    Key4ce - IT professionals: www.key4ce.eu


    • Proposed as answer by M. Tiggelaar Monday, November 12, 2012 9:16 PM
    • Edited by M. Tiggelaar Monday, November 12, 2012 9:18 PM
    Monday, November 12, 2012 9:16 PM
  • If it helps, here's how I just fixed this problem:

    (Backup your files before doing this)

    1) I looked at the event viewer and got: Product: Microsoft Lync Server 2010, Web Components Server -- Error 25542. Failed to find node: /configuration/system.webServer/security/authentication/windowsAuthentication in XML file: C:\Windows\system32\inetsrv\config\applicationHost.config, system error: -2147020584

    2) Went onto the front end and found the C:\Windows\system32\inetsrv\config\applicationHost.config file.

    3) I found this section:

                    <windowsAuthentication enabled="true" useKernelMode="false">
                        <providers>
                            <add value="Negotiate" />
                            <add value="NTLM" />
                        </providers>
                    </windowsAuthentication>

    And I disabled it by turning it into this

    <!--

                    <windowsAuthentication enabled="true" useKernelMode="false">
                        <providers>
                            <add value="Negotiate" />
                            <add value="NTLM" />
                        </providers>
                    </windowsAuthentication>

    -->

    4) I found the section it spoke about in the error:

    It looked like this:

           <authentication>

                    <basicAuthentication />

                    <clientCertificateMappingAuthentication enabled="false" />

                    <digestAuthentication />

                    <iisClientCertificateMappingAuthentication />

                </authentication>

    5) I added Windowsauthentication like this:

           <authentication>

                    <basicAuthentication />

                    <clientCertificateMappingAuthentication enabled="false" />

                    <digestAuthentication />

                    <iisClientCertificateMappingAuthentication />

                    <windowsAuthentication />

                </authentication>

    6) Did an IISReset and ran the installer again and it worked fine.

    • Proposed as answer by antsuc Tuesday, July 9, 2019 2:27 PM
    Tuesday, May 28, 2013 8:33 PM
  • I had similar issue

    Error: Error returned while installing ReachFonts.msi(Feature_WebComponent_ReachFonts), code 1603. Please consult log at C:\Users\fulluser\AppData\Local\Temp\Add-ReachFonts.msi-Feature_WebComponent_ReachFonts-[2011_06_07][12_01_56].log.

    We just go back and install IIS components and and few feature which was missing.

    IIS component

    basic auth,Digitial authentication,

    feature level

    Message Queuing | Message Queuing Services
    HTTP Activation (Important!)  Non-HTTP Activation.

    And reconfirm if any roles and feature missing installed it.

    reboot the server.

    Friday, September 13, 2013 10:48 AM
  • Tom_S_F - I know you wrote this in 2013.. but you must have seen into the future!
    You saved me in 2019 - thank you

    For others playing along at home. Search for "<authentication>" and find the block that doesn't have the "windowsAuthentication" block in it then add it. 

    I found a block that had it and was pulling my hair out because it was there. Turns out I was looking in the wrong spot and just needed to keep searching.

    Tuesday, July 9, 2019 2:27 PM