none
Mail fow issue with Edge Transport Servers (2013). Incorrect "Centralized Mail Flow Agent" REDIRECT on internet bound email.

    Question

  • Hi guys,

    I have a interesting one for the Exchange Edge Transport experts out there. To give context, we have the following mail flow topology.

    • 2 X AD forest (no trust, different namespaces) each with their own Exchange/ Office 365 Organisations. We call one DomainA (domainA.com) and the other DomainB (domainB.com).
    • DomainA has the Exchange Edge Transport Servers. We've commissioned them to do address rewrites for both DomainA and DomainB to become lets say domainC.com. This rewrite is done on Outbound only for identity reasons. Exchange Edge Subscription has been created successfully and is working fine.
    • DomainA, to accept all email from DomainB has been configured with all the domains from both Exchange Organisations. So Essentially DomainA has a number of Internal-Relay accepted domains. 
    • DomainB "Send Connector" sends all email into DomainA organisation. Mail is delivered successfully into the organisation due to accepted relay.
    • Mail flow both DomainA and DomainB hops in DomainA to the Edge Transport Servers correctly.
    • EdgeServer accepts email. And this is where it goes a bit wrong.
    1. For domainA.com, mail is rewritten as domainC.com and sent outboutn
    2. For domainB.com, mail is flowing to a Event REDIRECT on a "Centralized Mail Flow Agent" source AGENT. The mail is essentially lost. No NDR's no nothing. 

    Below is the message tracking log information:

    [PS] C:\Windows\system32>Get-MessageTrackingLog -MessageSubject Test123 | fl *


    Timestamp               : 6/21/2017 1:26:55 PM
    ClientIp                : 10.XX.1.XX
    ClientHostname          : ProdSERVEREx1.domaina.com
    ServerIp                : 10.XX.131.XX
    ServerHostname          : azSERVEREx1
    SourceContext           : 08D4B7D352611AF4;2017-06-21T05:26:54.832Z;0
    ConnectorId             : azSERVEREx1\Default internal receive connector azSERVEREx1
    Source                  : SMTP
    EventId                 : RECEIVE
    InternalMessageId       : 940597837828
    MessageId               : <ME1PR01MB197194A36F2AE418DF87AC26D8DA0@ME1PR01MB1971.ausprd01.prod.outlook.com>
    Recipients              : {bob@yahoo.com}
    RecipientStatus         : {}
    TotalBytes              : 7920
    RecipientCount          : 1
    RelatedRecipientAddress :
    Reference               :
    MessageSubject          : Test123
    Sender                  : bob@domainb.com
    ReturnPath              : bob@domainb.com
    Directionality          : Incoming
    TenantId                :
    OriginalClientIp        : 65.XXX.88.XXX
    MessageInfo             : 11A:
    MessageLatency          :
    MessageLatencyType      : None
    EventData               : {[FirstForestHop, ProdSERVEREx1.domaina.com], [Oorg, domainb.com], [ProxyHop1,
                              ProdSERVEREx1.domaina.com(10.XX.1.XX)], [DeliveryPriority, Normal], [AccountForest, localhost]}

    Timestamp               : 6/21/2017 1:26:55 PM
    ClientIp                :
    ClientHostname          :
    ServerIp                :
    ServerHostname          : azSERVEREx1
    SourceContext           : Centralized Mail Flow Agent
    ConnectorId             :
    Source                  : AGENT
    EventId                 : REDIRECT
    InternalMessageId       : 940597837828
    MessageId               : <ME1PR01MB197194A36F2AE418DF87AC26D8DA0@ME1PR01MB1971.ausprd01.prod.outlook.com>
    Recipients              : {bob@yahoo.com}
    RecipientStatus         : {}
    TotalBytes              : 7920
    RecipientCount          : 1
    RelatedRecipientAddress :
    Reference               : {940597837828}
    MessageSubject          : Test123
    Sender                  : bob@domainb.com
    ReturnPath              : bob@domainb.com
    Directionality          : Incoming
    TenantId                :
    OriginalClientIp        :
    MessageInfo             :
    MessageLatency          :
    MessageLatencyType      : None
    EventData               : {[ConnectorRedirect, smtp:domaina.com(smtp:domaina.com)], [DeliveryPriority,
                              Normal], [AccountForest, localhost]}

    So what's the go? What am I missing here :-).

    Looking forward to people's feedback!

    Cheers,

    Bob

    Wednesday, June 21, 2017 6:02 AM

All replies

  • Hi,

    It seems the messages cannot send out via the Edge server.

    Does these messages queued in the queues? Please run the command: get-queue | get-message and check the detailed messages.

    Your send connector need to be configured for the messages from domain B to be sent out.

    Please post the send connector information on the Domain A via the command below:

    Get-sendconnector | fl

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 22, 2017 9:19 AM
    Moderator