Direct Access 2012 console failes to load config because of a incomplete static address pool RRS feed

  • Question

  • I have been trying different settings with DA and enabled VPN/DA and set it to use DHCP. After the wizard completed the console didn't refresh and now complains "Settings for server " " cannot be retrieved. VPN is configured to allocate IP addresses using a static address pool, but no IP address ranges are configure"

    If I go to the RRAS console the APv4 address assignment is greyed out and I cannot edit it.

    I cannot uninstall the DA/RRAS role because DA is configured.

    Only option left is to reinstall windows which I would like to avoid as everything is working.

    How can I reset the configuration while the console/wizard is locked out?

    Tech with Alberta Education

    Friday, June 28, 2013 3:26 PM

All replies

  • On the Direct Access server, run powershell as an administrator. 

    Then run the following command: 

    Set-VpnIPAddressAssignment -IPAssignmentMethod ‘DHCP’

    ... then refresh the console. 
    • Proposed as answer by Dave Puetz Saturday, August 24, 2013 10:09 AM
    Thursday, August 8, 2013 7:55 PM
  • Thanks Dave, that worked!
    Friday, October 4, 2013 10:15 AM
  • Worked like a charm!

    thanks very much Dave.

    besides the solution, which is easy and fast - can you elaborate a little bit about why this happens?

    is it something we did wrong while configuring the DirectAccess\VPN or does anyone who configures VPN must add this row as a part of the normal step-by-step configuration?

    Tamir Levy

    Saturday, October 18, 2014 5:40 PM
  • Perfect! Thank you very much! Solve me a lot of trouble.
    Friday, June 12, 2015 9:20 AM
  • Thanks Dave :)
    Tuesday, January 26, 2016 4:40 PM