locked
Problem to work in standalone mode RRS feed

  • Question

  • Hello,

     

    I have a laptop computer with Vista enterprise installed on it, at work. I have a Windows server 2003 KMS server on my network at work. Vista is activated on ks server.

    When my laptop connect to the network with a cable, it is working very fine. When I wan to use it as a standalone computer (no network) for example at home for call duty,I manage sometime to logon but I have an error message that says 'Windows encountered a problem. The system will be restart in 1 minute" or sometimes I can not logon and  have 'the RPC server is unavailaible".

    Once on the network I check the event viewer and the only error message the following :

     

    eventID : 1000
      source : Application Error
      Description : Faulting application lsass.exe, version 6.0.6000.16386, time stamp 0x4549afbe, faulting   module   ItDAC.dll_unloaded, version 0.0.0.0, time stamp 0x456d9522, exception code 0xc0000005, fault offset 0x0230daaa, process id 0x26c, application start time 0x01c7840de4937194.

    and


     eventID : 1015
    source : wininit
    descritpion : A critical system process, C:\Windows\system32\lsass.exe, failed with status code 255. The machine must now be restarted.

    Does anyone get a solution, please ?
    Wednesday, April 25, 2007 8:26 PM

All replies

  • Hi, I have the same problem.  This is a copy of Vista Business that was pre-loaded on an HP-Compaq NX7400 laptop.  The internal IT Dept have not yet progressed their Vista project to a point where we have a KMS, so I logon to a standard 2003 domain.

     

    I only built this image last week so have not installed much software.  When the problem occurs I note the following things in the brief time before the machine shuts down:

    The sidebar starts but the apps in it do not, or only one of them does
    Running eventvwr.exe produced MMC errors
    These may both be caused by the RPC service falling over(?) and not actually be related to the problem itself.

     

    Until I saw the lsass errors, I was thinking that given the third-party unsupported nature of the sidebar gadgets might be the cause (i.e. gadgets start without internet connectivity, any that require net access fall over, possible lack of error handling causes system problem) but the lsass.exe errors suggests that this is related to the absence of the domain itself.

    Update: Could not post this last night due to this issue crashing the laptop AGAIN!  Have now traced this to errors caused when starting the VMware Authorization Service for VMware Server running locally.  Are you also running VMware Server?

     

    Tip:  Try setting all the VMware services to start manually, then restart the machine without network connectivity.  If the error does not appear, wait for everything else to start, then initialize the vmware auth service and wait a few seconds.  Checking the VMware-serverd logfile shows the following:

     

    Apr 30 11:30:51: app| VMHS: Impersonate runas couldnt find : c:\virtual machines\winxp x64\windows xp professional x64 edition.vmx

     

    pr 30 11:30:51: app| VMHS: Couldnt find a user to impersonate as for: c:\virtual machines\winxp x64\windows xp professional x64 edition.vmx
    Apr 30 11:30:51: app| SOCKET 1 closing socket
    Apr 30 11:30:51: app| SOCKET 1 Final release; freeing asock struct
    Apr 30 11:31:07: app| Error 12: Malformed response from server
    Apr 30 11:31:07: app| SP: Removing VM: c:\virtual machines\winxp x64\windows xp professional x64 edition.vmx

     

    This happens for each VM (both 32-bit and 64-bit, in case you wondered)

     

    Not sure why this is a problem though, since the service is attempting to start using the local system account, and it is the local security authority subsystem that falls over, but why does lsass need to see the domain to validate it's own local system account?

     

    I don't really need Server edition, I might just switch to workstation, as we have the licenses for it already.

    Monday, April 30, 2007 1:29 PM
  • Thanks so much I had the same problem.  Disabled all VM startup services and I was finally able to log on offline.  By the way I have the latest VM workstation installed. I did notice an audit failure in the security log.  It was for the __vmware_user__ , it listed the domain as our AD domain and not the local computer.
    Monday, April 30, 2007 2:41 PM
  • I finaly find the problem. My laptop has a digital finger reader and I installed the driver and the software Credential manager from HP.
    I uninstalled the software credential manager and the problem solved.

    Monday, April 30, 2007 2:50 PM
  • Hi Ryd.  When you say the latest version, are you using the 6.0 Beta, or v5.5.4 (the latest official release)?

    Wednesday, May 2, 2007 8:28 AM
  • Penfold2006 I am using the beta version.

     

    Ancksu It is funny you mention that because i have an HP with a digital finger reader and Credential manager installed and I am able to log in offline using it.

    Wednesday, May 2, 2007 1:17 PM
  • There is definately something going on with our unique combination of hardware and software.  I have an HP nw8440 laptop also with the finger reader, also running VMware Workstation 6.0 RC and am getting the same lsass application errors.  The first time I ever saw the problem was when I was installing VMware Workstation.  I will definatly try to disable the services from starting automatically.  I imagine that will fix my issue as well.  I would hate to turn off the finger reader.  Kind of cool function in a geeky way.

     

    Thanx,

    Matt

    Thursday, May 3, 2007 2:10 AM
  • Well until everyone started pitching in with info here I was thinking this was a vmware issue, but the common factor throughout these posts appears to be Vista authentication technology.  I have now removed my laptop from the domain and the issue has gone away.  This is too weird, since the vmware authorisation service is running as the local system account, so why is lsass.exe (note that is the "local security authority subsystem", after all) even looking at the domain?

     

    Incidentally, has everyone turned off UAC?  That is known to break stuff, but was the first thing I switched off after I received the machine.  UAC clearly is not causing my issue, but I'm just curious to see if it might be affecting things for others.

     

    Also, can someone try disabling credentials manager and see if that has any effect?  I'm going to keep plugging away with Sysinternals tools and stuff and see what I can come up with.

    Thursday, May 3, 2007 4:24 PM
  • FYI, replacing VMware Server with Workstation 6.0 resolved this issue.

     

    That said, Vista appears to be in dire need of a service pack...

    Sunday, May 13, 2007 12:10 PM
  • My laptop is a HP-Compaq 6715b with vista, digital finger reader and credential manager installed, the computer is a member of a domain and i had now problem logging on offline until i installed the latest VMWare Player (2.0.2).

     

    Now i get the exact same symptoms and errors, most of the time i cant log in and the computer reboots.

     

    I think i'll try to disable the VMWare services or uninstall it completely.

     

     

     

    Friday, February 15, 2008 6:31 PM
  • I had the same problem with a new HP 2510p and Vista and also digital finger reader. The machine rebooted always two times before allow me to log on. After read yours posts, today I have changed VMware services to manual and the problem dissapear.

    Many thanks to all of you.

     

    Sunday, February 17, 2008 6:50 PM
  • Same problem!  I'm so glad I found this thread...

     

    Vista Enterprise with SP1

    Fingerprint reader

    VMWare server installed

    Login doesn't work - gives "RPC server unavailable"

    Event log shows lsass.exe crashing on startup

     

    I think I'll go back to just using MS Virtual Server instead of VMWare's product and hopefully that'll fix it.

     

    Thursday, February 28, 2008 1:43 AM
  • You guys helped me a lot, thanks!
    Just for update:

    Asus V1SN with Fingerprint Reader
    VMware Server 1.0.4

    I also noticed that this problem occures less often, when a lan cable is plugged in.
    (Without the error occures virtually every time I start the laptop, with lan cable only once in a while)

    I have another problem, that might be related to this:
    The laptop starts quit fast (30s) to logon screen and the message "Push CTRL ALT DEL" apprears, but I have to wait 90s before the password dialog appears.
    Sunday, July 6, 2008 7:06 PM
  • I have the same problem with HP 8510p and it is the Fingerprint Reader as the problem started after I installed "HP Protect Tool Security Manager" and started using the FingerPrint Reader.   

    I rebuilt the machine from scratch and the error started happening with this tool and using the Fingerprint reader.   I don't have VMWare server installed
    Monday, January 12, 2009 5:02 PM
  • Hey Guys,

    I had the same problem on my Probook 6545b on Windows7 Pro 64bit. I solved the issue by starting the services from VMWare Workstation with a delay.

    Regards Nick


    Monday, January 25, 2010 7:45 PM