locked
Restore Documents and Settings to it's default junction behavior RRS feed

  • Question

  • I was fooling around with the Documents and Settings junction. I didn't know any better and right clicked it and selected "Take ownership". It was only after that I learned that it didn't actually exist and was only for older program installers to redirect them accordingly. How can I fix this? Is there any possible way that doesn't involve completely reinstalling Windows 7?
    Thursday, February 23, 2012 10:50 PM

Answers

  • Hi,

    I have checked this on my lab. If Documents and Settings is in your Windows partition, the default owner of the Documents and Settings is SYSTEM. You can click Edit and change the owner to SYSTEM.

    Hope this helps



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Friday, February 24, 2012 9:21 AM
  • Hi,

    The issue is caused by the removed system security control.

    In order to repair this, you should set the permissions to default.

    Please logon your Administrator Account and refer to the following figures:     

    Figure1: Change the owner to your Administrator Account.



    Figure2: Establish the following permission entries.




    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:40 AM
  • Figure3: Permissions of SYSTEM and your Administrator Account (Both Full Control).

    Figure4:Permissions of Everyone (Allow).


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:41 AM
  • Figure5: Permissions of Everyone (Deny).

    At last, don’t forget to change the owner to SYSTEM.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:41 AM
  • Hi,

    Please refer to What is an administrator account?

    However, User Account Control can protect your system and only give you the permissions of a standard user—even if you’re logged on as an administrator.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Wednesday, February 29, 2012 2:20 AM
    Wednesday, February 29, 2012 1:46 AM

All replies

  • Hi,

    I have checked this on my lab. If Documents and Settings is in your Windows partition, the default owner of the Documents and Settings is SYSTEM. You can click Edit and change the owner to SYSTEM.

    Hope this helps



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Friday, February 24, 2012 9:21 AM
  • I did that. Then removed all permissions from every user. I no longer see the padlock on it. Is that a bad thing? x.x
    Friday, February 24, 2012 7:06 PM
  • Hi,

    The issue is caused by the removed system security control.

    In order to repair this, you should set the permissions to default.

    Please logon your Administrator Account and refer to the following figures:     

    Figure1: Change the owner to your Administrator Account.



    Figure2: Establish the following permission entries.




    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:40 AM
  • Figure3: Permissions of SYSTEM and your Administrator Account (Both Full Control).

    Figure4:Permissions of Everyone (Allow).


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:41 AM
  • Figure5: Permissions of Everyone (Deny).

    At last, don’t forget to change the owner to SYSTEM.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Tuesday, February 28, 2012 2:07 AM
    Tuesday, February 28, 2012 1:41 AM
  • Thanks. Everything seems okay. Just one more question. What about separate user accounts? Like mine? It's the only account on my computer and is an administrator. Does that just fall under The Administrator permissions?
    Tuesday, February 28, 2012 2:09 AM
  • Hi,

    Please refer to What is an administrator account?

    However, User Account Control can protect your system and only give you the permissions of a standard user—even if you’re logged on as an administrator.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by BlazeFaia Wednesday, February 29, 2012 2:20 AM
    Wednesday, February 29, 2012 1:46 AM