none
clearing cache

    Question

  • Hi all,
                 I tried to clear the cache  by going through the following steps
    Start>All Programs>Microsoft Office PerformancePoint Server 2007>PerformancePoint Add-In for Excel Configuration Settings . But the Clear cache button is always disabled. How to enable it? Or any other way to clear all my cache.
     I need to clear the cache because the values are not in the cube. But the values still prevails in the cache and when i open the excel it retreives it from the cache. I want to make it sure that the cache is cleared as well

    Thanks in Advance

    Viswanathan N.

    Wednesday, February 27, 2008 7:12 AM

Answers

  • A few ideas you could try to avoid it happening again:

     

    1) in PPS excel addin go to performancepoint tab, options and make sure the advanced option "automatically cache assignments locally" is unticked

    2) I think even if this is unticked some data can be stored locally (can't figure out who yet). If you go to PPS excel addin, go to offline, manage offline assignments and refresh the application it might help

    3) otherwise there is a model property in PBM called "enable offline cube" associated with each model. If you set this to false I think this limits/avoids any data being locally cached.

     

    I'd be interested what configurations of these work for you if you have time to try them.

     

    Thanks,

     

    Tom 

     

    Wednesday, February 27, 2008 2:25 PM

All replies

  • Could mean one of 2 things. Either you have not entered the connection string info or your cache is clear. Does your "Test Connection" return a positive result?

     

    Wednesday, February 27, 2008 8:41 AM
  • Hi Paul,
                      First of all thanks for a quick response. I have checked both the things which you have mentioned. My cache is not clear( because values are not in the cube, but it shows in the form ). How to go about then?

    Thanks,
    Viswanathan N.
    Wednesday, February 27, 2008 9:17 AM
  • In your action pane you can refresh current workbook, sheet or system data. Try using those?

    Wednesday, February 27, 2008 10:14 AM
  • Hi Paul,   
                I have refreshed the workbook,sheet and the system data, Still the form retrieves the value from the cache. It is really killing my time. I don't know what to do to get rid of this cache.

    Thanks
    Viswanathan N.
    Wednesday, February 27, 2008 11:50 AM
  • I have no answer to your problem except that maybe your cache is clear and your original premise that the data is not in the cube may be mistaken? Have you looked at the cube using Excel Pivot Table with the same criteria as your matrix to compare the data.

     

    Wednesday, February 27, 2008 12:12 PM
  • Hi Paul,
                 Atlast i cleared the cache. I went into the Refresh Menu in the action pane and clicked the Clear Current Changes Command. Then I submit the form as blank. I closed the form. I opened the form again, the form opens as blank without the cache values.

    Thanks for your responses,

    Viswanathan N.
    Wednesday, February 27, 2008 12:31 PM
  • Excellent news. Maybe this is different to the cache. Did you save it privately? If you wait until Eric or Peter comes on-line you might get a more detailed explanation.

     

    Wednesday, February 27, 2008 12:48 PM
  • A few ideas you could try to avoid it happening again:

     

    1) in PPS excel addin go to performancepoint tab, options and make sure the advanced option "automatically cache assignments locally" is unticked

    2) I think even if this is unticked some data can be stored locally (can't figure out who yet). If you go to PPS excel addin, go to offline, manage offline assignments and refresh the application it might help

    3) otherwise there is a model property in PBM called "enable offline cube" associated with each model. If you set this to false I think this limits/avoids any data being locally cached.

     

    I'd be interested what configurations of these work for you if you have time to try them.

     

    Thanks,

     

    Tom 

     

    Wednesday, February 27, 2008 2:25 PM
  • Hi Tom,
                 Thanks for your valuable tips regarding clearing cache. It will be a great help for me in future.

    Thanks

    Viswanathan N.
    Thursday, February 28, 2008 4:02 AM