none
Delay in Internal Mail Delivery RRS feed

  • Question

  • Hi,

    We have an Exchange 2013 DAG setup as below in our environment .

    Primary Site - Node1 & Node2

    DR Site - Node3

    The above servers are setup with multi role (Mailbox and CAS)

    The issue is that slow network connection to DR site delay the internal mail delivery...if the copy queue to DR site increases, then the internal mail delivery delays.

    DR replication should not affect the mail delivery (both internal and external), but its strange in our case.

    Please help to resolve the issue.

    Regards,

    Sridhar

    Saturday, April 6, 2019 1:50 AM

All replies

  • Copy queues shouldn't impact mail flow.  Are you running low on disk space or something like that, causing "backpressure" that temporarily suspends mail delivery?

    Do you have your AD subnets and sites misconfigured so that mail is routinely being routed through the DR site?  Or do you have send connectors configured to route out through that site?  Normally in a configuration like you describe, SMTP would not be routed through the DR site so that's why I'm asking about misconfiguration.

    It sounds like you need to improve your DR network connection even if you solve the transport problem.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, April 6, 2019 4:57 AM
    Moderator
  • Hi,

    Agree with Ed Crowley, and add more suggestions.

    How do you know the email delay occurs in DR site?

    You can use the message tracking log to check when the message was delayed:

    Get-MessageTrackingLog -MessageSubject "<subject>" -Sender <sender address> | fl timestamp,EventID,Source

    You can check this document for more information about message tracking logs:Message tracking

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 8, 2019 4:20 AM
    Moderator
  • Hi,

    Any updates so far?

    If you have solved your problem, could you share with us? Maybe it will help more people with similar problems. Don't forget to mark it as answer,  this will be easy for other community members to find the useful one.

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, April 12, 2019 1:40 AM
    Moderator