none
Unable to install Module -Name AzureADPreview

    Question

  • How come I can't install  AzureADPreview module - what am I doing wrong?

    PS C:\> Install-Module -Name AzureADPreview
    Install-Module : The term 'Install-Module' is not recognized as the name of a cmdlet, function, script file, or
    operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
    again.
    At line:1 char:1
    + Install-Module -Name AzureADPreview
    + ~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Install-Module:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    Thursday, June 14, 2018 5:17 PM

All replies

  • $PSVersionTable.PSVersion

    Minimum PowerShell version

    3.0

    says it in the AzureADPreview page.

    Thursday, June 14, 2018 5:29 PM
  • I' running it at Administrator
    Thursday, June 14, 2018 6:32 PM
  • PowerShell Version

    Major  Minor  Build  Revision
    -----  -----  -----  --------
    4      0      -1     -1

    Thursday, June 14, 2018 6:32 PM
  • Install-Module is only available in V5


    \_(ツ)_/


    • Edited by jrvModerator Thursday, June 14, 2018 6:39 PM
    • Proposed as answer by Ben Lavender Thursday, June 14, 2018 9:18 PM
    Thursday, June 14, 2018 6:38 PM
    Moderator
  • How come I can't install  AzureADPreview module - what am I doing wrong?

    PS C:\> Install-Module -Name AzureADPreview
    Install-Module : The term 'Install-Module' is not recognized as the name of a cmdlet, function, script file, or
    operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
    again.
    At line:1 char:1
    + Install-Module -Name AzureADPreview
    + ~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Install-Module:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    As per JRV:

    Install it then your cmdlet will be available

    https://www.microsoft.com/en-us/download/details.aspx?id=54616

    Thursday, June 14, 2018 9:19 PM
  • Install-Module function is part of PowerShellGet module, it requires PowerShell v3 or newer.
    Saturday, June 16, 2018 12:49 PM