locked
Checkout of Document in Document Library returns Files Not Found RRS feed

  • Question

  • I get the error below every time I go to View All Site Content, and go into any Document Library and click Check Out. I can go into Manage Site Content and Structure, and find the same file and check it out just fine. We have it setup that the main site sits at top and then we have 100 or so sites under that. We have no approval process in place, Document Version History is set at Major Version, and We do not require checkout to edit a file. (I have replaced my domain name just for security purposes in case there is anything exposed here)

     

    Thanks

     

    File Not Found.   at Microsoft.SharePoint.SPSite..ctor(SPFarm farm, Uri requestUri, Boolean contextSite, SPUserToken userToken)
       at Microsoft.SharePoint.SPSite..ctor(String requestUrl)
       at Microsoft.SharePoint.SPWeb.GetWebRelativeUrlFromUrl(String strUrl, Boolean includeQueryString, Boolean canonicalizeUrl)
       at Microsoft.SharePoint.SPWeb.GetWebRelativeUrlFromUrl(String strUrl)
       at Microsoft.SharePoint.SPWeb.GetFile(String strUrl)
       at Microsoft.SharePoint.ApplicationPages.Checkin.get_File()
       at Microsoft.SharePoint.ApplicationPages.Checkin.OnLoad(EventArgs e)
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint

     

    Error in Logs:

     

    12/29/2011 10:18:42.93 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8b	Verbose 	Looking up context  site http://Moa.MYSITE.com:80/_layouts/Checkin.aspx?FileName=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FMoa%20Help%2Epdf&Checkout=true&Source=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FForms%2FAllItems%2Easpx in the farm SharePoint_Config_DB1	 
    12/29/2011 10:18:42.93 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8d	Verbose 	Looking up the additional information about the typical site http://Moa.MYSITE.com:80/_layouts/Checkin.aspx?FileName=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FMoa%20Help%2Epdf&Checkout=true&Source=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FForms%2FAllItems%2Easpx.	 
    12/29/2011 10:18:42.93 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8f	Verbose 	Site lookup is replacing http://Moa.MYSITE.com:80/_layouts/Checkin.aspx?FileName=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FMoa%20Help%2Epdf&Checkout=true&Source=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FForms%2FAllItems%2Easpx with the alternate access url http://Moa.MYSITE.com.	 
    12/29/2011 10:18:42.93 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8g	Verbose 	Looking up typical site http://Moa.MYSITE.com:80/_layouts/Checkin.aspx?FileName=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FMoa%20Help%2Epdf&Checkout=true&Source=https%3A%2F%2FMoa%2EMYSITE%2Ecom%2FDocuments%2FForms%2FAllItems%2Easpx in web application SPWebApplication Name=SharePoint - Moa.MYSITE.com443 Parent=SPWebService.	 
    12/29/2011 10:18:42.93 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8h	Verbose 	Found typical site / (a3442106-b6d7-4b78-858d-f19815b78048) in web application SPWebApplication Name=SharePoint - Moa.MYSITE.com443 Parent=SPWebService.	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	8e1f	High    	Failed to find the XML file at location '12\Template\Features\S2BaseSiteStapling\feature.xml'	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	0	Verbose 	GetUriScheme(https://Moa.MYSITE.com/Documents/Moa Help.pdf)	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	6t8b	Verbose 	Looking up  site https://Moa.MYSITE.com/Documents/Moa Help.pdf in the farm SharePoint_Config_DB1	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	88gr	Verbose 	alternateUrl is null	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	Database                      	880l	Verbose 	ConnectionString: 'Data Source=NAHOLLCG16;Initial Catalog=SharePoint_Config_DB1;Integrated Security=True;Enlist=False'    ConnectionState: Closed ConnectionTimeout: 15	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	                              	1624                          	8acb	Verbose 	Reverting to process identity	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	                              	1624                          	8acc	Verbose 	Current user before SqlConnection.Open: Name: NA\svc-spadmin SID: S-1-5-21-1644491937-1229272821-682003330-49371 ImpersonationLevel: None	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	                              	1624                          	8acf	Verbose 	Current user after SqlConnection.Open: Name: NA\svc-spadmin SID: S-1-5-21-1644491937-1229272821-682003330-49371 ImpersonationLevel: None	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	Database                      	880m	Verbose 	SqlCommand: 'dbo.proc_getSiteIdOfHostHeaderSite'     CommandType: StoredProcedure CommandTimeout: 0     Parameter: '@RETURN_VALUE' Type: Int Size: 0 Direction: ReturnValue Value: ''     Parameter: '@HostHeader' Type: NVarChar Size: 128 Direction: Input Value: 'Moa.MYSITE.com'	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	Topology                      	88gs	Verbose 	hostHeaderSiteInfo is null	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	88gv	Verbose 	request is not loopback	 
    12/29/2011 10:18:42.95 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	8nca	Verbose 	Application error when access /_layouts/Checkin.aspx, Error=The Web application at https://Moa.MYSITE.com/Documents/Moa Help.pdf could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.   at Microsoft.SharePoint.SPSite..ctor(SPFarm farm, Uri requestUri, Boolean contextSite, SPUserToken userToken)     at Microsoft.SharePoint.SPSite..ctor(String requestUrl)     at Microsoft.SharePoint.SPWeb.GetWebRelativeUrlFromUrl(String strUrl, Boolean includeQueryString, Boolean canonicalizeUrl)     at Microsoft.SharePoint.SPWeb.GetWebRelativeUrlFromUrl(String strUrl)     at Microsoft.SharePoint.SPWeb.GetFile(String strUrl)     at Microsoft.SharePoi...	 
    12/29/2011 10:18:42.95*	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	8nca	Verbose 	...nt.ApplicationPages.Checkin.get_File()     at Microsoft.SharePoint.ApplicationPages.Checkin.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)	 
    12/29/2011 10:18:42.96 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	0	Verbose 	Releasing SPRequest with allocation Id {10B0E9FF-D291-46FB-8323-478246702703}	 
    12/29/2011 10:18:42.96 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	0	Verbose 	Releasing SPRequest with allocation Id {750C15F6-EEED-4AA2-868C-3259F42646F8}	 
    12/29/2011 10:18:42.96 	w3wp.exe (0x0B28)                       	0x24AC	Windows SharePoint Services   	General                       	0	Verbose 	Releasing SPRequest with allocation Id {9DE39549-1C23-4875-919A-2DD57C8C5011}	 
    12/29/2011 10:18:44.01 	OWSTIMER.EXE (0x08E8)                   	0x1AF4	Windows SharePoint Services   	Timer                         	8e45	Verbose 	Begin invoke timer job Scheduled Unpublish, id {F06CD671-CD42-46EB-9636-052161EBA4E3}, DB {ADACCF1B-0B18-404B-9715-102EA47AADB4}	 
    12/29/2011 10:18:44.01 	OWSTIMER.EXE (0x08E8)                   	0x1AF4	Windows SharePoint Services   	Database                      	880l	Verbose 	ConnectionString: 'Data Source=nahollcg16;Initial Catalog=WSS_Content_Authoring;Integrated Security=True;Enlist=False;Connect Timeout=15'    ConnectionState: Closed ConnectionTimeout: 15	 
    12/29/2011 10:18:44.01 	OWSTIMER.EXE (0x08E8)                   	0x1AF4	                              	1624                          	8acb	Verbose 	Reverting to process identity


     


    • Edited by Josephs911 Thursday, December 29, 2011 4:50 PM
    Thursday, December 29, 2011 4:50 PM

Answers

  • Hi,

    From what I can see in these logs, it would appear that you are requesting content from http://moa.mysite.com but then being redirected to https://Moa.MYSITE.com - is this by intent?

    I have a few questions to clarify:

    * Is there an HTTP to HTTPS redirect occurring in IIS without SharePoint's knowledge?

    * Is the secure certificate properly set on the web application?

    The first thing I would to to test this theory would be to attempt logging into https://moa.mysite.com directly to see if you are having the same issue. If you get no response back, then the certificate is probably not setup correctly in IIS.

    Whichever type of connection you prefer should be setup with SharePoint's knowledge (HTTP or HTTPS).

    Troy Lanphier


    Troy Lanphier http://blog.sharepointcookbook.com
    • Marked as answer by Pengyu Zhao Thursday, January 5, 2012 9:34 AM
    Friday, December 30, 2011 2:13 AM

All replies

  • Hi,

    Try set Checkout as required to see if it works for you.


    Thanks, Rahul Rashu
    Thursday, December 29, 2011 8:50 PM
  • Hi,

    From what I can see in these logs, it would appear that you are requesting content from http://moa.mysite.com but then being redirected to https://Moa.MYSITE.com - is this by intent?

    I have a few questions to clarify:

    * Is there an HTTP to HTTPS redirect occurring in IIS without SharePoint's knowledge?

    * Is the secure certificate properly set on the web application?

    The first thing I would to to test this theory would be to attempt logging into https://moa.mysite.com directly to see if you are having the same issue. If you get no response back, then the certificate is probably not setup correctly in IIS.

    Whichever type of connection you prefer should be setup with SharePoint's knowledge (HTTP or HTTPS).

    Troy Lanphier


    Troy Lanphier http://blog.sharepointcookbook.com
    • Marked as answer by Pengyu Zhao Thursday, January 5, 2012 9:34 AM
    Friday, December 30, 2011 2:13 AM