PowerQuery from Exchange reports invalid credentials


  • When I try to connect to Microsoft Exchange as a Query data source, it tells me that my credentials are invalid, when in fact they are not. I have also double and triple-checked that my account is not locked out or otherwise disabled, and my emails are coming to Outlook just fine.

    Any pointers or tips to helping me trace down what's blocking me would be greatly appreciated.

    PS. I think this worked in the previous version of PowerQuery, but I don't know where to find that download now. I'd use it instead of anyone can tell me where to get it.

    Shawn Keene

    Wednesday, February 19, 2014 3:30 PM


All replies

  • Hi Shawn,

    Thanks for reporting this issue. We're following up via Frown so I'm marking this thread as complete here.


    Wednesday, February 19, 2014 6:49 PM
  • Thanks so much for your responsiveness, I never would have expected same-day (or in this case, same-hour) response!

    Shawn Keene

    Wednesday, February 19, 2014 7:19 PM
  • Hello,

    running into the same issue, could you please post how you managed to solve this?


    Thursday, March 06, 2014 2:18 PM
  • We are still investigating the original issue, if you are reporting a new issue, please report it via "send a frown" feature in Power Query to so we can follow up with more debugging.


    Zafar Abbas

    Friday, March 07, 2014 7:34 AM
  • It's several months later, is there any update on this issue? We are experiencing the same issue with 2007 Exchange all patched up.
    Thursday, July 24, 2014 12:43 PM
  • Same here, and I sent that frown ages ago. Could we just dispense with autodiscovery? I know what I have to fill out, and the magic under the hood is quite obviously not working.
    Monday, November 03, 2014 5:42 PM
  • Which version are you on?  I haven't had any issues since my reply above, I'm also using Excel 2013 now.

    Shawn Keene

    Monday, November 03, 2014 5:44 PM
  • I had the same issue and I submitted a frown. Immediately after that I started playing with Outlook configurations and somehow it worked.  Go to Outlook Account Settings, Change, More Settings > tab Connection. Try using Negotiate instead of NTML. 

    Half Scheidl

    Wednesday, December 03, 2014 7:12 AM
  • Hi there, has been a while but do you recall how you overcame this issue in more detail?
    Saturday, August 22, 2015 6:16 AM
  • Hi Miguel,

    Have addressed this with you on the Power Bi Blog and Exchange connector issues.

    This is connected with the queries on this thread which appears unresolved.

    I have no doubt there is a simple fix for this

    Saturday, August 22, 2015 6:17 AM
  • Hi endless112,

    This problem is solved for most of our users' case, with the new UPN (User Principal Name) support added in July. This is a problem caused to users that have their UPNs different from their email addresses.

    For example:



    If you don't know about this, you can ask your IT department to get your UPN.

    Hope this helps


    Monday, August 24, 2015 6:52 PM
  • I got the same error, though i wrote down the Password and the correct UPN.

    So the Problem is not solved.

    regards Michael

    Thursday, August 27, 2015 12:01 PM
  • Hi Michael,

    Can you send us your Fiddler traces? could help.



    Tuesday, September 01, 2015 1:40 AM
  • Hi Oguz,

    Agree with Michael - this issue definately not fixed.

    I have checked UPN with my administrators and even with supplied UPN no luck.

    Have attempted same for Power Query and Power Bi with same result.

    Help please?

    Friday, September 04, 2015 10:35 AM
  • Do you know if the mailbox you're trying to connect is on-prem or on Office365?
    Thursday, September 10, 2015 6:56 PM
  • Hi Oguz - confirming this is an on-prem exchange server.
    Thursday, September 10, 2015 10:27 PM