PowerQuery from Exchange reports invalid credentials


  • When I try to connect to Microsoft Exchange as a Query data source, it tells me that my credentials are invalid, when in fact they are not. I have also double and triple-checked that my account is not locked out or otherwise disabled, and my emails are coming to Outlook just fine.

    Any pointers or tips to helping me trace down what's blocking me would be greatly appreciated.

    PS. I think this worked in the previous version of PowerQuery, but I don't know where to find that download now. I'd use it instead of anyone can tell me where to get it.

    Shawn Keene

    Wednesday, February 19, 2014 3:30 PM


All replies

  • Hi Shawn,

    Thanks for reporting this issue. We're following up via Frown so I'm marking this thread as complete here.


    Wednesday, February 19, 2014 6:49 PM
  • Thanks so much for your responsiveness, I never would have expected same-day (or in this case, same-hour) response!

    Shawn Keene

    Wednesday, February 19, 2014 7:19 PM
  • Hello,

    running into the same issue, could you please post how you managed to solve this?


    Thursday, March 06, 2014 2:18 PM
  • We are still investigating the original issue, if you are reporting a new issue, please report it via "send a frown" feature in Power Query to so we can follow up with more debugging.


    Zafar Abbas

    Friday, March 07, 2014 7:34 AM
  • It's several months later, is there any update on this issue? We are experiencing the same issue with 2007 Exchange all patched up.
    Thursday, July 24, 2014 12:43 PM
  • Same here, and I sent that frown ages ago. Could we just dispense with autodiscovery? I know what I have to fill out, and the magic under the hood is quite obviously not working.
    Monday, November 03, 2014 5:42 PM
  • Which version are you on?  I haven't had any issues since my reply above, I'm also using Excel 2013 now.

    Shawn Keene

    Monday, November 03, 2014 5:44 PM
  • I had the same issue and I submitted a frown. Immediately after that I started playing with Outlook configurations and somehow it worked.  Go to Outlook Account Settings, Change, More Settings > tab Connection. Try using Negotiate instead of NTML. 

    Half Scheidl

    Wednesday, December 03, 2014 7:12 AM