locked
Sharepoint workspace error (cellstorage.svc)

    Question

  •  

    Hi all,

    I'm trying to set up sharepoint workspace.
    Works great on my developpement environnent but not on my production server.

    I can see and edit the list, but i'm unable to download or upload document.

    EventLog  gives me the following error:

    WebHost failed to process a request.

     Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/36620214

     Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/cellstorage.svc' cannot be activated due to an exception during compilation.  The exception message is: Service 'Microsoft.SharePoint.SoapServer.CellStorages' has zero application (non-infrastructure) endpoints. This might be because no configuration file was found for your application, or because no service element matching the service name could be found in the configuration file, or because no endpoints were defined in the service element.. ---> System.InvalidOperationException: Service 'Microsoft.SharePoint.SoapServer.CellStorages' has zero application (non-infrastructure) endpoints. This might be because no configuration file was found for your application, or because no service element matching the service name could be found in the configuration file, or because no endpoints were defined in the service element.

       at System.ServiceModel.Description.DispatcherBuilder.EnsureThereAreNonMexEndpoints(ServiceDescription description)

       at System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)

       at System.ServiceModel.ServiceHostBase.InitializeRuntime()

       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)

       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

       --- End of inner exception stack trace ---

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

     Process Name: w3wp

     Process ID: 5024

    Any idea ?
    Thanks

    Tuesday, July 19, 2011 4:51 PM

All replies

  • Hi,

    From the error message, it seems this issue is about the service ‘microsoft.sharepoint.soapserver.cellstorage’.

    I would recommend that you run a netmon or fiddler capture during the event that generates the error.


    Xue-Mei Chang
    Friday, July 22, 2011 5:43 AM
    Moderator
  • Hi Xue-Mei,

    Thanks for your suggestion.

    After trying with netmon and enabling IIS tracing, it  seems that's an authentification problem:

     

    - Http: Response, HTTP/1.1, Status: Unauthorized, URL: /tbc/_vti_bin/cellstorage.svc , Using NTLM Authentication

        ProtocolVersion: HTTP/1.1

        StatusCode: 401, Unauthorized

        Reason: Unauthorized

        Server:  Microsoft-IIS/7.5

        SPRequestGuid:  9c886a10-6a61-472e-9e52-9d9c6c4a0abe

      + WWWAuthenticate: NTLM

        XPoweredBy:  ASP.NET

        MicrosoftSharePointTeamServices:  14.0.0.5123

    It's very strange because all other services works with the same account (and all other account).

    Does anyone know what this service use (dll, config, ...) ?

    Thanks

     

    Monday, July 25, 2011 10:09 AM
  • check if web.config is correct (or exist) in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\ISAPI
    Thursday, March 22, 2012 12:52 PM
  • I was finally able to resolve this issue. I tried a number of things before I found what worked for our farm. Here's my activity log in case it helps anyone out.

    • I updated all my farm servers to February 2012 CU and though it gave me some trouble, it did nothing to solve my problem even running psconfig.exe didn't help.
    • Resolved a bunch of unrelated issues to clear out event log clutter on the farm. It was overdue anyhow. Issue persisted.
    • Tried the KB907306 mentioned for web folders, and found the cure might be worse than the disease. Started getting message sthat the document was checked out by someone else instead of the document is Read Only, which isn't really any better if you can't save it.
    • Tried performing all Windows Updates on my Win7 client including MSO Sign In updates - with no effect.
    • I tried killing the OWSSYNC.exe process with Process Explorer. It only comes back. I hate zombies!
    • On a lark I tried deleting my cookies and closing the browser like one would do for a claims authentication issue, but I think I was just grabbing at straws.
    • Investigated at great length the configuration of web.config in _vti_bin, and turned on WCF trace - but this oddly had no effect at all and I was never able to get the trace to work. At this point I was still getting the '/_vti_bin/cellstorage.https.svc' and '/_vti_bin/cellstorage.svc' Exception messages about Anonymous authentication. I compared it to some development servers that worked on the off change the configuration had gotten itself into a weird state, but could not see any difference. I took a brief look at the web.config for the web app itself, but I couldn't see anything wrong. All of this was an interesting experience but didn't fix anything.
    • Finally, I went into Central Administration > Manage Web Applications > Authentication Providers and changed the settings for Windows Authentication from Negotiate to NTLM. At this point, the WCF error magically went away and I was now able to save my documents.
    • For grins, I trimmed up my Intranet zone settings in IE9 and tested this in the Trusted Sites zone as wel. I was able to save and the only difference was that now I had to log in to Word and IE.
    • Wanting to know if the issue was in fact Kerberos or just something weird, I then went back into Central Admin > Manage Web Apps > Auth Providers andreversed the settings back to Negotiate Kerberos from NTLM. Restarted the web applications (of coruse, because this changes web.config) and lo and behold now it still works.

    So here is my theory on this issue until someone want to prove to me otherwise: something in a recent Windows or SharePoint update will break the ability to save documents by breaking the cellstorage web services' configuration in some ciritical way that I was unable to pin down. Modifying the authentication providers using the Web UI sets everything up correctly again. I think that this is also why extending the web app will resolve the issue. I have my doubts if changes made in PowerShell will have the same effect as there may be quite a bit SharePoint is doing under the hood here. It si definitely not the first time I have seen a security update break IIS in some essential way - and I doubt it will eb the last.

    My advice if you have this problem is first to try and "wiggle" your auth providers before you tinker around too much with all that other stuff that will waste your entire evening. :-)

    Unless you're one of the lucky folks that gets this on your Office 365 SharePoint. Then I guess your out of luck. (You could try asking the MS techs to read this, I guess.)

    I'm cross posting this answer at these issues which all seem to be related:

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/ec048a1f-e6cc-481d-8f46-308823568b56/
    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/30c61804-3200-4b8d-9466-5f32c24f9928/?prof=required

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/18a81941-9b73-470f-8721-b068b45f861c/?prof=required

    Friday, March 23, 2012 7:59 AM
  • Hello

    I´ve solved this issue removing from web.config some lines that enabling debugging. This issue occurred after Sharerpoint WSS to Sharepoint 2010 upgrade.

    Please see the text at web.config below and remove it:

        <behaviors>
          <serviceBehaviors>
            <behavior>
              <serviceDebug includeExceptionDetailInFaults="true" />
              <serviceMetadata httpGetEnabled="true" />
            </behavior>
          </serviceBehaviors>
        </behaviors>

    

    Monday, September 01, 2014 2:47 PM