locked
stsadm export not exporting my content RRS feed

  • Question

  • I have a situtation whereby I'm trying to export a subsite from one application to another application after a SharePoint 2003 migration to 2007 and the stsadm -o export command is not exporting the content from the site. Here's my scenario:

    I migrated an old SharePoint 2003 web application to a SharePoint 2007 (http://projects.int) application successfully. The SharePoint 2007 environment has no SPs or hotfixes installed (v 12.0.0.4518).

    I would like to move a sub-site within the migrated 2003 web app (http://projects.int/projA) to another web application (http://intranet/dept/projects/projA-001) on the same server.

    On the server I'm executing this stsadm command : stsadm -o export -url http://projects.int/projA -filename c:\projA\projAexport -includeusersecurity -versions 4

    When this command completes I only see users being exported and the cmp file is around 4k.

    When I perform the import to http://intranet/dept/projects/projA-001 the site is empty (no content).

    Has anyone experienced this?

    Wednesday, November 10, 2010 6:22 PM

All replies

  • i think you follow this link: http://blogs.msdn.com/b/skelley/archive/2007/07/12/stsadm-import-export-missing-content.aspx

    two things i am wondering, Under which account you trying to rum Export/ Import command.

    2) did you try to backup and restore command?

     

    stsadm -o export -url http://projects.int/projA -filename c:\projA\projAexport.bak -includeusersecurity -versions 4 

    and try to run under the admin a/c

     

     

    hope this works

    thanks

    -ws


    SharePoint administrator, MCTS,MCITP
    Wednesday, November 10, 2010 10:15 PM
  • It's also worth noting that exporting a sub-site isn't currently possible, it's either the entire site collection or nothing.
    http://www.final-exodus.net
    Thursday, November 11, 2010 11:16 AM
    Answerer
  • I ran the command as the admin....with no luck...

    I don't want to perform a backup and restore since this backups and restores the entire site collection which is not what i want....it is possible to export the content from a subsite (as i mentioned before it worked in my test envrionment just not on production)

    http://technet.microsoft.com/en-us/library/cc262759%28office.12%29.aspx

    stsadm -o export -url <subsite or site to export> -filename <file name of the exported file> -includeusersecurity -version <1-4 option to extract versions>

    Thursday, November 11, 2010 1:17 PM
  • Hi ruselle, I ran into exact same issue as you did. Did you ever find out the solution? If so, can you share please? Thanks in advance! Rachel
    Friday, April 1, 2011 6:03 AM