none
Machine is creating temporary profile instead of a permanent one

    Question

  • We have a SBS 2008 server with about 8 workstations that are all running windows XP Pro. All have been installed for about 1.5 years. We added a new workstation yesterday, a windows 7 pro. which went fine. After finishing with the new machine we went to log into one of the old machines with a different account. One that has been used before on another machine (XP) but had never been used on this machine (XP) before. When we do, the computer says the profile could not be found on the domain and then a second message says that the profile could not be found locally. The system then logs you in with a temporary roaming profile (we do not use roaming profiles). When you log off the profile is deleted, or it leaves a temporary profile called temp.domain name. When logged in you cannot change it to a local profile. We are now getting Userenv 1511 & 1521 event errors in the logs. The machine has been using 4 other domain accounts without issues and this account is used on other machines without issue. I have had seen this issue before in other SBS 08 & 03 environments when adding a Windows 7 machine to the domain but have no idea how to resolve. Could someone please offer some assistance?

    Thanks

    Robert Wiggins


    Robert Wiggins
    Tuesday, November 8, 2011 1:18 PM

All replies

  • Open Registry on the client machine-

    HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\CURRENT VERSION \PROFILE LIST

    Backup Profile List Key - Expand Profile List and look for any profile GUID with .bak extension, if you find any , delete it and reboot the machine and test.

     

     


    Binu Kumar Small Business Server Support
    Tuesday, November 8, 2011 9:03 PM
  • Thanks for the response. We tried that but there were none with .bak
    Robert Wiggins
    Tuesday, November 8, 2011 9:20 PM
  • Sounds similar to something I've met. Is this where it says words to the extent that user profile cannot be found and does a countdown.

    If so I've met it in a couple of guises, in the first I had a dual NIC workstation (unorthodox but necessary to access a domain and a workgroup at same time), in the second it occured after moving a workstation from one domain (SBS2003) to another (SBS2011)

    For the former the problem went away after giving up on the dual NIC idea, in the second we went through adding and removing from domain, and resetting the computer account on the domain. Don't recall exactly but there seemed to be a problem with authentication at the heart of it. The MCSE who was aiding picked up that the network drivers were rather old and that there might have been mismatch between password (complex naturally) typed and what was passed - a keyboard map thing # being in different places on US and UK boards.

     

     

     

     

     

     

     

     

     

     

     

    Wednesday, November 9, 2011 10:01 PM
  • Robert,

    On the SBS server, can you open an administrative command prompt and type: (Replace John Smith with the problem users login name)
    dsquery user -name "John Smith" | dsget user -profile

    Copy the results into here.


    Jeremy
    Thursday, November 10, 2011 4:31 AM
  • Hi Robert, have you resolved the issue? If not, please feel free to let us know, thanks.

     

    Sean Zhu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tnmff@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, November 14, 2011 7:46 AM
    Moderator
  • It seems we cannot login with most of the user accounts that are already created on the server but have not logged into theis machine yet, without it creating the temp. profile. If we create a new account on the server and use it to log in it seems to work fine?
    Robert Wiggins
    Monday, November 14, 2011 1:56 PM
  • no we have not. looking for something new to try.
    Robert Wiggins
    Monday, November 14, 2011 1:56 PM
  • Hi Robert, you can try UPHClean on user profile related issues. You can download it via the following link:
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=1b286e6d-8912-4e18-b570-42470e2f3582

    (Note: Supported Operating Systems: Windows 2000, Windows Server 2003, Windows XP)

    Most of the time, the problem with profiles not loading are because a program didn't release all of the handles when the program closed. So a temporary profile is used. Install UPHClean on the computer as it will allow the handles to be released.

    You can make a system restore point before you install just in case you want to go back to before you installed it.

    Meanwhile, you can also try copying a working user profile to the default user profile under control panel, delete the profiles that have problems and see what happens.


     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 15, 2011 8:23 AM
    Moderator
  • Sorry for the delay. I did typed in what you asked (dsquery user -name "John Smith" | dsget user -profile) and here is what I got

    profile

    SYSVOL\corporate.local\scripts

    dsget succeeded

    does that tell you anything?


    Robert Wiggins
    Tuesday, November 29, 2011 2:44 PM
  • Sean

    We tried the UPHClean but that did not resolve the issue. any other ideas?

     


    Robert Wiggins
    • Proposed as answer by susan-d Monday, March 5, 2012 3:14 PM
    • Unproposed as answer by susan-d Monday, March 5, 2012 3:15 PM
    Wednesday, December 7, 2011 3:26 PM
  • Robert,

    Login as local administrator,

    Regedit

    HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\CURRENT VERSION \PROFILE LIST

    Go to above location, you can find folders under this profile list, expand each folder (Each folders will be for each users of the computer), you can see the profile having issue, you have to delete that folder.

    Restart the machine then, remove from domain and join back to the domain, the issue will be fixed.

    Cheers

    Sanooj

    • Proposed as answer by Cody2468 Monday, December 17, 2012 2:44 PM
    Sunday, April 29, 2012 8:07 AM
  • This is a terminal server so it is a little more involved to disjoin and rejoin. ANy other way to fix it?

    Robert Wiggins

    Monday, April 30, 2012 9:08 PM
  • I wanted to revisit theis issue as it is happened again and I thought maybe someone will have more info. I had a machine that was part of the network and the profile got corrupted and I want to delete it and creat a new one with the same name. I am not able to do this because of this the same issue I had that is listed in this thread. (If you cannot see the whole thread please let me know). I don't want to have to wipe this machine and start from scratch but I have done all the things suggested in this thread as well as anything I can think of on my own. I have deleted the profile, the local user account, the network account, disjoined the domain and rejoined. No matter what I do when I try to login with this user account it will only allow me to create a temporary profile. As the thread indiactes I have had this issue with other machines and other accounts so it is not this user account or this machine. The olny way around it has been to give a person that needs to login to more than one machine is to give them a new account name. That has worked in the past to get around this issue but it is a pain in the butt. Now I have this issue which creating a new account is not going to be the solution. I need to use this account name. Can anyone offer some solution. Thanks for the help.

    Robert Wiggins


    Robert Wiggins

    Tuesday, November 20, 2012 5:31 PM
  • HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\CURRENT VERSION \PROFILE LIST

    • Similar issue & this worked PERFECT for me. Thank You!
    • Edited by Cody2468 Monday, December 17, 2012 2:45 PM
    Monday, December 17, 2012 2:43 PM
  • as you can see from my previous post this did not work. Any other ideas?

    Robert Wiggins

    Monday, December 17, 2012 2:51 PM
  • HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\CURRENT VERSION \PROFILE LIST

    Worked for me too...The issue was on a XP machine. Got resolved after removing the duplicate GUID and removing .bak from the original GUID.

    Monday, February 11, 2013 5:23 AM
  • Hi Robert -

    Your reply here showing the response to do dsquery / dsget suggests there *is* a roaming profile path set up, and this path also appears to be invalid.

    This would almost certainly cause the issues you are seeing.

    However, you also state in a more recent post that you've tried removing / re-creating the user account. One would assume from this that a statically set roaming profile path would be removed when you re-created the user. *UNLESS* you have a Group Policy Object that is setting the roaming profile path (incorrectly) for your users.

    Are you familiar with running "Resultant Set of Policy" on a computer / user? It might be quite interesting to do so for the user in question.

    Alternatively, if you have users that function okay, do these users happen to reside in a different Active Directory OU to those which do not function okay? Perhaps you could just move the users with the problems into the same OU as the users who do not have problems? Have a browse through Active Directory Users & Computers and see where the different user accounts reside.

    Hope this helps -

    Best regards,
    Simon.

    Monday, February 11, 2013 3:32 PM
  • This worked for me! 

    Here is what happened.

    The user was having an issue with access to a shared resource on our FS, when the users laptop was docked they could access the resource but when undocked the mapped drive would throw a "can't find this path" error. After reboot off the dock the share was there and could be accessed, dock and undock and the error would come back. 

    Ran the same steps above on a different laptop and the issue was not there. Concluded this is a bad/corrupted profile issue. Copied the users local data to a share and deleted the user's local profile. Rebooted and added the user back as admin on the laptop, logged in as user and was getting temp profile. Followed BinuKumar's steps and XXXXXXX.bak profile was there, deleted and reboot. Logged in as user and a proper user directory showed up.

    Thanks BinuKumar... 

    Wednesday, May 22, 2013 1:51 PM
  • Sanooj,

    Have been trying to crack this issue for the last couple of months & then hit on your advice.. It was spot on and fixed the issue..

    Thanks a ton the for fix..

    Regards,

    Amrut

    Wednesday, June 5, 2013 3:35 PM