locked
SharePoint 2007 Permissions Question RRS feed

  • Question

  • Does anyone out there know of a method to restore a higher level of permissions (Full Control) to a security group after it’s been changed to a lower level of permissions (approver)? This is, or rather was, the only admin type account in the List in question.

     

    Any help given would be greatly appreciated...

    • Moved by Mike Walsh FIN Tuesday, August 16, 2011 4:58 PM admin q - not social computing (From:SharePoint - Social Computing (pre-SharePoint 2010))
    Tuesday, August 16, 2011 2:54 PM

Answers

  • Please disregard my question above. I found a way to correct this issue. I'm going to detail it below in hopes that it might help someone else who's in this, or a similar, situation.

    What happened?

    In an attempt to prevent anyone else from inadvertantly deleting items from our production workflow tracking list, I created a new 'approvers' group minus the delete item permissions. Where the problem arose was during the assignments, I had a senior moment and assigned this new group to the admin group I had set-up on this particular list library. This could have caused me quite a few headachs as we have just started using the workflow features in SharePoint, and, if I couldn't access the settings on this list library when someone needed help; I'd be in trouble.

     

    The solution?

    I went into site name > Site Settings > Permissions > Permission Levels and temporarily granted the new approvers group the following two additional permissions:

    Site Permissions

    <input name="right" type="checkbox" value="ManagePermissions" />Manage Permissions  -  Create and change permission levels on the Web site and assign permissions to users and groups.

     

    List Permissions

    <input name="right" type="checkbox" value="ManageLists" />Manage Lists  -  Create and delete lists, add or remove columns in a list, and add or remove public views of a list.

     

    After resetting my admin group to "Full Control", I quickly removed the two permissions above... problem solved.

     

    Hope this helps,

     

    Longcr

     


    Calvin R. Long
    Tuesday, August 16, 2011 4:59 PM

All replies

  • Please disregard my question above. I found a way to correct this issue. I'm going to detail it below in hopes that it might help someone else who's in this, or a similar, situation.

    What happened?

    In an attempt to prevent anyone else from inadvertantly deleting items from our production workflow tracking list, I created a new 'approvers' group minus the delete item permissions. Where the problem arose was during the assignments, I had a senior moment and assigned this new group to the admin group I had set-up on this particular list library. This could have caused me quite a few headachs as we have just started using the workflow features in SharePoint, and, if I couldn't access the settings on this list library when someone needed help; I'd be in trouble.

     

    The solution?

    I went into site name > Site Settings > Permissions > Permission Levels and temporarily granted the new approvers group the following two additional permissions:

    Site Permissions

    <input name="right" type="checkbox" value="ManagePermissions" />Manage Permissions  -  Create and change permission levels on the Web site and assign permissions to users and groups.

     

    List Permissions

    <input name="right" type="checkbox" value="ManageLists" />Manage Lists  -  Create and delete lists, add or remove columns in a list, and add or remove public views of a list.

     

    After resetting my admin group to "Full Control", I quickly removed the two permissions above... problem solved.

     

    Hope this helps,

     

    Longcr

     


    Calvin R. Long
    Tuesday, August 16, 2011 4:59 PM
  • Hi,

    This can be done done site admins as well as by site collections admins.

    You can also use farm account for the same.

    I hope this will help you out.

     

     


    Thanks, Rahul Rashu
    Tuesday, August 16, 2011 7:56 PM