locked
Computer Shuts Down When Playing Games RRS feed

  • Question

  • I upgraded to Windows 7 last week from Vista. It runs everything very nicely except for my games (World of Warcraft, Half-Life 2), which cause the computer to shut down after about 20 minutes. There's no crashing or freezing. It's as though someone just pulled the power plug. Poof. It's all off.

    I'm no expert, but this doesn't strike me as a hardware problem since everything ran so nicely on Vista. But from what I can tell, when this happens, my fan starts spinning really fast and loudly, and my CPU clock indicates a lot of work being done by the processor. This was not a normal occurrence prior to installing 7. Doesn't seem to be a heating issue either. I've had heating problems before. You could feel it. It was very hot to touch. Nothing seems to be overheating this time. It's not hot.

    When I hear that fan start spinning, I harbor the illusion that I'll be able to alt+tab back into Windows for a few seconds, and that this will prevent my computer from shutting down. Actually, that seems to work reasonably well; but if I go 15 or 20 minutes without doing this regularly, it happens. I'm thinking of dropping back to Vista, but since my browsing and everything else runs so smoothly on 7, I'd really rather not if it can be avoided.

    Any pointers for me?





    Saturday, November 21, 2009 8:08 AM

Answers

  • Hi,

     

    According to your description. It can be the video card or chipset problem.

     

    I suggest updating BIOS, video card driver and chipset to the latest version.

     

    If it does not work, you can test it in Clean Boot mode.

     

    If the issue persists, you can collect System Information and upload it to the http://skydrive.live.com/ using your Live ID and I will check it:

     

    System Information

    ============= 

    1. Click the Start Button, type "MSINFO32" in the Start Search box and press Enter to start the System Information.

    2. On the popup window, on the menu bar, click "File", and click "Save", type a file name and then choose NFO as "Save as type", click Desktop on the left pane, and click Save. (If the Desktop option is not available, please click Browse Folder button first.)

    3. Go to the Desktop, right-click on the exported file, choose "Send To" -> "Compressed (zipped) Folder". Upload this file and let me know the link


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Friday, November 27, 2009 9:01 AM
    Monday, November 23, 2009 7:29 AM
  • I see 2 possible causes for what you computer is doing, mostly because I've had the same problems with other versions of windows when playing games. One is that Windows does not recognize you playing a game, only that it's doing a lot of sitting around getting bored, so it hit's it's 20 min sleep setting and goes to sleep on you. You can try altering your power save options for that one to see if that works.
    The other is that the processor is getting way too hot and invoking the auto shutdown to keep it from burning up. Make sure you computer is well ventilated and the ambient temp around it is below 75 degrees. (It will be much hotter in the case.) All electronics generate heat, and heat is bad. There is nothing more disturbing than listening to chips go off like popcorn.
    • Marked as answer by Vivian Xing Friday, November 27, 2009 9:01 AM
    Monday, November 23, 2009 9:12 AM

All replies

  • Hi,

     

    According to your description. It can be the video card or chipset problem.

     

    I suggest updating BIOS, video card driver and chipset to the latest version.

     

    If it does not work, you can test it in Clean Boot mode.

     

    If the issue persists, you can collect System Information and upload it to the http://skydrive.live.com/ using your Live ID and I will check it:

     

    System Information

    ============= 

    1. Click the Start Button, type "MSINFO32" in the Start Search box and press Enter to start the System Information.

    2. On the popup window, on the menu bar, click "File", and click "Save", type a file name and then choose NFO as "Save as type", click Desktop on the left pane, and click Save. (If the Desktop option is not available, please click Browse Folder button first.)

    3. Go to the Desktop, right-click on the exported file, choose "Send To" -> "Compressed (zipped) Folder". Upload this file and let me know the link


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Friday, November 27, 2009 9:01 AM
    Monday, November 23, 2009 7:29 AM
  • I see 2 possible causes for what you computer is doing, mostly because I've had the same problems with other versions of windows when playing games. One is that Windows does not recognize you playing a game, only that it's doing a lot of sitting around getting bored, so it hit's it's 20 min sleep setting and goes to sleep on you. You can try altering your power save options for that one to see if that works.
    The other is that the processor is getting way too hot and invoking the auto shutdown to keep it from burning up. Make sure you computer is well ventilated and the ambient temp around it is below 75 degrees. (It will be much hotter in the case.) All electronics generate heat, and heat is bad. There is nothing more disturbing than listening to chips go off like popcorn.
    • Marked as answer by Vivian Xing Friday, November 27, 2009 9:01 AM
    Monday, November 23, 2009 9:12 AM
  • our computers are not going into sleep mod they just shut off like you pulled the power cord I play games on Facebook and it really shuts off fast there it should not happen when you have 12 gig ram and quod processors 64 bit win 8.1 is what I run I know it's a video driver when windows builds this software you would think they would build into and around processers and cards it ticks you off when you spend all the money buying windows software and buy more ram and amd video cards and this happens it's not going to sleep and it is not heat it's software and driver trouble you build it build it around video and processors

         
    Friday, January 30, 2015 6:10 AM