locked
Disable automatic updating of e-mail address policy RRS feed

  • Question

  • Hello

    I have a single local domain, company.local, with no more than 10 users running windows 2008 sbs with exchange 2007.

    The exchange was deactivated, but now I'll just deploy and use it for a very single purpose, targeting mobility only.

    So, for example, I have a user called Conference. (conference@company.local). That user have as main e-mail: john@company.com

    The exchange will just retrieve e-mail from an external POP3 server and send thru an external SMTP server which e-mail address are "company.com". 

    I have setup Accepted Domains and E-mail Address Policies with company.com 

    I ran the best practices analyser, and all is running fine. The next thing would be change default SMTP e-mail address of user Conference on exchange from conference@company.com to john@company.com. But exchange won't allow, it returns a error:

    "The e-mail address for this recipient are automaticaly generated based on e-mail address policies. To modify the primary SMTP address for this recipient, you must disable automatic updating of e-mail addresses based on e-mail address policy".

    How do I set the policy to be disabled? Even the default policy don't allow that change. I did it before on Exchange 2003 without problems.

    I can't delete user "Conference" and recreate again, because it's a roaming profile and it would be painful to do. I understand that would be more simple if I can simply change that default SMTP address without problems!

    I would appreciate any clue.
    Thank you.

    MK2




    • Edited by -MK2- Wednesday, June 17, 2009 5:43 AM grammatic
    Wednesday, June 17, 2009 5:40 AM

Answers

  • Or if u want to do that using PowerShell in EMS then

    Set-mailbox user@domain.com -EmailAddressPolicyEnabled $false

    Now you can change the primary smtp address of this mailbox to whatever you want as far as Exchange allows it. 

    Regards,


    Laeeq Qazi
    • Marked as answer by Amit Tank Thursday, June 18, 2009 2:40 AM
    Wednesday, June 17, 2009 3:46 PM
  • If an e-mail address policy in your Exchange organization applies to this mailbox, the Set as Reply setting will be controlled by that policy. To change the primary address for a specific address type, you must clear the Automatically update e-mail addresses based on recipient policy check box

    -----------Refer to< Recipient Properties > E-Mail Addresses Tab>

    True, there’s no such error info in the exchange 2003. However, in the exchange 2007, please uncheck the “Automatically update e-mail addresses based on e-mail address policy” option in the “Properties” of the mailbox via EMC before we edit the primary address

    • Proposed as answer by Amit Tank Wednesday, June 17, 2009 7:44 AM
    • Marked as answer by Amit Tank Thursday, June 18, 2009 2:40 AM
    Wednesday, June 17, 2009 7:37 AM

All replies

  • If an e-mail address policy in your Exchange organization applies to this mailbox, the Set as Reply setting will be controlled by that policy. To change the primary address for a specific address type, you must clear the Automatically update e-mail addresses based on recipient policy check box

    -----------Refer to< Recipient Properties > E-Mail Addresses Tab>

    True, there’s no such error info in the exchange 2003. However, in the exchange 2007, please uncheck the “Automatically update e-mail addresses based on e-mail address policy” option in the “Properties” of the mailbox via EMC before we edit the primary address

    • Proposed as answer by Amit Tank Wednesday, June 17, 2009 7:44 AM
    • Marked as answer by Amit Tank Thursday, June 18, 2009 2:40 AM
    Wednesday, June 17, 2009 7:37 AM
  • Or if u want to do that using PowerShell in EMS then

    Set-mailbox user@domain.com -EmailAddressPolicyEnabled $false

    Now you can change the primary smtp address of this mailbox to whatever you want as far as Exchange allows it. 

    Regards,


    Laeeq Qazi
    • Marked as answer by Amit Tank Thursday, June 18, 2009 2:40 AM
    Wednesday, June 17, 2009 3:46 PM
  • Thank you for that. Didn't realize that would be so simple as unmark that box!
    apreciated your help guys.
    MK2
    Wednesday, June 17, 2009 11:12 PM