none
Unable To Start Application Identity Service For AppLocker On Windows 10 Enterprise RRS feed

  • General discussion

  • After my upgrade from Windows 8.1 Enterprise 64bit to Windows 10 Enterprise 64bit, the Application Identity service used by AppLocker is unable to start by default.

    I found that the AppIDSvc was stopped and its Startup Type was set to Manual.  When I attempted to change the Startup Type to Automatic via the GUI, it produced the error "Access is denied" even though services.msc from run from an elevated cmd prompt.  

    The only way to work around this was to edit the registry and changing Start=2 at HKLM\SYSTEM\CurrentControlSet\Services\AppIDSvc.

    Is this expected behavior?  I currently have a Group Policy Preference that sets this service to start automatically, but it is also being denied when attempting to change the Startup Type to Automatic according to the event logs.  Hence at the moment, Windows 10 clients are no longer coming online with AppLocker policies enabled.

    Tuesday, August 11, 2015 2:32 AM

All replies

  • Aakash Shah,

    Thank you for your feedback.

    I will help to submit this at my side, besides, please take use of the built-in feedback Tool to submit your finding.

    Thank you for your understanding and support.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, August 12, 2015 7:38 AM
    Moderator
  • Is there a webpage I can submit the feedback to?  I can't submit this feedback on my work computer since it's currently having problems accepting my Office 365 account, and I can't use my home computer since it wants me to switch my entire account to using a Microsoft account from a local account. If I can submit this feedback using some other method, like directly on a webpage, that would be helpful.

    Thanks!

    Friday, August 14, 2015 9:21 AM
  • Hi Aakash,

    Currently there is no feedback forums available for Windows 10.

    There used to be a feedback forum for Windows 10 preview and is locked when Windows 10 is release on 29th July.

    There should be Bug report available at the MSDN connect Microsoft site:

    https://connect.microsoft.com/

    Hope the information here would be helpful

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 17, 2015 5:48 AM
    Moderator
  • Hey, I'm curious, did you resolve this? I'm facing the same issue. Services snap-in gives me "access denied" error when I try to start "Application Identity" service on Windows 10 Pro.
    Wednesday, February 3, 2016 1:57 AM
  • Seems like nobody at Microsoft is interested in this. We see this bug here, too. And it's annoying to build some extra scripting to enable the service because this bug is still there. 
    Thursday, March 3, 2016 2:05 PM
  • Hi, I also encountered this same bug in Win 10 x64 Enterprise.

    Microsoft, please fix this, some people do actually use AppLocker!

    Monday, March 14, 2016 4:24 AM
  • Just encountered this as well when I updated from Windows 7 to Windows 10 on my home computer. Very strange that Microsoft disables security-measures.
    Thursday, June 23, 2016 3:46 PM
  • Fresh install of Windows 10 v1511 Education and this problem is present.

    Any ideas as to why?

    Come on Microsoft, you give us a tool to manage the use of Apps, but then you won't let us run it?

    A response please?

    Friday, July 15, 2016 10:21 AM
  • Try this:

    https://technet.microsoft.com/en-us/itpro/windows/keep-secure/configure-the-application-identity-service

    Certain services are secured in Windows 10 in such a way that you cannot configure autostart through the GUI.

    I'm still having issues though. The option to configure services through local policy manager is not available on any of my Windows 10 installs, both Enterprise and Pro. So I'm not sure if the guidance is correct or not.

    Aaron

    Tuesday, August 9, 2016 3:34 PM
  • I am having similar issue. I am trying to block windows store for a local windows account using applocker but I think because of Application Identity service issue (not being able to configure it to start automatically) the local security policy for applocker is not getting enforced. Its getting really frustrating with this inability to block apps while microsoft tries to shove un-necesssary apps like "windows store" down your throat.
    Tuesday, December 13, 2016 1:10 AM
  • THis is an old thread, but I had the same issue and found out the explanation and a solution in this article https://docs.microsoft.com/en-us/windows/security/threat-protection/windows-defender-application-control/applocker/configure-the-application-identity-service

    Starting with Windows 10, the Application Identity service is now a protected process. Because of this, you can no longer manually set the service Startup type to Automatic by using the Sevices snap-in.

    Wednesday, February 26, 2020 3:10 PM