locked
DirectAccess on Server 2012 Essentials R2 Breaks Client Connectivity RRS feed

  • Question

  • I recently completed a Windows Server 2012 Essentials > R2 migration. All is well, clients all working and backing up etc.

    I decided to follow the instructions at http://technet.microsoft.com/en-us/library/jj204618.aspx for configuring Essentials to act as a DirectAccess server. After completing the guide, all of my on network clients report the server as offline in the connector software and will not process their backups.

    If I disable the DirectAccess Server GPO and do a gpupdate /force on the server, the clients connect again and backups work. I've reviewed the contents of the Server GPO and the only settings which it applies are Windows Firewall settings which I cannot see would cause any conflict with client connectivity but clearly there is some.

    Clients are running Windows 8.1 Pro at the moment as I haven't looked into the Enterprise client requirements just yet so the Client GPO is not the issue as the WMI filter on the Client GPO is blocking my current clients from applying it, it's definatly a server-side issue.

    Has anyone else had any issues with setting up DirectAccess causing local network issues like this?


    Richard Green MCSE Windows Server 2003, MCTS Desktop Virtualization

    Saturday, December 21, 2013 10:37 PM

Answers

  • This was caused in the past by not excluding port 6602 from NetNatTranisition, in the original instructions it was excluded by having two ranges 6601-6601 6603-10000 (i think)

    they then updated that doc to start at 10,000

    So i would first check that you didnt have a typo in that command and mistakenly set it from 1000.


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    • Marked as answer by Justin Gu Friday, January 3, 2014 1:34 AM
    Sunday, December 22, 2013 9:51 PM

All replies

  • R2 seems a little different on direct access, all you need is the connector.

    When you boot your machine outside the network the connector will “see it”, and do some kind of automatic direct access. You will have access to all your network resources, and if I remember correctly the backup will work.

    The best part (besides the fact that there is no need for all that configuration) is that I tested it with Windows 7 Pro, and it just worked. No more need of an Enterprise client.

    Saturday, December 21, 2013 11:15 PM
  • R2 seems a little different on direct access, all you need is the connector.

    When you boot your machine outside the network the connector will “see it”, and do some kind of automatic direct access. You will have access to all your network resources, and if I remember correctly the backup will work.

    The best part (besides the fact that there is no need for all that configuration) is that I tested it with Windows 7 Pro, and it just worked. No more need of an Enterprise client.


    The option you are referring to is "Keep me remotely connected" in the client connector, however this uses the SSTP VPN RAS connection which is created by enabling the Anywhere Access feature in the Dashboard and not DirectAccess.

    The RAS connection was there in R1 of Windows Server 2012 Essentials, it's just the "Keep me remotely connected" option which is new.


    Richard Green MCSE Windows Server 2003, MCTS Desktop Virtualization


    • Edited by richardjgreen Sunday, December 22, 2013 10:37 AM Typo
    Sunday, December 22, 2013 10:33 AM
  • This was caused in the past by not excluding port 6602 from NetNatTranisition, in the original instructions it was excluded by having two ranges 6601-6601 6603-10000 (i think)

    they then updated that doc to start at 10,000

    So i would first check that you didnt have a typo in that command and mistakenly set it from 1000.


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    • Marked as answer by Justin Gu Friday, January 3, 2014 1:34 AM
    Sunday, December 22, 2013 9:51 PM
  • cheers, worked like a treat!!
    Friday, September 4, 2015 2:24 PM