none
Unable to install App-V 5.0 Sp2 Client RRS feed

  • Question

  • Hi all,

    Thanks for reading.

    I am trying to install App-V 5.0 Sp2 for the first time on a small test network.  On my test network I am running the following-

    • Windows Server 2012 r2 Datacenter
    • Windows 8.1 32bit

    So far I have installed the App-V Server, and the sequencer with no problems.  I have also sequenced an app and it is doing up on the management website.

    The issue appears when I try to install the App-V 5.0 Sp2 client on a Windows 8.1 client machine- I am installing it through the MDOP toolkit, and the installation goes fine and it reports that the installation is successful, however I am unable to view any shortcut to the client itself, and when I go through program files & into App-V and click the .exe to open it up, I get no feedback from the program at all.

    In event viewer I do get the following error-

    Getting server publishing data failed.
    URL: http://192.168.1.3:44444
    Error code: 0x45500D27

    and also-

    HttpRequest sendRequest failed
    URL: http://192.168.1.3:44444
    Error code: 0x45500D27

    I have also tried turning off windows firewall at both ends.

    Any advise would be greatly appreciated.

    Kind regards,

    Doug

    **Update

    I just changed a few settings on the server (I changed the port of the publishing server to 80) and now I am getting a different error in event viewer-

    The content from server is not valid XML for publishing
    URL: http://APP01:80
    Error Code: 0x3E501605

    • Edited by DMuirhead Friday, June 20, 2014 2:24 PM Update
    Friday, June 20, 2014 2:09 PM

Answers

  • Hello,

    If you copy the files of the package to the client (say to c:\test).

    Then remove all the added packages, and then re-add them from the local path (using powershell) and then republish them - do they start then?


    Nicke Källén | The Knack| Twitter: @Znackattack


    Sunday, June 29, 2014 7:52 PM

All replies

  • With App-V 5.0 SP2 the client GUI actually became a package you publish, so there is no shortcut or GUI by default. 

    I would start here http://support.microsoft.com/kb/2778168 for troubleshooting your publishing refresh issues.


    Steve Bucci Microsoft

    Friday, June 20, 2014 6:22 PM
  • Could you list your current (modified) port list:

    • Management Server web application
    • Publishing Server web application
    • Reporting Server web application (if installed)
    • Default Web site

    Please verify that both, the App-V registry values and the IIS port bindings show the same values. 

     


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Monday, June 23, 2014 8:39 AM
    Moderator
  • Hello,

    Thanks for your reply.  My current ports are as follows-

    Management - Registry port 55555 - IIS Binding 55555

    Publishing Web Application - Registry port 80 - IIS Binding 80

    Reporting Server - Registry port 55554 - IIS Binding 55554

    The default site IIS Binding is 11111 But I am unsure how to check this in the registry.

    The management site does work it is purely the publishing service that I cannot get to work.

    I have disabled the windows firewall on both ends.

    **Edit

    When I run the get-appvpublishingserver on my client this is the output I get:

    ID:   1
    Setbygrouppolicy:   False
    Name:   Publishingservice
    URL:   http://app01:80
    Globalrefreshenabled:   False
    Globalrefreshonlogon:   False
    Globalrefreshinterval:   0
    Globalrefreshinterfalunit:   Day
    Userrefreshenabledd:   True
    Userrefreshonlogon:   True
    Userrefreshinterval:   0
    Userrefreshintervalunit:   Day

    • Edited by DMuirhead Tuesday, June 24, 2014 9:16 AM
    Tuesday, June 24, 2014 9:03 AM
  • OK, that looks good. 

    In your Publishing Server Registry section, there also should be a reference to the Management server address (Appv\Server\PublishingService: Publishing_Mgt_Server). Validate that this is pointing to http://app01:55555

    In your Management Server console, there is a 'Server' node. Check that it contains the Publishing server name (well, it's the same machine..)

    On the client, can you open a browser and navigate to http://app01:80? This should be possible without any additional authentication and you should receive an XML document.

    Make sure you have HF2 (or better: HF4) for App-V 5 SP1 installed on your server, as this brings Win 8.1 support. http://www.tmurgent.com/appv/index.php/resources/app-v-5-releases has the KB numbers.

    Is there anything in the server's App-V event logs?


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, June 24, 2014 12:03 PM
    Moderator
  • Hello, sorry for the late reply.

    Your last post has been a great help in solving the issue.

    I checked the registry location that you asked and that was as it should be, also in the management console the APP01 server was there, and also when I browse to http://app01:80 I do indeed receive a page of XML.

    I next had a quick look at the event logs on the server and sure enough I was getting an error saying the client OS was not recognised (Or something similar).

    I logged onto the management console and clicked about and that brought up the version, although annoyingly I did not take a note of the original version number, but after upgrading to HF4 (I am now on version 8.0.1224.0).

    After installing HF4, I no longer receive the OS not recognised error, and when I go to Powershell on my client pc and do sync-appvpublishingserver -serverid 1 it is successful, I am also pleased to report that there are no more errors in the event logs both on client side & server side.

    The only issue I am experiencing now is that a sequenced application (Its just Microsoft Word) is not deploying?  Do applications take a while to sync?  Is there any PS command I can do to force a connection?  Or any way of getting to a GUI?  Also I noticed that there is a HF for the app-v client & sequencer.  I have done the client but I didn't do the sequencer - is this advisable with a Server 2012 r2 & Windows 8.1 enviro?

    Thanks very much for being so patient!

    Doug

    Tuesday, June 24, 2014 10:17 PM
  • Steve Bucci mentioned above where to get a client GUI: http://www.microsoft.com/en-us/download/details.aspx?id=41186

    or for real admins:

    sync-appvpublishingserver  (downloads the list of apps)

    get-appvclientpackage -all (returns all applications, even the new, 'hidden' once)

    Anyway you should see the word application in the XML (http://app01:80)  on , but not that the Publishing server only talks every 10 minutes to the Management server, so it may take a while 


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Wednesday, June 25, 2014 9:20 AM
    Moderator
  • Thanks for your help. I am still unable to get my sequenced application to work on my client, although I now believe it could be something to do with the sequencing process. I am currently in the process of building a blank machine to capture an application on.
    Thursday, June 26, 2014 8:29 AM
  • does get-appvclientpackage -all return anything on the client?

    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Thursday, June 26, 2014 9:30 AM
    Moderator
  • Yes, after I have successfully sequenced my new application on a clean VM, When I run get-appvclientapplication -all it comes back with the application which I sequenced, and when I run get-appvclientpackage -all I get the package that is published, and now the shortcut has shown up on the desktop, although when I click it nothing happens.

    And here is the Powershell output I get

    • Edited by DMuirhead Thursday, June 26, 2014 10:53 AM Added images
    Thursday, June 26, 2014 10:30 AM
  • Hello,

    If you copy the files of the package to the client (say to c:\test).

    Then remove all the added packages, and then re-add them from the local path (using powershell) and then republish them - do they start then?


    Nicke Källén | The Knack| Twitter: @Znackattack


    Sunday, June 29, 2014 7:52 PM