locked
Exchange 2003 - 2010 - There is currently no route to the distribution group expansion server RRS feed

  • Question

  • I'm on the last final steps from migrating from Exchange 2003 to Exchange 2010. All mailboxes are on 2010, I removed the smtp routing group connector from the servers and shutdown Exchange 2003.
    Email is flowing fine except for certain internal emails - example, when I do a test smtp from an application or email coming from sql alerts to an IT distribution group, etc. I went into the 2010 Queue viewer and saw alot of emails in the "unreachable domain".

    When I click on the "unreachable domain" queue I receive the error (screenshot)

    When i click on one of the stuck emails I receive the information\error:
    Identity: abc-MAIL2010\Unreachable\10419
    Subject: Test message
    Internet Message ID: <53ddf269-8611-463b-bf75-94d5fcffd2ad@abc-MAIL2010.abc.local>
    From Address: smtptest@barracudanetworks.com
    Status: Ready
    Size (KB): 1
    Message Source Name: SMTP:Relay Connector
    Source IP: 10.1.10.30
    SCL: 0
    Date Received: 12/20/2011 10:44:58 AM
    Expiration Time: 12/22/2011 10:44:58 AM
    Last Error: There is currently no route to the distribution group expansion server
    Queue ID: abc-MAIL2010\Unreachable
    Recipients:  opsys@abcsites.com


    I have already created a relay connector on the 2010 server with all subnets included.

    I noticed on one of the Distribution List properties>Advanced Tab> that the "Set expansion server" was the 2003 server, I just changed it to the 2010 server. Why is this? Shoudlnt they all be on the 2010 server? How can I fix all this? Help!

    How can I resolve this?

    Tuesday, December 20, 2011 4:37 PM

Answers

  • Hi,
    Check all your distribution groups and make sure they don't have any expanstion server set.
    You can do that by running: Get-DistributionGroup | where {$_.ExpansionServer -ne "$null"} | ft Name,ExpansionServer

    If you find DLs with and expanstion server set, remove it.
    Get-DistributionGroup | where {$_.ExpansionServer -ne "$null"} | set-distributiongroup -ExpansionServer $null

    By default, no expansion server is set, so for some reason, someone must have thougt it was a good idea to set one.


    Martina Miskovic - http://www.nic2012.com/
    • Proposed as answer by Byron Wright Tuesday, December 20, 2011 10:33 PM
    • Marked as answer by badlands2011 Wednesday, December 21, 2011 3:06 PM
    Tuesday, December 20, 2011 4:44 PM

All replies

  • Hi,
    Check all your distribution groups and make sure they don't have any expanstion server set.
    You can do that by running: Get-DistributionGroup | where {$_.ExpansionServer -ne "$null"} | ft Name,ExpansionServer

    If you find DLs with and expanstion server set, remove it.
    Get-DistributionGroup | where {$_.ExpansionServer -ne "$null"} | set-distributiongroup -ExpansionServer $null

    By default, no expansion server is set, so for some reason, someone must have thougt it was a good idea to set one.


    Martina Miskovic - http://www.nic2012.com/
    • Proposed as answer by Byron Wright Tuesday, December 20, 2011 10:33 PM
    • Marked as answer by badlands2011 Wednesday, December 21, 2011 3:06 PM
    Tuesday, December 20, 2011 4:44 PM
  • I ran that first command and about 20 DLs appeared. Just to confirm I should now run the second command you provided to remove any expansion server?

    I have no idea how they were set like this, strange. Will this solve the problem withthe messages stuck in the message queue?

    Tuesday, December 20, 2011 4:57 PM
  • Yes, run the second command to remove any expansion server set.
    When you have done that, restart the service msexchangetransport and the emails in the queue should be delivered.
    Martina Miskovic - http://www.nic2012.com/
    Tuesday, December 20, 2011 4:58 PM
  • Thanks but unfortunately that didnt work.

     

    In the app event log on the cas server I received in order these errors, one for every mailstore on the old exchange server it seems:

    1. Cannot find route to Mailbox Server CN=abc-MAIL,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=abc,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=abc,DC=local for store CN=Limit 3gig,CN=First Storage Group,CN=InformationStore,CN=abc-MAIL,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=abc,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=abc,DC=local in routing tables with timestamp 12/20/2011 5:14:38 PM. Recipients will not be routed to this store.

    2. The Microsoft Exchange Transport service has started the background scan of the queue database. All messages that have not yet been delivered will be loaded.

    3.The background scan of the transport queue database has completed. 30 message(s) were found.

    4. The service has started successfully. 

     

    5. The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time.

    Tuesday, December 20, 2011 5:30 PM
  • The above commands should at least make sure that you don't get the error message "There is currently no route to the distribution group expansion server" again

    Can you restart "Microsoft Exchange Mail Submission" (MSExchangeMailSubmission)?

    EDIT: The first error is expected since the old server hasn't been uninstalled yet but the routing group connector has been deleted.


    Martina Miskovic - http://www.nic2012.com/
    Tuesday, December 20, 2011 5:40 PM
  • It seems that those 30 emails stuck in the queue happened when I shutdown the exchange 2003 server. and the emails in the queue are either from or to Distribution Groups. I turned on the Exchange 2003 server and seems ok now.

    All email besides that is flowing fine. I dont know how it seems it may be still relying on the Exchange 2003 server somehow, all mailboxes are on 2010, the routing group connectos have been removed and when the 2003 Exchange server is shutdown all email is fine except those 30 in the queue (the to/from Distribution Groups).

    I restarted the Microsoft Exchange Mail Submission service and that didnt help either.

    Tuesday, December 20, 2011 5:53 PM
  • So, is the Microsoft Exchange Mail Submission Service started or not.
    Check with: Test-ServiceHealth

    Removing the routing groups is something that shouldn't be done until all Mailbox- and Public folder databases has been deleted in Exchange 2003.

     


    Martina Miskovic - http://www.nic2012.com/
    Tuesday, December 20, 2011 5:59 PM
  • yes, the Microsoft Exchange Mail Submission Service is started and the result of the test-servicehealth is good.

    I thought it was safe to remove the routing group connectors since there were no user mailboxes on the 2003 server and the PF's have been moved to 2010 as well. So I assume there would be no reason for mail to transfer through it anymore?

    Tuesday, December 20, 2011 7:19 PM
  • So I recreated the routing group connectors and the mail that was stuck in the queue flowed out. The Exchange 2003 server is back online.

    When I had the 2003 server shutdown mail was flowing fine except for those few mails in the 2010 queue, which seemed to be to Distribution Groups.

    Strange that there is nothing pointing to the 2003 server and no mail should be flowing through it since the mailboxes have been removed and everything is pointing to the 2010 server.

    Tuesday, December 20, 2011 8:46 PM
  • Mail was still flowing to the 2003 server because those groups were configured to use 2003 as the expansion server (which expands group membership to be invidual users). The messages were already on route to the 2003 box, that is why they did not deliver properly after the expansion server was changed (they were stuck in the queue and not reevaluated).

    Now that the expansion server setting has been removed, new messages to those distribution groups will not be routed to the Exchange 2003 server.


    Byron Wright (http://byronwright.blogspot.com)
    Tuesday, December 20, 2011 10:32 PM