Adding Content Advisor to Internet Explorer 11, No "Content Page" folder in Group policy editor RRS feed

  • Question

  • I want to use Content Advisor in Internet Explorer 11. I have found a few post that say to use Local Group Policy Editor. However "Content Page" folder does not exist. I have checked the following locations:

    Computer Configuration>Administrative Templates>Windows Components>Internet Explorer>Internet Control Panel>

    User Configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control Panel ->

    Internet Control Panel has only two folders "security page" and "advanced page". The "Content Page" folder does not exist.

    • Edited by TrekTNG789 Monday, December 16, 2013 5:51 AM
    Monday, December 16, 2013 5:44 AM

All replies

  • Hi,

    you did not mention your windows version.

    In Internet Options (win7/IE11)>Content tab, Content advisor has been replaced with Parental Controls.


    Monday, December 16, 2013 7:41 AM
  • I have windows 7 professional with IE 11.

    IE 9 has both parental control and content advisor

    IE 10, IE 11 only parental control.

    It can only be considered a replacement if it performs the function of the thing being replaced. In this case it is more accurate to say downgrade.

    I am looking to add about 10 websites to the whitelist and block all the others with a supervisor password, like it was possible to do this in Content advisor. I cannot do this with parental control, so I am looking for a way to put content advisor back on to IE 11 using Local Group Policy Editor.

    Please read the above the post.

    Tuesday, December 17, 2013 5:54 AM
  • Wednesday, December 18, 2013 12:07 AM
  • Something not quite right with your inetres.admx?

    On my Win7+IE11 system, I can enable Content Advisor by using the GPO setting you mention (it's also mentioned in the comments of this blog post about IEM)

    I did a quick test of enabling/disabling Content advisor, and that part worked fine (I didn't do any Content Advisor setup of passwords, ratings, sites etc)

    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Wednesday, December 18, 2013 12:44 AM
  • Hi,

    Based on your description, I would like to suggest you try to re-register the related mmc snap-in DLL to check the result:

    regsvr32 <snap-in DLL name>

    Administrative Templates and Scripts: gptext.dll

    For your reference:

    Some Group Policy areas are missing from the Group Policy Editor

    This article is also applied for Windows 7.

    Hope it helps.


    Blair Deng

    Blair Deng
    TechNet Community Support

    Wednesday, December 18, 2013 1:49 AM
  • Did you ever find a fix for this? I'm having the same issue, but I have Windows 10 Professional and I did install the feature update (1511).
    Friday, February 3, 2017 7:56 PM
  • Hi CarbonCT,

    The GPO settings found under Windows Settings>Internet Explorer Maintenance were depreciated in IE10.

    Please see the workarounds found with this web search (there are quite a few).


    Friday, February 3, 2017 11:36 PM
  • in Windows 10, the old Content Advisor strings and \Content\ category within the ADMX/ADML GP templates, are removed. That would be why the \Content\ category is missing from the GPeditor.

    I've just checked on my Win10-1607, and the INETRES.ADMX/ADML files have had the references removed.

    (PS: it's not at all related to IEM. IEM is not a template-based control, IEM is embedded within a DLL, which is long gone, and never was in Win10)

    I just tried tinkering with the equivalent registry keys on my Win10-1607, and couldn't get CA to show up, but I didn't reboot)

    It may be, that CA is finally totally gone..

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Proposed as answer by Bennon Maina Tuesday, April 18, 2017 2:09 PM
    Saturday, February 4, 2017 12:46 AM