locked
Hyperlinks in Office documents change from absolute to relative RRS feed

  • Question

  • Hi

    I'm experiencing a problem with Office/SharePoint that was documented on this forum back in 2008 without a solution:

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/8ce40b9c-cc93-4a6b-9b5a-142a3ad6c4a8

    Does anyone know if a fix is now available?

    It's pretty bizarre: If I insert a hyperlink into an Excel file stored on SharePoint then repeatedly open the file for editing and save it again, at some point the hyperlink will switch from absolute to relative without any intervention from me.

    Trouble is, when it changes to relative it no longer works for people editing the file because the link points to a destination relative to the user's drafts folder on the local drive.

    I've noticed that this doesn't happen on all my sites. In some sites Office behaves differently. In the site where the problem occurs, the sequence for opening the file is like this:

    Menu: Edit in Office Excel
    Dialog: You are about to check out and edit: filename
                 [tick] Use my local drafts folder

    In the site with no problem, the sequence is like this:

    Menu: Edit in Office Excel
    Dialog: Some files can harm your computer...You are opening the following file: filename

    In the site where there's a problem, unchecking the 'Use my local drafts folder' seems to solve the issue. But I cant rely on all users following an instruction to do that. It only takes one to forget and the links become broken for everyone afterwards.

    Office 2007
    SharePoint 2007
    IE8

    Help appreciated!

    -Stuart

    Friday, March 9, 2012 12:00 PM

Answers

  • Hi Stuart,

    I tried to reproduce this issue, but it worked well with both popup dialogs in my environment.

    As a workaround, you can change the dialog from "Dialog: You are about to check out and edit: file name [tick] Use my local drafts folder"  to "Dialog: Some files can harm your computer...You are opening the following file: file name" via disable the option "Require documents to be checked out before they can be edited" from those problem libraries versioning settings page.

    Thanks


    Daniel Yang

    TechNet Community Support

    • Marked as answer by Stoo Thursday, March 15, 2012 3:03 PM
    Wednesday, March 14, 2012 9:03 AM
    Moderator

All replies

  • Hi,

    Try repairing your office installation.


    Thanks, Rahul Rashu

    Sunday, March 11, 2012 11:12 AM
  • Thanks Rahul, but I have tried repairing my Office installation, and it hasn't had any effect on this.

    The issue was pointed out to me by a user, so it isn't just me experiencing the problem, but I guess I could get a few other people to try it and see if it's across the board or not.

    I wonder if having different site templates would account for Office handling integration differently from one site to another. Any thoughts?

    -Stuart

    Monday, March 12, 2012 6:07 PM
  • Hi,

    Try not using your local draft folder for this and then observe this.


    Thanks, Rahul Rashu

    Tuesday, March 13, 2012 4:23 AM
  • Yes, if I uncheck the option to use the local draft folder, then the problem doesn't occur. Cant rely on users doing that though!

    It's puzzling that Office/SharePoints uses the local draft folder by default when opening files in some sites, but not in others!

    -Stuart

    Tuesday, March 13, 2012 7:20 PM
  • Hi Stuart,

    I tried to reproduce this issue, but it worked well with both popup dialogs in my environment.

    As a workaround, you can change the dialog from "Dialog: You are about to check out and edit: file name [tick] Use my local drafts folder"  to "Dialog: Some files can harm your computer...You are opening the following file: file name" via disable the option "Require documents to be checked out before they can be edited" from those problem libraries versioning settings page.

    Thanks


    Daniel Yang

    TechNet Community Support

    • Marked as answer by Stoo Thursday, March 15, 2012 3:03 PM
    Wednesday, March 14, 2012 9:03 AM
    Moderator
  • By Jove! I do believe that workaround has cracked it!

    Thanks

    Stuart

    Thursday, March 15, 2012 3:05 PM