locked
Can't re-install vs2017 community RRS feed

  • Question

  • My visual studio community crashed when I tried to apply the latest update, I don't know which update it was, as foolishly i didn't write it down.

    It got so far into the update, then it crashed, saying that VS2017 Community was now corrupted, and the only way back was to re-install it.  I uninstalled visual studio, and tried to re-install it, but when it go to the screen where I choose what elements of Visual Studio i want to use, it wouldn't let me go any further, saying something like "The installer folder wasn't empty".  I tried to empty it, but it wouldn't let me, as although I am an administrator, I didn't have administrator privileges to remove these files. After trying without success to fix this, I gave up and went to bed.

    The following morning, I tried to install VS2017 again, and the installation worked.  However, I noticed that it's installed VS2017 Enterprise.  I can't afford the enterprise version, so I'm worried that microsoft are going to charge me for it.  What did I do wrong, and how can I fix it?

    Tuesday, August 22, 2017 9:19 PM