locked
Disable Document Check Out and Check In? RRS feed

  • Question

  • In SharePoint 2010, is it possible to disable the Check out/check in option in a document library?  I have a doc library that many people access, some users are leaving files checked out and then others cannot see changes.  Is there a way to just stop the check out/check in altogether?
    Monday, September 5, 2011 2:06 PM

Answers

All replies

  • Hi,

    Someone has enabled check in and check out for that document library. The answer is yes, you can disable it as below:

    To disable check-in and check-out on a SharePoint document library:

    1. Navigate to the SharePoint document library on which you want to disable check-in and check-out.
    2. On the Settings menu, click Document Library Settings.
    3. On the Customize page under General Settings, click Versioning settings.
    4. On the Document Library Versioning Settings page, select NO for Require documents to be checked out before they can be edited?, and click OK.

    Regards

    Henrik A. Halmstrand
    http:/www.sharepointrevealed.com
    http://getspconfig.codeplex.com
    Monday, September 5, 2011 2:31 PM
  • Hi Henrik,

    I already have NO checked off for "Require documents to be checked out before they can be edited?".  But this doesn't stop people from checking files out.

    I just realized that when edit a files properties using the sharepoint from the drop down list "Edit Properties" everything works fine.  However, I'm also using a tool called VizitPro to edit PDF files and when ever I edit files there, it does check out the files.

    Is there a way to truely disable the check out function?

    Monday, September 5, 2011 2:54 PM
  • See this post: http://social.msdn.microsoft.com/Forums/en/sharepointdevelopment/thread/7b154cba-711a-42ee-bf35-b71d32ba3dd5

    This works for MOSS but not sure for 2010. You can try and see if it works or not.


    Connect with Me!

    Aryan Nava | Twitter: @cloudtxt | Blog: http://virtualizesharepoint.com
    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Monday, September 5, 2011 3:01 PM
  • If do not want check in and check out this means that you do not want version control. If you disable version control then check out and check in will not be available anymore.
    Monday, September 5, 2011 3:11 PM
  • I have version control turned off already, documents still get checked out.
    • Proposed as answer by Davidaus7777 Thursday, January 18, 2018 12:55 AM
    Monday, September 5, 2011 9:17 PM
  • Check if publishing features are enabled at site or site collection level.

    Check this link too:

    http://technet.microsoft.com/en-us/library/ff718246.aspx


    Regards

    Henrik A. Halmstrand
    http:/www.sharepointrevealed.com
    http://getspconfig.codeplex.com

    Tuesday, September 6, 2011 5:07 PM
  • I'm wondering if you ever got this resolved. The same thing is happening to me: no matter that I already have NO selected for "Require documents to be checked out before they can be edited?" in Versioning settings for my library, still all of my documents act as if they want to be checked out when I click on them and still have "Check Out" selectable in the menu drop down for each item.

    That seesm to me to indicate that "Require documents to be checked out before they can be edited?" in Versioning settings DOES NOT WORK.

    Is this a known fact? Why everyone else in this thread point to that as a solution when it doesn't work?

    Enquiring minds want to know...

    Tuesday, July 9, 2013 12:30 PM
  • Hi, Jambou.

    Have you checked if there is some required field to the documents empty?

    Regards,

    Douglas

    Wednesday, July 17, 2013 1:33 PM
  • Hi, Mandel.

    Have you checked if there is some required field to the documents empty?

    Regards,

    Douglas

    Wednesday, July 17, 2013 1:34 PM
  • Hi Douglas, there are no required fields in the particular document libary I am working with as far as I can tell, other than the name of each document in the libray. My documents in the library all have names and titles.

    Still, "checking out" never seems to go away, even though I have changed settings so that it should no longer be active in this library.

    I'm guessing it has something to do with dpocuments HAVING to be checked out during the upload process? And, even though the documents in essence get checked in once they're in a library, I can't really turn off "checking out"?

    I don't know. What seems odd to me is that from the tone of other answers in this thread, others of you seem to be saying that you CAN turn off "checking out" in libraries. Does that mean you no longer see "Check Out" in the drop down menu for document names in that library?

    Does it mean you're not asked about checking out a document if you click on the document Name's link?

    This always happens with PDF files in any library I'm working with. For Word files, it depends on whether we have SP Services turned on or not.

    It could well be that I'm just not understanding seomthing fundamental to SP here.

    Thanks.

    Wednesday, July 17, 2013 1:57 PM
  • Start of Rant

    I wonder if anyone from Microsoft ever even reads posts like this.

    I have scoured the web and it seems this is something people want to do, just get rid of the "checkout" on certain libraries. I don't want people getting a message asking them to "open" or "open and checkout" on a PDF, I just want them to be able to read it then close it with not extra interaction. It works that way on my anonymous public side, why not on my secure internal... ahhhh

    The turning off versioning as suggested here does not resolve...

    End of Rant

    Wednesday, August 7, 2013 9:27 PM
  • OK, found a solution.

    Seems to be Adobe and integration into SharePoint.

    Add this registry setting to your desktop.

    Method 1:

    1. Open the registry editor
    2. Go to HKLM\SOFTWARE\Policies\Adobe\…\…\FeatureLockDown.
    3. Create a key called cSharePoint.
    4. Create a DWORD value, name it bDisableSharePointFeatures.
    5. Set its value to 1.

    This should fix this for you.

    Wednesday, August 7, 2013 10:13 PM
  • Do I have to change this registry setting on every client computer?
    Thursday, December 26, 2013 8:11 PM
  • The amazing part about this, is that this is still an issue on SharePoint 2013.  Very annoying for the same reason mentioned above.

    For now, I have all my document libraries open in browser so that Adobe Acrobat does not open.


    It's me

    Tuesday, June 17, 2014 4:15 PM
  • Having the same issue.  Not sure why so many people don't understand.

     1) Yes you can disable REQUIRING check-out.

     2) No you cannot disable the option to check-out.

    I have users over-thinking, checking out documents (because they don't understand what Check-Out means) and never checking them back in. 

    MICROSOFT: This option would be great.

    Thursday, October 2, 2014 7:37 AM
  • We are experiencing the same issue with SharePoint 2013 documents being opened by Word 2010.

    Document is not checked out, user navigates to doc, opens in browser app, then clicks "Edit Document" -> "Edit in Word".. Then document shows as checked out..  You then can go to File -> Info -> Discard Check Out, and continue editing while allowing others to open the document read-only.

    My issue is that we do want versioning, but not check out.   Once we have all our users on Office 2013, we are expecting to be able to use the co-authoring features.

    Wednesday, October 8, 2014 9:54 PM
  • Thanks.... Douglas

    It works for me...

    Monday, September 5, 2016 12:34 PM
  • Hi! For later, this helped me for 2016. If required fields is missed, the document are marked as checket out regardless of the versioning settings.

    Friday, June 9, 2017 8:38 AM
  • Hi,

    Someone has enabled check in and check out for that document library. The answer is yes, you can disable it as below:

    To disable check-in and check-out on a SharePoint document library:

    1. Navigate to the SharePoint document library on which you want to disable check-in and check-out.
    2. On the Settings menu, click Document Library Settings.
    3. On the Customize page under General Settings, click Versioning settings.
    4. On the Document Library Versioning Settings page, select NO for Require documents to be checked out before they can be edited?, and click OK.

    Regards

    Henrik A. Halmstrand

    Note that in the above, what is actually being commanded is this:

    • Require documents to be checked out before they can be edited?     NO

    In other words, by selecting no, you are not turning off the ability to check out, you are allowing people to modify the document, without having it checked out.  This does not appear to solve the problem.

    Wednesday, October 4, 2017 2:26 PM
  • Hi. I know this is an old post, but I am having a related problem that I cannot figure out how to solve. I have a SP 2010 site collection, and I have full design and editing permissions. I am the collection owner. I have set every page library in the parent and child sites to NOT require checkout before pages can be edited since I am the only one editing pages. However, despite the fact that I have checked NO for Require documents to be checked out before they can be edited?, my sites still REQUIRE me to check out the pages before I can edit them. This is extremely annoying as I have to keep the document library window open to continually check out pages while I work on them in other browser windows. Does anyone know what the issue could be and how I can fix it? Thanks.
    Friday, March 23, 2018 7:43 PM
  • Hi. I know this is an old post, but I am having a related problem that I cannot figure out how to solve. I have a SP 2010 site collection, and I have full design and editing permissions. I am the collection owner. I have set every page library in the parent and child sites to NOT require checkout before pages can be edited since I am the only one editing pages. However, despite the fact that I have checked NO for Require documents to be checked out before they can be edited?, my sites still REQUIRE me to check out the pages before I can edit them. This is extremely annoying as I have to keep the document library window open to continually check out pages while I work on them in other browser windows. Does anyone know what the issue could be and how I can fix it? Thanks.
    If you open a page for editing that requires checkout, it will prompt you.  You don't have to keep the library window open.  You can also checkout a page on the ribbon bar.
    Friday, March 23, 2018 9:01 PM
  • Hi DubaStep. Thanks for responding, but it does not give me the option to check out the page from the page itself, which is another frustration because I have that option with other sites I manage in other site collections. However, that still doesn't explain why the site REQUIRES that I check out a page even though I have set it to NOT require checkout for editing. Has anyone encountered this issue?
    Tuesday, March 27, 2018 1:30 PM