none
Timephased grid in Task tracking method Hours Per Period not enabled in PWA 2010 RRS feed

  • Question

  • I have been trying to configure and test our Task Tracking method in PWA 2010 to mirror as close as possible PWA 2003 method.  I have disabled the Time sheet function so it would not be confusing to anyone.

    I have set my Task Settings and Display for the "Hours of Work Done per Period" option and did not pick the Single User mode in Timesheet Settings and Defaults.  From my understanding with these settings you should be able to bring up the Task Sheet on the PWA home page and enter daily hours in the timephased grid on the right in the Actual Work cell for whatever day you chose and also for Overtime hours.  You are also suppose to be able to change Remaining Work if needed.

    In the Resource I have setup for testing the grid on the right is not accessable on any day.  The only place I am able to place hours is in the Actual Work column on the left section where I can also change Remaining Work but this is not what I need to mirror PWA 2003 where it works as I have explained.

    I have tried to change the Methods to see if this changes the results but it does not seem to make a difference.

    Any advice would be appreciated, thanks.

    Forrest

    Tuesday, January 3, 2012 6:36 PM

Answers

  • Yes, changing it to auto scheduled and republishing should work.

    Also, as a side note, you can set the default to be auto scheduled from Task Mode Settings under Server Settings >> Additional Server Settings


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com
    • Marked as answer by Forrest Tuesday, January 3, 2012 9:09 PM
    Tuesday, January 3, 2012 8:37 PM
    Moderator
  • Hi,

    to check if the SP1 is installed or not, you can go to control panel, programs and features and click on view installed updates to view the patches applied to Project Server 2010.

    I was able to reproduce you issue, you have to change your tracking method from PWA -> Server settings -> Task Statusing and display. And if the checkbox to "Force Project Managers to use the selected method is...." is selected than you can change the setting from project professional.

    Change the tracking method to Hours of work done per period, open the project plan and republish. to verify, click on File in Project Project Professiona, click on Info and on your right Tracking method should be " Specify Hours"

    And you can certainly enter the acutal hours on today's date even if your task start date was 2 week back, i was only trying to make a point that if you are looking for hours ddetails in task timephased view than you need adjust the perido from the ribbon to view.

    Hope this helps.


    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )
    • Marked as answer by Forrest Tuesday, January 3, 2012 9:21 PM
    Tuesday, January 3, 2012 9:13 PM
  • Khurram,

    I went to Control Panel and looked, it does not have the SP1 patch.

    I was able after selecting your instructions and using auto-scheduled tasks to enter resource hours on the right side of the grid.  I was even able to enter time on days outside of the scheduled range and it automatically moved the task to the new start date after Re-publishing.

    Thanks again

    Forrest

    • Marked as answer by Forrest Tuesday, January 3, 2012 9:21 PM
    Tuesday, January 3, 2012 9:21 PM

All replies

  • Change the method on the project and republish....File > Info, and then you'll
    see the method on the right.  (I don't have Project open in front of me,
    but it's something like that)
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Tuesday, January 3, 2012 6:44 PM
    Moderator
  • Andrew,

    When I get into the Project in Project Pro and go to File > Info > Tracking Method the only option is "Specify Hours".  I republished anyway and went back into PWA and looked at the Test Resource's Task Page.  I can see the timephased grid on the right as before and it is still not accessable.

    Any other thoughts???

    Tuesday, January 3, 2012 7:12 PM
  • What patch level are you on? If pre-SP1, then check to see if the tasks are "manually" Scheduled. They were previously not supported for Time-Phased input.
    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com
    Tuesday, January 3, 2012 7:44 PM
    Moderator
  • Hi,

    in addition to Prasana/Anderw advice, you can also check if the timephased task view is displaying the current week, only then you will be able to enter the actual hours against the assigned hours.

    also you can set from project server to force the reporting method to avoid such issue and apply consistency across the organization, for this:

    PWA-> Server Settings -> Under Time and Task Management, Task Settings and Display -> choose the method and check the box available in Tracking methods "Force Project Managers to use the ....."

    hope this helps.


    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )
    Tuesday, January 3, 2012 8:15 PM
  • Gentlemen,

    Thanks so much for your input.

    I am currently verifying my Patch Level, I suspect it is Pre-SP1

    Prasanna, The test project was manual mode because I generated it from within PWA.  That brings up a question; If I am pre-SP1 can I get past this by changing to Auto-schedule mode?

    Khurram, by current week do you mean in relation to the task?  If the task start date is two weeks ago is that the current week I need to be at?  What if I need to enter time for a task today that was scheduled to start two weeks in the future, do I need to move the start back two weeks?

    Forrest

    Tuesday, January 3, 2012 8:24 PM
  • Yes, changing it to auto scheduled and republishing should work.

    Also, as a side note, you can set the default to be auto scheduled from Task Mode Settings under Server Settings >> Additional Server Settings


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com
    • Marked as answer by Forrest Tuesday, January 3, 2012 9:09 PM
    Tuesday, January 3, 2012 8:37 PM
    Moderator
  • Hi,

    to check if the SP1 is installed or not, you can go to control panel, programs and features and click on view installed updates to view the patches applied to Project Server 2010.

    I was able to reproduce you issue, you have to change your tracking method from PWA -> Server settings -> Task Statusing and display. And if the checkbox to "Force Project Managers to use the selected method is...." is selected than you can change the setting from project professional.

    Change the tracking method to Hours of work done per period, open the project plan and republish. to verify, click on File in Project Project Professiona, click on Info and on your right Tracking method should be " Specify Hours"

    And you can certainly enter the acutal hours on today's date even if your task start date was 2 week back, i was only trying to make a point that if you are looking for hours ddetails in task timephased view than you need adjust the perido from the ribbon to view.

    Hope this helps.


    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )
    • Marked as answer by Forrest Tuesday, January 3, 2012 9:21 PM
    Tuesday, January 3, 2012 9:13 PM
  • Just want to say Thanks to you all for the great input.

    I was able to run a test case using auto scheduled tasks and did update approved entered hours in right side section.

    Schedule looked correct after re-publishing.

    Much Thanks

    Forrest

    Tuesday, January 3, 2012 9:16 PM
  • Khurram,

    I went to Control Panel and looked, it does not have the SP1 patch.

    I was able after selecting your instructions and using auto-scheduled tasks to enter resource hours on the right side of the grid.  I was even able to enter time on days outside of the scheduled range and it automatically moved the task to the new start date after Re-publishing.

    Thanks again

    Forrest

    • Marked as answer by Forrest Tuesday, January 3, 2012 9:21 PM
    Tuesday, January 3, 2012 9:21 PM
  • Hello All,

    I am new to project server and using the Tasks web part on Project Server 2010. Unlike the previous version, the web part is not showing total hours by day. The Hours per Day checkbox is not there in the Projects Web App Category on the Web part properties. This is critically important my company. I was reseaching the web, of course without success, if it is possible to add this functionality.

    Any help please?

     


    • Edited by Girma Teka Monday, January 16, 2012 9:25 PM
    Monday, January 16, 2012 9:23 PM
  • Hello,

    Same issue, i'm not using timesheet only My task and I'm looking a way to have total hours by day in this web part. But I don't understand why Microsoft don't allow user to add it with a parameter ??

    Tuesday, January 24, 2012 3:57 PM