none
Performance Point cannot create Data source RRS feed

  • Question

  • Hello -

    We are using SharePoint 2010 and project Server 2010 that are patched up to date

    I have created a Performance Point Service Application but when I try to create a Datasource via Dashboard Designer, it provides the error below

    This DataSource cannot be used because Performance Point Services has not been configured correctly. Additional Details have been logged for your administrator.

    In the Event log it created IDs 5 and 6

    6

    The following data source cannot be used because PerformancePoint Services is not configured correctly.  Data source location: https://<hostname>/AFSSSA/ProjectBICenter/Data Connections for PerformancePoint/114_.000 Data source name: New Data Source  The PerformancePoint Services Unattended Service Account is not set. The setting is located in "Manage service applications" in SharePoint Central Administration under the PerformancePoint Services management page.

    5

    PerformancePoint Services has not been configured with a valid Unattended Service Account. The setting is located in "Manage service applications" in SharePoint Central Administration under the PerformancePoint Services management page.

    In the ULS Logs I get the same errors.

    I have looked at this and the Service Application is created as others we have created, it is associated with the correct web application and the unattended account is set correctly and has access to the OLAP and SQL databases.

    Is there anywhere else that we should be looking?

    Thanks,

    Shane


    Shane O'Hanlon (Accenture)

    Thursday, October 25, 2012 4:36 PM

All replies

  • Hi Shane,

    For the Analysis Services data source, have you tested different cubes within the cube database? Do they all give the same error? Is the authentication set to use the unattended service account? Does that account have access to the cube (either an admin of SQL AS or have View Olap Data in project server)? Have you tried a SQL server table data source connecting to the reporting database?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, October 25, 2012 4:46 PM
    Moderator
  • Hi Paul,

    Thanks for responding

    The problem is that I cannot create the data source. After I enter the server, it doesn't provide any databases and then returns the error in DB Designer.

    The account has access to the Cube in question alright and returning anything from the SQL Database Server throws the same message.

    What do you mean by "Is the authentication set to use the unattended service account". The unattended account is set in "PerformancePoint Service Application Settings"

    Let me know if you need more info

    Thanks,

    Shane


    Shane O'Hanlon (Accenture)

    Thursday, October 25, 2012 4:53 PM
  • Hi Shane,

    Does it make a difference what account you run the dashboard designer with? Have you tried more that one SQL server? Do they all give the same error? Does the performancepoint service account have access to the web application content database? The command below will give the account the correct access to the content database if it doesn't have already:

    $w = Get-SPWebApplication -identity <web application>
    $w.GrantAccessToProcessIdentity("<service account>")

    Taken from this link: http://technet.microsoft.com/en-us/library/ee748644.aspx

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, October 25, 2012 7:51 PM
    Moderator
  • Dashboard Designer get credential from IE cache, so what account you used when open DD?

    And are you sure your "unattended account" config correctly and it in SSAS --> Analysis Service Properties --> Security ?


    Nguyễn Dương Phú

    Friday, October 26, 2012 4:24 AM
  • Hello, I'm working with Shane on this problem.

    To answer everyone's questions:

    Q:  Does it make a difference what account you run the dashboard designer with?
    A:  No.

    Q:  Have you tried more than one SQL Server?
    A.  Yes, it keeps failing.

    Q:  Does the performancepoint service account have access to the web application content database? The command below will give the account the correct access to the content database if it doesn't have already:

    $w = Get-SPWebApplication -identity <web application>
    $w.GrantAccessToProcessIdentity("<service account>")

    A:  Yes, I did the above (removed identifying details):
    PS C:\Users\username> $w = Get-SPWebApplication -identity "Web Application"
    PS C:\Users\username> $w.GrantAccessToProcessIdentity("Domain\Unattended.User.Account")
    PS C:\Users\username>

    Q:  Dashboard Designer get credential from IE cache, so what account you used when open DD?
    A:  Both an administrator account and the unattended user account (which has administrator privileges).

    The cmdlet Get-SPPerformancePointServiceApplication | Get-SPPerformancePointSecureDataValues returned the correct value, the Domain\Unattended.User.Account.

    Any other suggestions would be greatly appreciated.

    Friday, October 26, 2012 7:07 PM
  • Note that with the PowerShell cmdlet that Paul mentions, you need to grant access to the PerformancePoint service account rather than the unattended service account. That's the account that's running the PerformancePoint Services application pool. (You can find this account by selecting the service application in Central Administraiton and clicking Properties in the ribbon.)

    Since the error that you're seeing is specific to the unattended account not being configured, you may want to delete and reconfigure the unattended service account in PerformancePoint Application Settings. See Configure the unattended service account for PerformancePoint Services for reference. Also, ensure that Secure Store is correctly configured (see Configure the Secure Store Service).

    And of course, be sure to select the Unattended Service Account option in your data source in Dashboard Designer before you try to connect to SQL Server or Analysis Services.

    • Proposed as answer by AvivaX Monday, October 29, 2012 1:22 PM
    Friday, October 26, 2012 10:11 PM
  • apart of my Q have not got answer yet:

    Did unattended account in SSAS' security group ?


    Nguyễn Dương Phú

    Saturday, October 27, 2012 6:20 AM
  • Yes, it had been added to the SSAS security group.

    The solution to the problem turned out to be rather simple:  The Windows Claim Token Service was stopped on all three servers in our farm.  (We are using NTLM authentication.)

    Thanks to everyone for all of the suggestions.

    Monday, October 29, 2012 1:41 PM
  • Hi,

    try to follow below steps.

      • Navigate to Central Administration | Manage Service Applications | PerformancePoint Service Application | Performance Point Service Application Settings
      • Configure the unattended service account
    1. Start using Dashboard Designer.

    In case still getting error then first perform below steps then repeat above steps again

    1. Navigate to Central Administration | Manage Service Applications | Secure Store Service
    2. Click Generate New Key from the ribbon
    3. Type in a pass phrase and click OK.

    Thanks !!!


    Sachin Vashishth MCTS

    Sunday, August 11, 2013 2:46 PM
  • Did this ever get fixed? I have the same issue. I get no databases in the drop-down list when I enter the Analysis Services server information when creating a new data source in PerformancePoint.
    Monday, September 9, 2013 2:15 PM
  • Found the fix. Requires ADOMD version 10 (SQL 2008 R2). Can find it here: http://go.microsoft.com/fwlink/?LinkId=130651.

    1. Install ADOMD.NET version 10 from link above.

    2. Run IISReset

    It then works.

    Credit to Yossi Dahan for posting info on his blog: http://yossidahan.wordpress.com/2012/08/14/cant-get-ssas-databases-to-appear-in-performance-point-dashboard-designer-check-you-adomd-net-version/

    and to Chris Givens for posting link to ADOMD.Net version 10: http://social.technet.microsoft.com/Forums/sharepoint/en-US/d6ad5601-bb81-4972-a7ff-2fb555b01d8f/microsoft-sql-server-2008-analysis-services-adomdnet-installation-error

    • Proposed as answer by Matz Höög Monday, February 24, 2014 1:00 PM
    Monday, September 9, 2013 2:38 PM