none
MessageCopyForSentAsEnabled on 2016 CU4 RRS feed

  • Question

  • Folks,

    MS has recently released the CU4 to make the MessageCopyForSentAsEnabled available to any type of mailbox. The problem is that - even if the it's set to true - the messages sent from the shared mailbox **which is actually just a user mailbox with full & sendas permission to someone else ** keep going to the owner sent items.

    Did someone apply this CU and could confirm this issue?

    This is the command

    set-mailbox "Mbox/W-Full&SendAs_Rights_To_Owner" -MessageCopyForSentAsEnabled $true

    I would have done the mailbox as shared but since users need activesync this solution is not applicable. Last and not least, each user will have a dozen of email accounts: I just can't add them one by one in Outlook... it's not feasible. 

    Regards



    • Edited by Selva_MSN Thursday, December 22, 2016 11:30 PM
    Thursday, December 22, 2016 4:51 PM

All replies

  • Hi Selva,

    Please refer to the following steps, and confirm if there is any misunderstanding:

    1. Grant user Test2 "full access" & "Send as" permission to Test1, and change the MessageCopyForSentAsEnabled to $true on mailbox Test1:

    2. In test2 mailbox, send an email from test1 , but the message only locate in test2 mailbox's sent item folder, not in test1 mailbox's sent item folder, as below:

    My lab is Exchange 2016 CU4 also :

    If any misunderstanding, please feel free let me know, I will look into this issue further and give you an update ASAP.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 23, 2016 10:24 AM
    Moderator
  • Hi Niko,

    No, there's no misunderstanding.

    I have followed the MS manual for this option. When I found that the feature had been applied to all type of mailbox (not only shared), I pushed the CU4 immediately to my server.

    In any cases, I have done the same changes you mentioned in your post above. Exchange version corresponds to mine

    1) applied send as and full permissions to the various mailboxes for my user

    2) applied the messagecopysentasenabled to all the mailboxes

    so I have userA, and dozens of userA(n) mailboxes. These mailboxes have sendas+full for user userA, plus messagecopysentasenabled equal to $True

    Thanks,Alex

    • Edited by Selva_MSN Tuesday, December 27, 2016 3:50 PM
    Tuesday, December 27, 2016 1:25 PM
  • Hi Selva,

    This is quick note to let you know we are performing research on this issue and will give you an update as soon as possible.

    Thanks for understanding and support.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 30, 2016 9:41 AM
    Moderator
  • Thanks Niko
    Saturday, December 31, 2016 5:20 PM
  • Hi Niko, sorry for bothering you but did you have a chance to replicate this issue? Thanks
    Monday, January 9, 2017 9:16 AM
  • Hi Selva,

    Sorry for delay.

    I have done lots of tests, but it can success sometimes, not always, as below :

    1. there are two mailboxes named Niko01& Niko02, grant Niko01 the "send as & full access" permissions to Niko02:


    2. Set messagecopysentasenabled to true:


    3. login Niko01 mailbox via OWA, and send a message as Niko02, and then check the Niko02's sent item folder:

    If using a shared mailbox, and set messagecopyforsentasenabled to true, every message is copied as expected.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, January 10, 2017 6:36 AM
    Moderator
  • Hi Niko,

    So you confirm that the problem sometimes remains, right?

    Just to make sure we are on the same page: I am talking about normal mailbox, not 'shared '... I know it works well with that kind of mailbox.

    Regards,

    Alex

    Tuesday, January 10, 2017 10:54 AM