Group Policy for Wallpaper


  • Hello Everyone

    As per organization's requirement I pushed a fixed wallpaper to all our users using group policy desktop wallpaper settings. After pushing the wallpaper settings, following situation is observed :

    1) For some users, the group policy applied immediately after their next login.

    2) For some users, the group policy applied but instead of the jpg image pushed, a black screen is displayed as their desktop.

    3) For remaining users, the group policy simply didnt get applied and their desktop is what they have set.

    Kindly suggest on this scenario ans steps to ensure the policy gets applied to all users.

    Thankyou in Advance

    Saturday, February 25, 2017 4:34 PM

All replies

  • Hi, Avi Yadav.

    Even if you have a "fast" connection, GPO doesn't grant a 100% of configurations to work. You could start with:

    "gpupdate /force" to clean GPO cache and reapply Group Policy. Powershell may help you with that if you can't wait.

    Wait for users to reboot OS for 2-3 times if you can wait.

    Saturday, February 25, 2017 7:48 PM
  • Dear Serge

    Thanks a lot for your response. 

    Actually I did gpupdate /force on systems that did not get updated. Also I have waited for more than a week and the policy is still not getting applied.

    Sunday, February 26, 2017 11:42 AM
  • Hi,
    Are the users using the same windows system? What system version?
    In my experience, the similar problem may happen on windows 10, if that is the case, you could have a try deleting the following file and then log off/log on Windows 10 to see if it helps:
    In addition, if a GPO is not applying, you could check the following article for common reasons to try troubleshooting:
    10 Common Problems Causing Group Policy To Not Apply
    Best regards,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, February 27, 2017 9:16 AM
  • Dear Avi Yadav,

    Some of the workstations where wallpaper not getting applied, may be the "Active Desktop" has not been enabled on the workstations.

    You need to enable the setting under the path from GPO,

    User Configuration\AdministrativeTemplates\Desktop\Active Desktop

    "show web content on my active desktop"


    Syed Abdul Kadar M.

    Dont forget to mark as Answered if you found this post helpful.

    Monday, February 27, 2017 1:17 PM
  • Hi,

    Was your issue resolved? If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions. If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, March 3, 2017 6:51 AM