none
Unable to add a SharePoint-app to a site collection from the App Catalog

    Question

  • Hi!

    We have created a SharePoint-app and have installed it successfully in many O365+SP environments. However, we have encountered a problem in two O365 environments. In those cases we are able to add the SP app to the App Catalog normally, but we are unable to add it to any site collections, as the app is not shown when we try to add an app from site contents.

    The account we use is the owner of the App Catalog and site collection admin. We have tried removing the app and adding it again to the App Catalog, but this does not help.

    Has anyone else encountered this problem, and how have you solved it?


    Wednesday, April 27, 2016 12:25 PM

All replies

  • Hi Eetu,

    Please refer the below page 

    http://www.edinkapic.com/2015/03/sharepoint-app-missing-from-your-apps.html 


    Thanks, Kaviya (Please remember to click “Mark as Answer” on the post that helps you) Blog:

    Friday, May 6, 2016 7:30 AM
  • Hi,

    As explained in the original post, the person who tries to add the app, is both site collection admin and owner/admin of the App Catalog. I assume that the owner/admin of the App Catalog does always have read permission to the App Catalog.


    Monday, May 9, 2016 7:34 AM