locked
Visual Studio 2010 RRS feed

  • Question

  • Hi,

     Did any body got success in sequencing the Visual Studio 2010 (Pro & Ultimate), I have followed the receipe which is present in Technet , but i m getting the error in shortcut launch stating that " Cannot find One or More Components ,please reinstall the application", 

    what could be done to resolve this ?


    CBERV

    Monday, October 29, 2012 10:33 AM

Answers

  • Hello,

    I would recommend to have all VC++ installed natively on both client and sequencer

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, November 1, 2012 8:39 PM
  • You are missing a prerequisite, it needs to be installed on the clients. But as I don't have access to our prod-environment for the moment, I'm not sure what it was ..

    Ahaa, copy/paste from the recipe .. did you installed .Net 4.0 FULL with the 2468871 Update?

    On the App-V Client

    Be sure to complete the following steps on all App-V Clients to which the sequencing will be deployed.

    1.       Install Microsoft .NET Framework 4 Full Profile.  Using Microsoft Update, install all updates for Windows and .NET Framework.
    2.       Make sure that the following update was installed by Microsoft Update.  If not, install it manually.  2468871 Update for the .NET Framework 4
    3.       Run services.msc and disable the Windows Presentation Foundation Font Cache service.

     

    Monday, November 5, 2012 1:44 PM

All replies

  • Hello,

    I haven't received that error at all - have you ensured that the technical requirements are fulfilled?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, October 29, 2012 10:47 AM
  • ya ,, i m sure i didnt missed anyting which is discussed in the receipe.

    CBERV

    Monday, October 29, 2012 10:54 AM
  • Hello,

    Sounds great - if there wasn't any missed step I suggest you use Process Monitor to identify what happens in the background

    Nicke Källén | The Knack| Twitter: @Znackattack

    • Proposed as answer by QRQ Wednesday, October 31, 2012 5:30 PM
    • Unproposed as answer by QRQ Wednesday, October 31, 2012 5:30 PM
    Monday, October 29, 2012 12:47 PM
  • Can you check the parse items of your sequencer and see to that you do not have anything related item there where the application puts the files. If there is one please remove from the parse item and then re sequnce the application?

    QRQ

    Wednesday, October 31, 2012 5:32 PM
  • Hi,

      I have checked the parse items and exclusion items. When i install the Applications its installing VC Runtime 9.0 (X86),VC Runtime 10.0 (x86 &x64), As per the receipe i m excluding the share point tools and SQL Server installation. Will i need to exclude also VC runtime also here.

    Note ::  my sequencer build contains the VC++ Redistributable 2005 & 2008 (x86&x64 ) Versions.



    CBERV

    Thursday, November 1, 2012 11:19 AM
  • Hello,

    I would recommend to have all VC++ installed natively on both client and sequencer

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, November 1, 2012 8:39 PM
  • You are missing a prerequisite, it needs to be installed on the clients. But as I don't have access to our prod-environment for the moment, I'm not sure what it was ..

    Ahaa, copy/paste from the recipe .. did you installed .Net 4.0 FULL with the 2468871 Update?

    On the App-V Client

    Be sure to complete the following steps on all App-V Clients to which the sequencing will be deployed.

    1.       Install Microsoft .NET Framework 4 Full Profile.  Using Microsoft Update, install all updates for Windows and .NET Framework.
    2.       Make sure that the following update was installed by Microsoft Update.  If not, install it manually.  2468871 Update for the .NET Framework 4
    3.       Run services.msc and disable the Windows Presentation Foundation Font Cache service.

     

    Monday, November 5, 2012 1:44 PM