locked
Destination Folder Access Denied - Copying File to the root of C:\ RRS feed

  • Question

  • Hello,

    This is my first post here so excuse me on my etiquette.

    I have recently made a new serveron my domain and all I did was copy the permissions created on a server like I have done in the past to save time. Only this time I am not able to copy any files from anywhere to the root of the C:/ drive without getting an annoying popup looking for extra elevation. Now I have set UAC to the most minimum settings and have
    logged in using my administrative credentials yet the problem still persists. It is not only me that this is affecting my manager and a co-worker are all having the same issue.<o:p></o:p>

    After we allow the elevation to go through it explicitly adds my user account to the file created or copied. We are wondering what the cause of this and how to resolve it.

    many thanks in advance


    Tuesday, May 22, 2012 8:57 PM

Answers

  • Hi Eddie,

    Thank you for the post.

    Yes, UAC feature cause the elevation prompt when you copy files to drive C root folder.
    To disable UAC via group policy:
    1. Run gpedit.msc, navigate and browse to Computer Configuration--Windows Settings--Security Settings--Local Policies--Security Options
    2. Set policy User Account Control: Behavior of the elevation prompt for administrators – Elevate without prompting
    3. Set policy User Account Control: Detect application installations and prompt for elevation – Disabled
    4. Set policy User Account Control: Run all administrators in Admin Approval Mode – Disabled

    The workaround is to use the Built-in Administrator account to operate or copy file to drive C subfolder instead of root folder.

    If there are more inquiries on this issue, please feel free to let us know.

    Regards


    Rick Tan

    TechNet Community Support

    • Marked as answer by Rick Tan Tuesday, May 29, 2012 1:46 AM
    Friday, May 25, 2012 4:35 AM

All replies

  • You can start command prompt with elevated rights one times and do all changes from command line and close command prompt.

    Regards

    Milos

    Tuesday, May 22, 2012 9:02 PM
  • I realize that but it doesn't fix the issue at hand. If you would have read the above post you would have noticed I am trying to find out why I cannot make a new text document in the root of my C:\ and why I cannot copy a simple text file from desktop to my c:\ drive without being further elevated. 

    Tuesday, May 22, 2012 9:11 PM
  • Does anybody know if this is a UAC prompt, if it is a UAC prompt is there away for me to turn it off using Group Policies?

    Also after I allow elevation windows automatically adds me to the security permissions on the file I have copied. There should be no reason that it needs to add me to the folder with my account because I am already logged on to the server with full administrative credentials.
    This is really bizarre.

    Tuesday, May 22, 2012 10:09 PM
  • When I copy remotely from a diffrent computer via Command Prompt no problem. When I try to copy to this computer from another locally on command line I get access is denied! Which makes no sence at all. I have been playing with group policies concerning UAC to see if I could make it so no elevated prompts come up and still nothing. Does anyone know if there was a security update that locked the C:\ drive?

    Thursday, May 24, 2012 5:42 PM
  • Hi Eddie,

    Thank you for the post.

    Yes, UAC feature cause the elevation prompt when you copy files to drive C root folder.
    To disable UAC via group policy:
    1. Run gpedit.msc, navigate and browse to Computer Configuration--Windows Settings--Security Settings--Local Policies--Security Options
    2. Set policy User Account Control: Behavior of the elevation prompt for administrators – Elevate without prompting
    3. Set policy User Account Control: Detect application installations and prompt for elevation – Disabled
    4. Set policy User Account Control: Run all administrators in Admin Approval Mode – Disabled

    The workaround is to use the Built-in Administrator account to operate or copy file to drive C subfolder instead of root folder.

    If there are more inquiries on this issue, please feel free to let us know.

    Regards


    Rick Tan

    TechNet Community Support

    • Marked as answer by Rick Tan Tuesday, May 29, 2012 1:46 AM
    Friday, May 25, 2012 4:35 AM