locked
Remote Desktop Connection has stopped working, windows 8 RRS feed

  • Question

  • Recently I noticed that remote desktop connection stopped working while using vpn.

    mstsc dies with "remote desktop connection has stopped working".

    On application log I have error:

    Faulting application name: mstsc.exe, version: 6.2.9200.16465, time stamp: 0x50b422f2

    Faulting module name: DUI70.dll, version: 6.2.9200.16384, time stamp: 0x50108e6a

    Exception code: 0xc0000005

    Fault offset: 0x00000000000027ee

    Faulting process ID: 0x13218

    Faulting application start time: 0x01ce10bceb4bdf92

    Faulting application path: C:\WINDOWS\system32\mstsc.exe

    Faulting module path: C:\WINDOWS\system32\DUI70.dll

    Report ID: 29449643-7cb0-11e2-be7d-00261898b356

    Faulting package full name:

    Faulting package-relative application ID:

    and information event:

    Fault bucket 90583939, type 4

    Event Name: APPCRASH

    Response: Not available

    Cab Id: 0

    Problem signature:

    P1: mstsc.exe

    P2: 6.2.9200.16465

    P3: 50b422f2

    P4: DUI70.dll

    P5: 6.2.9200.16384

    P6: 50108e6a

    P7: c0000005

    P8: 00000000000027ee

    P9:

    P10:

    Attached files:

    C:\Users\XXX\AppData\Local\Temp\WER3137.tmp.WERInternalMetadata.xml

    These files may be available here:

    C:\Users\XXX\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_mstsc.exe_2f4a5abdd6baaf1173ea159fb7946fd4571972_15ce3877

    Analysis symbol:

    Rechecking for solution: 0

    Report ID: df9d3e2f-7caf-11e2-be7d-00261898b356

    Report Status: 17

    I'll have session both to default port 3389 and fixed port 9833. I have set to firewall both application mstsc

    as allowed and also tcp ports.

    Friday, February 22, 2013 6:00 AM

All replies

  • Download this file from my Dropbox

    https://www.dropbox.com/s/v81q3got2ts52x6/WER_remoteDesktop_full.reg

    and import it. It generates dump of the crashing Remote Desktop Connection into the folder C:\localdump. Compress the dump as zip/rar or 7z and uplaod the compressed file to your Skydrive/dropbox and post a link here.


    "A programmer is just a tool which converts caffeine into code"

    Friday, February 22, 2013 6:18 AM
    Answerer
  • I just went through a similar issue, I wrote about it here.  Your mileage may vary, but check your print drivers.  try not redirecting your printers, or read how I traced the issue.

    Although your error seems to deal with the DirectX systems. If you have a dell or brand name computer go to their support site, and updated all your Video, Audio, and BIOS.  You mentioned VPN, what client?  Is it supported on Windows 8.  Almost willing to bet that will resolve your issue

    http://adminontherun.blogspot.com/2013/02/why-i-dislike-printer-drivers-in-windows.html


    Peter D. Wood EDTS, LLC. http://www.edtsolutions.com Views expressed are mine and do not necessarily represent those of EDTS, LLC, or its clients.


    • Edited by Peter D. Wood Sunday, February 24, 2013 4:01 AM added inrormation.
    Sunday, February 24, 2013 3:48 AM
  • Here's link  skydrive.live.com/redir?resid=DEEA1E465A6F6262!374 for  mstsc dump.

    I noticed that i can take rdp sessions to Windows 2003 terminal servers but not to Windows 2008(R2) servers.

    Uninstalled all printers and still get this "remote desktop stopped working" when trying to connect to 2008 servers.

    add https:// for link, some reason I cannot post link, I got "your account needs to be verified" error.

    Sunday, February 24, 2013 10:58 AM
  • Trying with Cisco AnyConnect Secure Mobility client and Shrew Soft vpn client.

    Both stopped working at same time.

    Sunday, February 24, 2013 11:11 AM
  • that's what happened with me and my printer... 2k3 was fine but not 2008 or higher 

    What model of machine do you have?  As I mentioned the dui70.dll is part of directX,  Chances of if being the vpn clients are meh.  https://skydrive.live.com/redir?resid=F99F34C737E3EFF1!233&authkey=!AD8LaMfiEigUNS0 try posting those minidumps here.    I'll take a look at them.


    Peter D. Wood EDTS, LLC. http://www.edtsolutions.com Views expressed are mine and do not necessarily represent those of EDTS, LLC, or its clients.

    Sunday, February 24, 2013 3:40 PM
  • I can't download the dumps. I always get a skydrive error. upload it to a fast 1 click hoster like RS.com, zippyshare.com or http://rghost.net.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, February 24, 2013 7:29 PM
    Answerer
  • I uploaded those to yours skydrive share that you ceated also..

    Sunday, February 24, 2013 7:46 PM
  • I can't download from skydrive. There seams to be an issue. upload the dump file somewhere else.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, February 24, 2013 7:53 PM
    Answerer
  • unforunately the dump isn't really helping me, since for some reason the dll list is corrupt and wouldn't let me view your loaded DLLS.

    please download http://download.microsoft.com/download/B/B/1/BB139FCB-4AAC-4FE5-A579-30B0BD915706/mpsreports_x64.exe

    install it and run it with the Select general info only for now, at the end, save teh results to your desktop and upload to the same shared skydrive link.


    Peter D. Wood EDTS, LLC. http://www.edtsolutions.com Views expressed are mine and do not necessarily represent those of EDTS, LLC, or its clients.


    • Edited by Peter D. Wood Monday, February 25, 2013 2:55 AM updated instructions.
    Monday, February 25, 2013 2:46 AM
  • Did you guys get anywhere with this or have any info? I'm stuck in the same boat. I tried reading the dmp's and it looks like its all related to system DLL's that handle logins and credentials. I've made it my goal to figure this out and I keep hitting dead ends. There's not even a spot to report a bug I can find.

    Any info would be great, thanks.

    Saturday, June 1, 2013 5:55 PM
  • Further proof it's something with credentials/authentication. I found a valid workaround, but I think this one's on Microsoft to actually fix.

    I opened up Remote Desktop Connection, put in my username and clicked the Save Credentials box. Then I edited all the other settings. Saved the RDP connection to my desktop. Then I edited it with notepad, and added the password value. I found a blog that provides a program that'll hash the password for you. I used it so I can say its safe:

    http://www.remkoweijnen.nl/blog/2007/10/18/how-rdp-passwords-are-encrypted/

    I put the hashed password in, saved the file. Then used it to connect and it worked. So by bypassing RDP having to ask for credentials, it didn't crash when it asks. Kind of inconvenient if you have many computers you have to connect in to. But for those in a bind this will work for you.

    Saturday, June 1, 2013 7:17 PM
  • upload the dmp, maybe I can see more details.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, June 2, 2013 6:40 AM
    Answerer
  • Maybe you tried to disabe the autologin last user account in windows 8?

    "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVerision\Authentication\LogonUI\UserSwitch  Enabled=1"

    I had the same problems when i was messing around with this, when logged on this value should be 0.

    • Proposed as answer by Mottigen Das Tuesday, September 16, 2014 6:39 AM
    Saturday, June 15, 2013 12:14 AM
  • In my case, the problem was a file named "bdmpega64.acm", which is an A/V codec that is included with the Bandicam software, as well as many video games. I still haven't determined which software included this codec, or how to remove it without causing problems, but this file is indeed the source of my RD crashing. Disabling sound in the RD connection eliminates the crashing.

    Thanks to Andre.Ziegler's debugging work in the related thread: Remote Desktop connection has stopped working" problem in Windows 8, Please help me!

    • Edited by GeraldCough Thursday, November 14, 2013 2:44 PM
    Friday, September 27, 2013 8:25 PM
  • Hi, I got the same problem with Win 8.1. I tried to connect without sharing printers,but it still crashes, here is my log:

    https://www.dropbox.com/s/s2hscjdg4bmqz0q/mstsc.exe.4464.dmp

    Friday, October 25, 2013 9:00 PM
  • you have issues with the credentials (authui!CCredUI::CredUIPromptForWindowsCredentialsW):

    0e dui70!DirectUI::Element::SetLayoutPos
    0f authui!`Microsoft::WRL::Module<1,Microsoft::WRL::Details::DefaultModule<1> >::Create'::`2'::`dynamic atexit destructor for 'module''
    10 authui!UserList::UIJobEvent
    11 authui!CCredDialog::UIJobEvent
    12 authui!CEnumerationSyncReplyJob::DeferredExecute
    13 authui!CDeferredUIThreadJob::Do
    14 authui!CJobQueue<IUIJobEvent * __ptr64>::DoJob
    15 authui!CCredentialJobQueue::HandleMessage
    16 authui!CCredDialog::DialogProc
    17 authui!CCredDialog::s_DialogProc
    18 user32!UserCallDlgProcCheckWow
    19 user32!DefDlgProcWorker
    1a user32!DefDlgProcW
    1b user32!UserCallWinProcCheckWow
    1c user32!DispatchMessageWorker
    1d user32!IsDialogMessageW
    1e user32!DialogBox2
    1f user32!InternalDialogBox
    20 user32!DialogBoxIndirectParamAorW
    21 user32!DialogBoxIndirectParamW
    22 authui!CCredDialog::Dialog
    23 authui!CCredUI::CredUIPromptForWindowsCredentialsW
    24 credui!CredUIPromptForWindowsCredentialsWorker
    25 credui!CredUIPromptForWindowsCredentialsW
    26 mstscax!CTscCredentialsQueryUi::PromptForCredentialsNew
    27 mstscax!CTscCredsAssistant::PromptForTsCredentials
    28 mstscax!CTscCredsAssistant::AcquireTsCredentials
    29 mstscax!CTscCredsAssistant::OnSecurityLayerNegotiationComplete
    2a mstscax!CUI::OnSecurityLayerNegotiationComplete
    2b mstscax!CTSMsg::Invoke
    2c mstscax!CTSThread::RunQueueEvent
    2d mstscax!CTSThread::RunAllQueueEvents
    2e mstscax!CTSThread::OnNotifyThreadEventQueue
    2f mstscax!CTSThread::OnNotifyThreadMessage
    30 mstscax!PAL_System_Win32_ThreadWndProc
    31 user32!UserCallWinProcCheckWow
    32 user32!DispatchMessageWorker
    33 user32!DialogBox2
    34 user32!InternalDialogBox
    35 user32!DialogBoxIndirectParamAorW
    36 user32!DialogBoxParamW
    37 mstsc!CDlgBase::CreateModalDialog
    38 mstsc!CDlgBase::DoModal
    39 mstsc!CDefaultContWndExt::OnConnectionIssued
    3a mstsc!CContainerWnd::StartConnection
    3b mstsc!CMainDlg::DialogBoxProc
    3c mstsc!CMainDlg::StaticDialogBoxProc
    3d user32!UserCallDlgProcCheckWow
    3e user32!DefDlgProcWorker
    3f user32!DefDlgProcW
    40 user32!UserCallWinProcCheckWow
    41 user32!SendMessageWorker
    42 user32!SendMessageW
    43 user32!IsDialogMessageW
    44 mstsc!TSCMain
    45 mstsc!WinMain
    46 mstsc!WinMainCRTStartup
    47 kernel32!BaseThreadInitThunk
    48 ntdll!RtlUserThreadStart
    

    I saw a similar crash for Explorer and the Answer from MS is they know about the crash and will fix it after Win8.1 GA. So check for updates in November patchday and hope it is fixed.

    Also try the workaround from Stefhan_. This string is also shown in your dump.


    "A programmer is just a tool which converts caffeine into code"

    Saturday, October 26, 2013 6:43 AM
    Answerer
  • This solved the issue for me, thanks for the tip!
    Tuesday, September 16, 2014 6:38 AM
  • Unchecking the option to use my printers in the remote connection fixed the crash for me. I'm on windows 8.1 and was connecting to Windows Server 2008 R2.
    Friday, January 23, 2015 9:55 PM
  • This solved the issue for me, great tip!!
    Tuesday, February 24, 2015 11:21 AM